文档库

最新最全的文档下载
当前位置:文档库 > Vericut 基础教程-构建机床、程序原点、刀具设置、宏程序仿真 by ljg

Vericut 基础教程-构建机床、程序原点、刀具设置、宏程序仿真 by ljg

Vericut 基础培训一构建三轴机床、仿真宏程序

Vericut 基础培训1

——构建三轴机床,仿真宏程序

作者:LJG

使用Vericut仿真,必须包含毛坯、数控程序、刀具三个部分,但为了仿真的准确性和真实性,我们还需要机床、夹具用于仿真碰撞,设计模型用于比对仿真结果的正确性等。

这一章我们从基本的三轴机床构建讲起。

在Vericut里有两种方法构建机床,一种是通过Vericut自带的简单建模工具建立机床模型,另外一种是使用其它CAD软件先建立好机床模型,再将机床模型文件导出为Vericut可以接受的文件格式,再导入Vericut。用Vericut自带的建模工具建立机床模型比较麻烦,这里我们用第二中方法,利用NX将建好的机床模型文件导出为.STL 格式文件,并导入Vericut用以构建三轴机床。

一、从NX输出机床模型

从论坛http://www.wendangku.net/doc/048dc8234b35eefdc8d33367.html上下载机床模型文件,用NX6打开,如下图1所示。

Vericut 基础教程-构建机床、程序原点、刀具设置、宏程序仿真 by ljg

图 1

一般像机床外壳,控制系统操作面板等实际仿真过程中不需要的部件可以不导出,不过在Vericut里导入不参与仿真的部件可以增加机床的真实感。这里我们不导出机床外壳,控制系统操作面板这两个部件,将这两个部件隐藏如图2所示。

Vericut 基础教程-构建机床、程序原点、刀具设置、宏程序仿真 by ljg

图 2

将不用的部件隐藏后,我们可以看见如图3所示的主轴端面的坐标系。

Vericut 基础教程-构建机床、程序原点、刀具设置、宏程序仿真 by ljg

图 3

在机床建模的时候,我们一般会按照机床的机械零点位置来建立各个机床运动部件的模型,而机床的Z轴的机械原点一般在主轴端面,如图3所示。但从这个机床模型可以看出X、Y轴的位置并不在机械原点,所以我们导出后还要在Vericut里进行调整。

下面先输入机床床身,即在仿真过程中不运动的部件。选择主菜单File > Export >STL…,弹出Rapid Prototyping对话框,这里可以设置输出模型的公差,公差的大小会影响STL文件的大小,不改变参数,单击OK,在弹出的对话框中输入要保存的文件名,输入Based_Y,双击鼠标中键(单击两次OK),选择绿色的底座和导轨,如图4所示的高亮显示部件,选择完成后所有弹出的窗口,都选择OK。

Vericut 基础教程-构建机床、程序原点、刀具设置、宏程序仿真 by ljg

图4

用相同的方法输出Based_Z部件,如图5所示。

Vericut 基础教程-构建机床、程序原点、刀具设置、宏程序仿真 by ljg

图5

输出Z部件,如图6所示。

Vericut 基础教程-构建机床、程序原点、刀具设置、宏程序仿真 by ljg

图6

输出Y部件,如图7所示。

Vericut 基础教程-构建机床、程序原点、刀具设置、宏程序仿真 by ljg

图7

输出X部件,如图8所示。

Vericut 基础教程-构建机床、程序原点、刀具设置、宏程序仿真 by ljg

图8

输出Spindle部件,如图9所示。

Vericut 基础教程-构建机床、程序原点、刀具设置、宏程序仿真 by ljg

图9

我们在输出模型的时候可以将相同的运动部件分开输出,如上面输出X轴运动部件时可以将导轨滑块和工作台分开输出,这样导入Vericut后可以针对不同STL模型文件定义不同颜色,使仿真的机床在视觉上更接近于真实机床。

完成输出机床模型后,接下来将输出的模型导入Vericut。

二、在Vericut中建立机床模型

1、新建一个公制项目文件(HARDINGE_VMC1000II.vcproject)

●运行Vericut6.2。

●选择File > New Project > Millimeter ( 或选择工具条上按钮),新建项目文

件。

●选择工具条上按钮设置你的工作路径,例如:E:\HARDINGE_VMC1000II。

●选择File > Save as...菜单命令,。

●在Shortcut下拉列表框中选择E:\HARDINGE_VMC1000II,进入用户自定义

路径。

●在File文本框输入HARDINGE_VMC1000II,单击Save,将新建项目文件保

存在用户自定义目录下。

工具条上新建项目文件的快捷命令:(Inch:英制)或 (Millimeter:公制)。右键在该图标上单击可以在两种模式来回切换。

2、定义机床运动结构

(1) 显示部件树

●将刚才导出的机床模型文件拷贝到用户目录E:\HARDINGE_VMC1000II下。

●在主菜单中,选择Configuration > Component Tree ( 或选择工具条按钮),

系统弹出Component Tree窗口,如图2所示。

Vericut 基础教程-构建机床、程序原点、刀具设置、宏程序仿真 by ljg

图 10

(2) 定义“Base”部件

●在图形区,单击右键,选择弹出菜单View Type > Machine,切换到机床视图。

●在Component Tree (部件树)中,选择节点,双击,弹出Modeling

窗口,进行部件或模型相关参数定义。

●选择Model标签。

●在Type下拉列表框中选择 Model File 选项。

●单击Browse…按钮。

●在Shortcut下拉列表框中选择E:\HARDINGE_VMC1000II选项,进入用户自

定义路径。

●在文件下拉列表框中选择Base_y.stl文件。

●单击Open按钮。

●在Modeling窗口中,从Color下拉列表框中选择28:Dodger Blue 。

●单击Add按钮,将该文件添加到Base节点下。

按照上述步骤将Base_z.stl文件添加到Base部件节点下,对应Color选项: 10:Beige。如图11所示。

Vericut 基础教程-构建机床、程序原点、刀具设置、宏程序仿真 by ljg

Vericut 基础教程-构建机床、程序原点、刀具设置、宏程序仿真 by ljg

图 11

一般,我们把机床中不运动,不参与仿真的部件模型放在Based根节点下。

(3) 定义“Z”线性轴

●在Component Tree中,选择节点。

●右击节点,从弹出菜单中选择Append > Z Linear。

●双击,进入Modeling窗口定义Z轴速度和颜色。(后面如果没有特

别说明,都是选择节点,双击进入Modeling窗口)

●在Component Attribute标签中,在Rapid Rate文本框输入Z轴快速定位(G00)

的进给率(units/min):30000。

●在Accel/Decel下,Max Feed Velocity (units/min)文本框输入进给状态(G01、

G02/3)的进给率:12000。

下面添加Z1轴的部件模型。

●选择Modeling窗口的Model标签,添加用户自定义目录E:\

HARDINGE_VMC1000II里的Z.stl,颜色 7:White。(后面如果没有特别说明,

都是从该目录添加模型)

●添加完成“Z”轴部件模型,如图4所示。

Vericut 基础教程-构建机床、程序原点、刀具设置、宏程序仿真 by ljg

Vericut 基础教程-构建机床、程序原点、刀具设置、宏程序仿真 by ljg

图 12

每定义好一个运动轴,可以通过MDI功能检查设置运动轴的运动方向是否与机床实际运动方向相同。

Vericut 基础教程-构建机床、程序原点、刀具设置、宏程序仿真 by ljg

工具条上,左键单击按钮,弹出MDI窗口,在Axis下拉列表框选择已定义好的运动轴,在Jog Distance文本框输入运动步距。如图13所示。

Vericut 基础教程-构建机床、程序原点、刀具设置、宏程序仿真 by ljg

图 13

(4) 定义“Spindle”刀具轴

●在Component Tree中,节点下添加。

添加Tool Spindle S3的部件模型。

●通过Modeling窗口,添加Spindle.stl, 颜色3:Light Steel Blue。

添加完成“Spindle”部件模型,如图14所示。

Vericut 基础教程-构建机床、程序原点、刀具设置、宏程序仿真 by ljg

Vericut 基础教程-构建机床、程序原点、刀具设置、宏程序仿真 by ljg

图 14

(5) 定义刀具换刀点(Gage Point)

●在Component Tree中,节点下添加。

添加完成Tool换刀点,如图15所示。

Vericut 基础教程-构建机床、程序原点、刀具设置、宏程序仿真 by ljg

图 15

现在我们完成所有Z轴运动部件的定义,如果我们仿真的时候不需要机床,那么只用定义机床运动结构的节点,不需要在节点下添加机床的实体模型。

(6) 定义“Y”线性轴

●在Component Tree中,节点下添加。

●进入Modeling窗口,Component Attribute标签中,在Rapid Rate文本框输入

Y轴快速定位(G00)的进给率(units/min):30000。

●在Accel/Decel下,Max Feed Velocity (units/min)文本框输入进给状态(G01、

G02/3)的进给率:12000。

添加Y1轴的部件模型。

●选择Modeling窗口的Model标签,添加Y.stl, 颜色12:Dart Turquoise。

因为在NX里的建模坐标系不在机床机械原点,在仿真过程中我们需要超程报警,所以我们导入的机床必需设置好机床机械原点,该机床的行程是X1020*Y510*Z410,下面将Y轴部件移动到机械原点。

●选择Modeling窗口的Positiion标签,注意在该窗口的上面在Selected复选框

选择Components,这样我们在移动时,是移动整个部件,而不是移动一个模

型。在Translate标签下Position文本框输入: 0 -255 0 (数字之间用空格分开),

表示将Y轴部件移动X0,Y-255,Z0的距离,如图16所示。

Vericut 基础教程-构建机床、程序原点、刀具设置、宏程序仿真 by ljg

Vericut 基础教程-构建机床、程序原点、刀具设置、宏程序仿真 by ljg

图 16

Vericut里面有许多坐标系,如部件坐标系、模型坐标系、机床坐标系、工件坐标系、用户自定义坐标系等,但对构建机床运动结构影响最大的是部件坐标系(Component)。当新建一个Vericut项目文件的时候,Vericut所有的坐标系都是在一个位置。注意看上图中每个节点后面括号里的参数值,里面的数值就是该组件坐标系原点相对于上一级父节点组件坐标系的距离,对于旋转轴,每个旋转轴都是绕自己的组件坐标系来旋转的。

在平移,旋转坐标系的时候,要注意选择对象,即在Modeling窗口上面的Selected 的复选框选项,如果是Model,移动的只是一个模型文件,如果是Components,移动的是组件,包括这个组件节点下的所有节点都会相应的移动,Selected选项如图17所示。

Vericut 基础教程-构建机床、程序原点、刀具设置、宏程序仿真 by ljg

图 17

(7) 定义“X”线性轴

Vericut 基础教程-构建机床、程序原点、刀具设置、宏程序仿真 by ljg

在Component Tree中,节点下添加。

●在Modeling窗口,Component Attribute标签中,在Rapid Rate文本框输入X

轴快速定位(G00)的进给率(units/min):30000。

●在Accel/Decel下,Max Feed Velocity (units/min)文本框输入进给状态(G01、

G02/3)的进给率:12000。

●选择Model标签,添加X.stl, 颜色3:Light Steel Blue。

●选择Position标签,注意在该窗口的上面在Selected复选框选择Components,

在Translate标签下Position文本框输入: -510 0 0,移动X组件到机械原点。

如图18所示。

Vericut 基础教程-构建机床、程序原点、刀具设置、宏程序仿真 by ljg

图18

(13) 移动“Attach”部件

●在Component Tree中,选择节点。

●右击,从弹出菜单选择命令。

Vericut 基础教程-构建机床、程序原点、刀具设置、宏程序仿真 by ljg

●在部件树中,选择,右击,从弹出菜单选择命令,将

Vericut 基础教程-构建机床、程序原点、刀具设置、宏程序仿真 by ljg

粘贴到节点下,如图19所示。

Vericut 基础教程-构建机床、程序原点、刀具设置、宏程序仿真 by ljg

图 19

要更改部件树中的节点位置,可以选择要更改的节点再拖动到想要更改的节点位置下。

(14) 移动“Stock”部件坐标系

展开Attach节点,选中Stock节点,可以看到Stock组件坐标系与X组件坐标系是在同一位置,这就意味着我们建立的或输入的毛坯文件的原点会在这个坐标原点上,所以我们需要将Stock的部件坐标系移动到工作台面。

●在组件树中选择Stock节点。

●进入Modeling窗口,选择Position标签页,在Translate标签下Position文本

框输入: 0 0 -510,坐标系移动后如图20所示。

Vericut 基础教程-构建机床、程序原点、刀具设置、宏程序仿真 by ljg

图 20

3、机床设置

机床运动结构定义完成后,需要对机床进行初始化设置,如机床干涉检查、机床初始化位置、机床行程等。这些参数一般可以从机床厂家得到,如果没有这些参数可以自己实际操作,测量出这些数据。

菜单栏Configuration > Maching Setting…,打开Machine Settings窗口,如图30所示。

Vericut 基础教程-构建机床、程序原点、刀具设置、宏程序仿真 by ljg

图 21

(1) 机床干涉检查设置

●确定已勾选Machine Simulation On复选框。

●在Collision Detect标签页,勾选Collision Detection复选框。

●在Ignore Collision between Cutter and Stock下拉列表框选择No。

●在Default Near Miss输入1,单击右侧按钮,这个参数用于设置两部件

件碰撞检查的最小距离。

●添加如图22所示的部件干涉设置。

Vericut 基础教程-构建机床、程序原点、刀具设置、宏程序仿真 by ljg

图 22

如果设置干涉检查时如图23所示。

Vericut 基础教程-构建机床、程序原点、刀具设置、宏程序仿真 by ljg

图 23

在仿真时,Vericut将检查Y轴组件以及关联部件(夹具、毛坯)和Z线性轴以及关联部件(主轴、刀具)是否会产生碰撞,这种方法可以检查全部可能发生碰撞的部件,但会降低仿真速度。而设置成图22所示的部件干涉检查时,Vericut仿真时只会检查在列表当中存在的两个部件间的碰撞。所以设置干涉检查尽量不选用Sub-Components,而对会产生干涉的部件和其子部件分别设置,这样可以提高仿真速度。

(2) 机床初始化位置设置

●在Machine Settings窗口里,选择Tables标签页,单击按钮,弹出

Add/Modify Machine Table窗口。

●在Table Name下拉列表框选择Initial Machine Location。

●在SubSystem ID下拉列表框选择1。

●在Values(XYZABCUVWABC)文本框输入:X-510 Y-255 Z0,设置机床的初始

位置。

(3) 机床行程设置

●在Machine Settings窗口里,选择Travel Limits标签页。

●勾选Log Error for Over Travel 和Allow Motion Beyond Limit复选框。

●列表框设置内容如图24所示。

Vericut 基础教程-构建机床、程序原点、刀具设置、宏程序仿真 by ljg

图 24

剩下的运动轴优先级按默认设置即可。

完成机床初始化设置。

4、定义控制系统

机床初始化定义完成后,需要加载机床的控制系统,在后面的杂志我们会陆续给大家介绍控制系统的定义。这个实例中,我们加载Vericut自带的控制系统fan150im.Ctl。

●在Project树里,右键双击,弹出Open Control…窗口。

●在Shortcut下拉列表框中选择Library,选择fan15im.ctl,单击Open。

添加完成控制系统,机床自动初始化到我们上面定义的初始位置。从Vericut6.2开始Fanuc控制系统已经包含的极坐标指令,之前的版本是没有的。

5、仿真实例

通过上面的步骤我们完成了一台三轴机床的构建,下面我们通过一个实例来具体运用。

再次强调我们仿真所必须的三个条件:刀具、毛坯、程序。

(1) 刀具

这个机床用的是BT40的刀柄,我们将建立一把直径20的铣刀。

●在Project树里,双击,弹出Tool Manager窗口。

●选择菜单命令Add > Tool > New > mill,弹出Tool ID窗口。

●在Tool Component标签页下的Component Type选择Holder,建立刀柄。

●选择Revolve Profile,通过点位新建刀柄模型。

●单击Add添加第一个点位坐标X0,Z-30。

●再分别添加下列14个点位:

X Z

25 -30

25 0

32 0

32 4.81

29 6.42

28 6.42

28 10.25

29 10.25

32 11.86

32 17

22 17

22 20

12 88

0 88

●最后单击Tool ID窗口的Add。

●选择Assembly标签页,在Position文本框输入:0 0 70,将刀柄沿Z轴移动70的

距离。

●添加完成如图25所示。

Vericut 基础教程-构建机床、程序原点、刀具设置、宏程序仿真 by ljg

图 25

●再选择Tool Component标签页,在Component Type选择Revolved Cutter。

●在Diameter(D)文本框输入:20。

●Height(H)文本框输入:70。

●Flute Length文本框输入:40。

●单击Add,关闭该窗口,完成如26图所示。

Vericut 基础教程-构建机床、程序原点、刀具设置、宏程序仿真 by ljg

图 26

刀具定义好了后,还要设置换刀点(Gage point),我们只有设置正确的Gage Point,才能保证刀具换刀到机床的正确位置。

●在Tool Manager窗口单击Gage Point下面的文本框,如图27所示。

Vericut 基础教程-构建机床、程序原点、刀具设置、宏程序仿真 by ljg

图 27

我们注意看Tool Display显示的刀具区域上图中的红圈内的箭头,在Vericut里,当我们激活(右键单击)某些文本框的时候,就会在图形显示区域激活捕捉光标,用于捕捉坐标点。

●将鼠标移动到刀具显示区域,移动鼠标可以看到,箭头会自动捕捉一些坐标

点,将鼠标移动到如图28所示的位置。

Vericut 基础教程-构建机床、程序原点、刀具设置、宏程序仿真 by ljg

图 28

●单击鼠标中键,自动捕捉到这个切面的中心点,在Tool Manager窗口的提示栏

会显示Use Middle Mouse button to set Z-axis only。完成后Gage Point下面的文

本框自动输入捕捉的坐标点的值:0 0 90,如图29所示。

Vericut 基础教程-构建机床、程序原点、刀具设置、宏程序仿真 by ljg

图 29

定义完成后保存新建的刀具文件。

●选择Tool Manager菜单栏File > Save,文件名输入Test,单击Save,然后关闭

Tool Manager窗口,弹出的窗口选Yes。

●选择工具条上的MDI命令,弹出MDI窗口,在这个窗口我们可以调试之前

设置的机床行程,定义的指令等。在窗口最下面的NC Block Entry 文本框输入换刀指令T1 M6,将刚才建立的1号刀具换到机床主轴上,如图30所示。

Vericut 基础教程-构建机床、程序原点、刀具设置、宏程序仿真 by ljg

图 30

(2) 程序

我们将编写一个宏程序加工六方顶面的圆角。

●在用户目录下新建一个文本文档,文件名Test.txt。

●程序内容如下:

%

O0001

( TEST_PROGRAM )

( MACHINE : HARDINGE_VMC1000II )

( CONTROL : FANUC 15I-MB )

( PROGRAMMER : ***************** )

( DATE : MON MAY 11 2009 )

( TIME : 10:04:54 )

( VERSION : 1.0)

( =============================== )

G40 G17 G49 G94 G0 G90 G21 G80

#1=150.

#2=80.

#3=5.

#4=10.

#5=0

#15=0.1

#6=5.

#20=8.

G91 G28 Z0

T1 M6

S2000 M13

G54 G90 G00 X0 Y0

G43 Z200. H1

Z30.

#7=#1/2+#4

#8=#2/2+#4

#9=#6+#4

G00 X#20 Y[-#8-#20]

WHILE [#5 LE 90] DO 1

#11=#7-#3*[1-COS[#5]]

#22=#8-#3*[1-COS[#5]]

#33=#3*[SIN[#5]-1]

#16=#9-#3*[1-COS[#5]]

G00 Z#33

G01 X#20 Y[-#22-#20] F600

G91 G03 X-#20 Y#20 R#20

G90 G01 X-#11,R#16 F1000

Y#22,R#16

X#11,R#16

Y-#22,R#16

X0

G91 G03 X-#20 Y-#20 R#20 F600

G90 G00 X#20

#5=#5+#15

END 1

G00 Z200.

M30

%

●在Project树里,双击,弹出NC Program的窗口。

●单击Add…。

●在Shortcut下拉列表框中选择E:\HARDINGE_VMC1000II选项,进入用户自

定义路径。

●在文件下拉列表框中选择Test.txt文件,单击OK按钮。

●返回NC Program窗口,单击OK按钮。

添加完成程序。

(3) 毛坯

我们将定义一个150*80*200的方块,做为毛坯。