文档库

最新最全的文档下载
当前位置:文档库 > HSRP 的配置方法及实验

HSRP 的配置方法及实验

HSRP 的配置方法

[no] standby [group-number] ip [virtual ip address] 说明:使路由器在指定局域网段加入或退出一个备份组。需要指定备份组号和虚拟IP 地址。备份组号范围从0 到

255,如group-number 不指定,备份组号缺省为0,virtual ip address 如果不指定,路由器不会参与备份,直到从备份组中的活动路由器获得虚拟IP 地址。注意虚拟IP 地

址应该是接口所在网段的地址。一旦退出HSRP 备份组,则路由器在该备份组上设置的所有HSRP 特性不再有效(如优先级,授权字等).

standby [group-number] priority [priority-value] 说明:HSRP 中根据优先级来确定参与备份组的每台路由器的地位,备份组中优先级最大并且已获得虚拟IP 地址的路由器

将成为活动路由器,优先级其次的路由器将成为备份路由器。优先级缺省值是100,可设置范围从0 到255。

standby [group-number] preempt 说明:一旦备份组中的某台路由器成为活动路由器,只要它没有出现故障,其它路由器即使随后被配置更高的优先级,也不会成为活动路由,

除非被设置抢占方式。路由器如果设置抢占方式,它一旦发现自己的优先级比当前的活动路由器的优先级高,就会成为活动路由器。相应地,原活动路由器会退出活动态,成为备

份路由器或其它。缺省方式是不抢占。

standby [group-number] authentication string 说明:HSRP 授权字确认同备份组间其它路由器的有效性。授权字string 的长度不超过8 个字节。注意:同一备份组要设置

相同的授权字。

standby [group-number] timers [hello_time] [hold_time] 说明:HSRP 备份组路由器之间通过定时发送Hello 报文确认相互的状态,超过一定时间(hold time)没有收到某

台路由器的Hello 报文,则认为它已关机或出现故障。用户可以调整发送Hello 报文的间隔时间(hello time)和超时时间(hold time)。缺省值分别是3 秒和10 秒。时间

单位是秒。注意:同一备份组要设置相同的hello time 和hold time。

standby [group-number] track interface_name [priority-reduced] 说明:HSRP 监视接口功能,更好地扩充了备份功能,即不仅在路由器出现故障时提供备份功能,而且在某

网络接口不可用时,也可以使用备份功能。命令作用是监视接口interface_name,如果接口变为不可用,则将优先级减少priority-reduced (priority-reduced 缺省值为10)。

实现多组HSRP实验

实验配置

HSRP 的配置方法及实验

一、外网配置:

配置R1:

Router>en

Router#conf t

Router(config)#hostname R1

R1(config)#int S0

R1(config-if)#ip add 12.1.1.1 255.255.255.252

R1(config-if)#no shut

R1(config-if)#int E0

R1(config-if)#ip add 192.168.10.100 255.255.255.0

R1(config-if)#no shut

R1(config-if)#exit

R1(config)#ip route 0.0.0.0 0.0.0.0 S0

R1#sh run

配置R2:

Router>en

Router#conf t

Router(config)#hostname R2

R2(config)#int S0

R2(config-if)#ip add 12.1.1.2 255.255.255.252 R2(config-if)#no shut

R2(config-if)#clock rate 64000

R2(config-if)#int S1

R2(config-if)#ip add 23.1.1.2 255.255.255.248 R2(config-if)#no shut

R2(config-if)#clock rate 64000

R2(config-if)#end

R2#sh run

配置R3:

Router>en

Router#conf t

Router(config)#hostname R3

R3(config)#int S0

R3(config-if)#ip add 23.1.1.3 255.255.255.248 R3(config-if)#no shut

R3(config-if)#int E0

R3(config-if)#ip add 192.168.20.200 255.255.255.0

R3(config-if)#no shut

R3(config-if)#exit

R3(config)#ip route 0.0.0.0 0.0.0.0 S0

R3#sh run

二、配置NAT:

R1#conf t

R1(config)#access-list 10 permit 192.168.10.0 255.255.255.0

R1(config)#ip nat inside source list 10 interface S0 overload

R1(config)#end

R1#sh run

R3#conf t

R3(config)#access-list 20 permit 192.168.20.0 255.255.255.0

R3(config)#ip nat inside source list 20 interface S0 overload

R3(config)#end

R3#sh run

三、配置HSRP多组负载均衡:

R1#conf t

R1(config)#int E0

R1(config-if)#standby 1 ip add 192.168.10.254 //激活HSRP,设置R1连接的内网的虚拟网关

R1(config-if)#standby 1 priority 120 //用于设定端口的HSRP优先级,具有最高备份优先级的HSRP 成员将成为激活路由器

R1(config-if)#standby 1 preempt //表明当本地路由器的备份优先级超过当前激活路由器时,它就将接管控制权,成为激活路由器

R1(config-if)#standby 1 track serial 0 40 //用于设置允许路由器端口根据另一端口的可用性而修改自己的HSRP优先级值(即监视端口状态)

R1(config-if)#standby use-bia //启用HSRP多组均衡负载

R1(config-if)#standby 2 ip add 192.168.20.254

R1(config-if)#standby 2 prempt

R3#conf t

R3(config)#int E0

R3(config-if)#standby 2 ip add 192.168.20.254 //激活HSRP,设置R3连接的内网的虚拟网关

R3(config-if)#standby 2 priority 120 //用于设定端口的HSRP优先级,具有最高备份优先级的HSRP 成员将成为激活路由器

R3(config-if)#standby 2 preempt //表明当本地路由器的备份优先级超过当前激活路由器时,它就将接管控制权,成为激活路由器

R3(config-if)#standby 2 track serial 0 40 //用于设置允许路由器端口根据另一端口的可用性而修改自己的HSRP优先级值

R3(config-if)#standby use-bia //启用HSRP多组均衡负载

R3(config-if)#standby 1 ip add 192.168.10.254

R3(config-if)#standby 1 prempt

配置PC机:

PC1:设置本地连接的TCP/IP属性:ip:192.168.10.10 掩码:255.255.255.0 网关:192.168.10.254 PC2设置本地连接的TCP/IP属性:ip:192.168.20.20 掩码:255.255.255.0 网关:192.168.20.254

分别在PC1和PC2上ping外网,在R1,R3上分别开启地址转换信息显示和HSRP信息显示,可以观察看你想看到的信息。

实验总结:

1.在一个HSRP组内的多个路由器共用一个虚拟的物理地址和IP地址,该地址被作为局域网内所有主机的缺省网关地址。HSRP协议决定哪个路由器被激活,该被激活的路由器接收发过来的数据包并进行路由。

2.相关命令:

?standby ip: 用于激活HSRP。

?standby priority: 用于设定端口的HSRP优先级,具有最高备份优先级的HSTP成员将成为激活路由器(假设设置为优先权方式)。

? standby timers: 用于设定hello包之间的时间间隔(hello time)以及路由器在多长一个时间段内没有从HSRP邻居收到hello包就判定该邻居已关闭(hold time)。

? standby preempt: 表明当本地路由器的备份优先级超过当前激活路由器时,它就将接管控制权,成为激活路由器。

? standby track: 用于设置允许路由器端口根据另一端口的可用性而修改自己的HSRP优先级值

3.配置HSRP步骤:

①创建虚拟IP,用作内网网关

②抢占线路优先级

③提高组优先级

④监视端口(监视的端口down掉后,自动下降所设的优先级值,默认自动下降10)

4.一个路由器可以同时属于多个HSRP组,该特性允许网络管理员在提供冗余能力的同时对各路由器进行负载平衡。在上图中,两台PC使用不同的缺省网关,主机1以HSRP组1的虚拟IP地址

192.168.10.254为缺省网关,而主机2以组2的虚拟IP地址192.168.20.254为缺省网关。

在正常工作状态下,局域网的数据流量在两台路由器之间均分;一旦发生故障,备份路由器被激活,所有流量被路由至该路由器的端口。上图中的两台路由器均同时属于两个HSRP组,路由器1是组1的激活路由器及组2的备份路由器,路由器3是组2的激活路由器及组1的备份路由器