文档库

最新最全的文档下载
当前位置:文档库 > 网络工程校园网课程设计

网络工程校园网课程设计

网络工程校园网课程设计

网络工程校园网课程设计

网络工程校园网课程设计

《计算机网络课程设计》

课题设计名称:校园网搭建

名字:江惠龙

网络工程校园网课程设计

闽江学院计算机实验教学中心印制

目录

一、校园网概述及分析 (1)

1.1校园网概述 (1)

1.2校园网建设需求 (1)

1.3校园网建设目标 (1)

二、需求分析 (2)

2.1通信需求分析 (2)

2.2校园网技术性能需求分析 (2)

2.2.1网络结构 (2)

2.2.2工作站 (3)

2.2.3网络适配器 (3)

2.2.4路由器 (3)

2.3安全与管理需求分析 (3)

三.校园局域网的设计 (4)

3.1网络核心层设计 (4)

3.2网络汇聚层设计 (4)

3.3网络接入层设计 (4)

四.网络方案设计 (6)

4.1设备要求 (6)

4.2硬件设备 (6)

4.3 ip地址和端口分配 (7)

4.4网络拓扑结构 (9)

4.5设备配置描述 (9)

4.5.1主校区接入层交换机: (9)

4.5.2核心层交换机 (10)

4.5.3主校区路由器配置: (12)

4.5.4分校区路由器 (14)

4.5.5分校区核心交换机 (15)

4.5.6分校区接入层交换机 (15)

4.5.7 DHCP服务器配置 (17)

4.5.8 WEB和DNS服务器配置 (18)

4.5.9 FTP和TFTP服务器配置 (19)

五.设备选型 (22)

5.1网络设备 (22)

5.2服务器设备 (22)

5.3经费预算 (22)

六.技术总结 (24)

一、校园网概述及分析

1.1校园网概述

进入到二十一世纪,伴随信息技术的发展,围绕Internet的技术日渐成熟,信息技术的应用已经渗透到社会生活的各个层面,成为一种生活方式,吸引了社会大众广泛参与。信息技术是当今最具潜力的新兴生产力,已成为衡量一个国家、一个地区生产力发展水平的最重要标志。

随着计算机、通信和多媒体技术的发展,使得网络上的应用更加丰富。同时在多媒体教育和管理等方面的需求,对校园网络也提出进一步的要求。因此需要一个高速的、具有先进性的、可扩展的校园计算机网络以适应当前网络技术发展的趋势并满足学校各方面应用的需要。信息技术的普及教育已经越来越受到人们关注。学校领导、广大师生们已经充分认识到这一点,学校未来的教育方法和手段,将是构筑在教育信息化发展战略之上,通过加大信息网络教育的投入,开展网络化教学,开展教育信息服务和远程教育服务等将成为未来建设的具体内容。

校园网建设的目标简而言之是将校园内各种不同应用的信息资源通过高性能的网络设备相互连接起来,形成校园园区内部的Intranet系统,对外通过路由设备接入广域网。

建设校园网对每个学校来说都不是一件容易的事情,都要经过周密的论证、谨慎的决策和紧张的施工。当一堆设备变成网络的时候,大部分学校的满腔热情也慢慢地冷却凝固。校园网建成了,各种问题也不断涌现:设计目标根本无法实现,没有合适的应用软件,许多设想根本无法实施,后续的维护费用不堪承受等等。

1.2校园网建设需求

(1)主校区5个虚拟局域网(vlan)与分校区的通讯。

(2)特定虚拟局域网(各系与行政楼)间的计算机之间的通讯。

(3)分校区对网络应用服务器(DNS,DHCP,WEB,FTP)进行规划配置。

(4)主校区都能访问应用服务器提供的服务。

1.3校园网建设目标

(1)实现主校区5个虚拟局域网(vlan)与分校区通过运营商建立帧中继通讯。

(2)设计访问控制列表(ACL)实现特定虚拟局域网(各系与行政楼)间的计算机之间的通讯。

(3)实现对分校区网络应用服务器(DNS,DHCP,WEB,FTP)进行规划配置。

(4)实现主校区都能访问应用服务器提供的服务。

(5)实现行政楼无线上网。

(6)实现远程登录方便配置通讯设备

二、需求分析

随着计算机、通信和多媒体技术的发展,使得网络上的应用更加丰富。同时在多媒体教育和管理等方面的需求,对校园网络也提出进一步的要求。因此需要一个高速的、具有先进性的、可扩展的校园计算机网络以适应当前网络技术发展的趋势并满足学校各方面应用的需要。信息技术的普及教育已经越来越受到人们关注。学校领导、广大师生们已经充分认识到这一点,学校未来的教育方法和手段,将是构筑在教育信息化发展战略之上,通过加大信息网络教育的投入,开展网络化教学,开展教育信息服务和远程教育服务等将成为未来建设的具体内容。

网络在日常教学办公环境中起着至关重要的作用,校园网的运作模式会带来大量动态的www应用数据传输,会有相当一部分应用的主服务器有高速接入网络的需求(目前为100/1000Mbps,今后可会更高)。这就要求网络有足够的主干带宽和扩展能力。同时,一些新的应用类型,如网络教学、视频直播/广播等,也对网络提出了支持多点广播和宽带高速接入的要求。

除上述考虑外,还要注意到由于逻辑上业务网和管理网必须分开,所以建成后校园网应能提供多个网段的划分和隔离,并能做到灵活改变配置,以适应教学办公环境的调整和变化。

2.1通信需求分析

(1)通讯要求主校区与分校区能够相互通讯,可以通过动态路由RIP协议,结合帧中继使得全网通讯。

(2)主校区各个虚拟局域网有特定要求,各个虚拟局域网只能与行政楼相互通讯,主校区使用单臂路由让各个虚拟局域网能够相互通讯,再通过制定访问控制列表限制特定的虚拟局域网不能相互访问。

(3)各个虚拟局域网能远程登录各自的接入层交换机,及核心层交换机,路由器。

(4)行政楼装置无线设备,要求实现无线上网。

2.2校园网技术性能需求分析

2.2.1网络结构

在一定程度上和我们采用的网络拓扑结构有关。考虑到学院校区,而且科教楼和综合楼信息点较多,我们采用星型的网络拓扑结构。这样一来不但从布线的成本上可以节省开支,而且骨干链路也实现了冗余。学校将来要重点建设的综合楼系统在这次工程中仅提供了交换机,同时配置了三层交换机。

总体采用星型网络拓扑结构,分为核心,汇聚和接入三层.主干采用千兆以太网接入.核心层。两个中心交换机做核心(双核心叠加2000M),汇聚层是1000M链路。全校所有上网计算机均通过各个楼栋交换机与该区域的汇聚层主交换机链接,区域汇聚层主交换机分别连到两台核心交换机,再通过路由与Internet连接。

根据学校的建筑物的分布,把校园网的主节点放置在图书馆的网络中心,教学区和办公区的使用量很大,但生活区的使用量相对比较小,所以以图书信息楼为核心,主干为千兆以太网向其他大楼辐射,建筑物之间使用多模光纤连接。每幢建筑只需要一个网络服务器。

服务器运行网络操作系统,是整个网络系统的核心,它为网络用户提供服务并管理整个网络。

2.2.2工作站

工作站又称客户机,是用户和网络的接口设备,用户通过它可以与网络交换信息,共享网络资源。当一台计算机连接到局域网上时,这台计算机就成为局域网的一个客户机。客户机通过网卡、通信介质以及通信设备连接到网络服务器。客户机只是一个接入网络的设备,它的接入和离开对网络不会产生多大的影响,它不象服务器那样一旦失效,正在使用这一功能的网络会受到影响,可能会使网络的部分功能无法使用。现在的客户机都用具有一定处理能力的PC(个人计算机)机来承担。

2.2.3网络适配器

它是构成计算机局域网络系统中最基本的、最重要的和必不可少的连接设备,计算机主要通过网卡接入局域网络。网卡的接口类型RJ45、BNC、AUI、SC、ST等。网卡的传输速率主要有10MBPS、100MBPS、1000MBPS、10M/100MBPS、自适应网100M/1000MBPS自适应网卡等几种。

2.2.4路由器

路由器能容易地实现LAN-LAN、WAN-WAN和LAN-WAN-LAN的多种网络连接形式。它最典型的应用在INTERNET上。路由器可以隔离广播分组。

2.3安全与管理需求分析

校园网的主要用户是在校学生,富有好奇心和好胜心的他们在网络环境中有意和无意地尝试各种的网络侵入和攻击,这很容易给校园网带来安全方面的隐患,造成网络瘫痪、非法接入、信息泄漏等严重后果。为了提高校园网的安全性,就需要提升接入网络设备的安全控制功能,满足校园网对用户接入安全控制地需要。

我们采用了一下技术提高校园网的安全:

1.制定相应的访问控制列表。

2.划分虚拟局域网,只有特定的虚拟局域网才能相互通讯。

3.端口mac地址绑定。一旦mac地址与指定的不通,端口就关闭。

三.校园局域网的设计

从逻辑设计的角度来看,大型网络可分为核心层、分布层和接入层,每层都有其特点:

3.1网络核心层设计

大学校园网采用层次化网络拓扑结构,核心层采用两台带有第三层交换模块的千兆以太网交换机。核心交换机之间采用聚合链路(Port TRUNKING),该技术可使交换机之间连接最多四条负载均衡的冗余连接。当两个交换机之间的一条线路出现故障时,传输的数据会快速自动切换到另外一条线路进行传输,以使网络真正具备高容量、无阻塞、可靠的多媒体传输和优质的管理能力,可使千兆以太网交换、快速以太网交换以及路由构成一套有机的网络主干。

核心层为下两层提供优化的数据转移功能,它是一个高速的交换骨干,其作用是尽可能快的交换数据包而不应卷入到具体数据包的运算中(ACL,过滤等),否则会降低数据包的交换速度。

核心层还包括IP路由配置管理、IP组播、静态VLAN 、生成树、设置陷阱和警报、RMON监控管理以及服务器群的高速连接等。

3.2网络汇聚层设计

在校园院区之内楼宇之间连接时,主要楼域可放置二级交换机,当然也可以是第三层交换机。分布层交换机和核心层交换机之间均在全双工模式下的GBE宽带连接,保证分支主干的无阻塞交换。

分布层提供基于统一策略的互联性,它连接核心层和接入层,对数据包进行复杂的运算。在院区网络环境中,分布层主要提供如下功能:地址聚集、部门和工作组的接入、广播域;组播传输域的定义、VLAN分割、介质转换和安全控制等。

由于闽江学院网络规模不大,且核心层交换机性能强,汇聚层交换机的任务直接交给接入层,数据通讯策略问题交给路由器。

3.3网络接入层设计

接入层交换机放置于每幢楼的楼层内可用于直接接入到信息点。因采用可网管;可堆叠的高性能交换机,以便于扩展,交换机应具备扩展槽,以便根据需要加插二口堆叠模块;单口或双口的千兆模块。

接入层的主要功能是为最终用户提供对网络的访问途径。主要提供如下功能:宽带共享、交换宽带、MAC层过滤和网段微分。

在接入INTERNET设计时,推荐采用局域网(LAN)光纤接入方法,次方式通过配备路由器设置,租用电信部门的专线并向CERNET管理部门申请IP地址及注册域名,并通过路由器计费代理进行校园网网内学生上网的计费。

层次化设计的优点可以总结为如下几点:

1)可扩展性。因为网络可模块化增长而不会遇到问题。

2)简单性。通过将分成许多小单元,降低了网络的整体复杂性,使故障排除更容易,能隔离广播风暴的转播、防止路由循环等潜在的问题。

3)设计的灵活性。使网络容易升级到最新的技术,升级任意层次的网络不会对其他层次

造成影响,无须改变整个环境。

4)可管理性。层次结构使单个设备的复杂性大大降低,更易管理。

四.网络方案设计

4.1设备要求

校区网络建设应该以应用为核心,在设计中充分考虑到教育管理和多媒体教学的要求并且网络技术上应该具有一定的先进性,同时还要为以后的扩展留有一定的空间。

为此校园校区网络网应该能达到以下要求:

(1)稳定可靠的网络

只有运行稳定的网络才是可靠的网络,而网络的可靠运行取决于诸多因素,如网络的设计,产品的可靠,而选择一个具有运营此类网络规模经验的网络合作厂商则更为重要。要求有物理层、数据链路层和网络层的备份技术。

(2)高带宽

由于校园校区网络网络应用的特殊性,它对整个网络系统的性能要求相对来说比较高。其中,网络速率要求主要的信息点100M交换到桌面,园区网中各终端间具有快速交换功能。为了支持数据、话音、视像多媒体的传输能力,在技术上要到达当前的国际先进水平。要采用最先进的网络技术,以适应大量数据和多媒体信息的传输,既要满足目前的业务需求,又要充分考虑未来的发展。为此应选用高带宽的先进技术。

(3)易扩展的网络

系统要有可扩展性和可升级性。易扩展不仅仅指设备端口的扩展,还指网络结构的易扩展性:即只有在网络结构设计合理的情况下,新的网络节点才能方便地加入已有网络;网络协议的易扩展:无论是选择第三层网络路由协议,还是规划第二层虚拟网的划分,都应注意其扩展能力。对于核心网络设备,要求骨干交换机具备第三层交换能力,要求支持今后的视频点播、电视电话会议的宽带多媒体应用,并要求留有一定的扩充能力。

(4)安全性

网络系统应具有良好的安全性,由于网络连接园区内部所有用户,安全管理十分重要。网络具有防止及便于捕杀病毒功能。应支持VLAN的划分,并能在VLAN之间进行第三层交换时进行有效的安全控制,以保证系统的安全性。校区网络与校园网相连后具有“防火墙”过滤功能,以防止网络黑客入侵网络系统。可对接入因特网的各网络用户进行权限控制。(5)容易控制管理

对于网络管理,要求全网能够远程登录,实现对网络的监测和控制。并支持虚拟网络功能,对网络用户具有分类控制功能。

4.2硬件设备

A、主服务器:数量:4台

B、Cisco PT路由器2台。

C、Cisco 3560核心交换机2台

D、Cisco 2960 交换机 6台

E、网络连接设备(包括Router,基带Modem,,网卡,网线等,数量根据网络模型和办

公场所的具体情况确定)。

F、交换机,路由器线卡模块(具体情况确认)

G、接入无线路由器 2台

H、机架2个

4.3 ip地址和端口分配

网络工程校园网课程设计

网络工程校园网课程设计

4.4网络拓扑结构

网络工程校园网课程设计

4.5设备配置描述

4.5.1主校区接入层交换机:

以计算机系接入层交换机为例

switch(config)# hostname jsjswitch //主机名为jsjswitch

jsjswitch(config)# enable secret mjxy //配置用户登录密码为密文mjxy

jsjswitch(config)# no ip domain-lookup //关闭命令域名查找解析功能(以免命令敲错卡住)

jsjswitch(config)# spanning-tree portfast default //开启接入端口加速(重新开启端口免等待)

jsjswitch(config)# interface rang FastEthernet0/1 – f0/24 //接入层接口配置jsjswitch(config-if-range)# switchport access vlan 10 //接入vlan10

jsjswitch(config-if-range)#switchport mode access //配置接口为access模式jsjswitch(config-if-range)#switchport port-security //开启端口安全

jsjswitch(config-if-range)#switchport port-security mac-address sticky //动态绑定mac

jsjswitch(config-if-range)#switchport port-security maximum 1

//最大的接入地址为1

jsjswitch(config-if-range)#switchport port-security violation shutdown //发生违例时就关掉端口

jsjswitch(config-if-range)#exit

jsjswitch(config)# interface GigabitEthernet1/1

jsjswitch(config-if)#switchport access vlan 10

jsjswitch(config-if)#switchport mode access

jsjswitch(config-if)#speed 1000 //千兆到核心层

jsjswitch(config-if-range)#exit

jsjswitch(config)# interface Vlan10 //配置一个虚接口ip地址,主要用来远程登录

jsjswitch(config-if)#ip address 192.168.1.253 255.255.255.0

jsjswitch(config-if-range)#exit

jsjswitch(config)# line con 0//console口密码设置为mjxy

jsjswitch(config-line)#password mjxy

jsjswitch(config)# line vty 0 4 //以下配置远程登录用户5个,密码为mjxy jsjswitch(config-line)#password mjxy

jsjswitch(config-line)#login

jsjswitch(config-line)#end

jsjswitch#write

4.5.2核心层交换机

switch(config)# hostname zxqhexinswitch //主机名

zxqhexinswitch(config)# enable secret mjxy//登录密码密文显示mjxy

zxqhexinswitch(config)# no ip domain-lookup

zxqhexinswitch(config)# spanning-tree portfast default //开启接入端口加速(重新开启端口免等待)

zxqhexinswitch(config)# interface FastEthernet0/1 //计算机系接入点

zxqhexinswitch(config-if)# switchport access vlan 10

zxqhexinswitch(config-if)# switchport mode access

zxqhexinswitch(config-if)# speed 100

zxqhexinswitch(config-if)# exit

zxqhexinswitch(config)# interface FastEthernet0/2 //数学系接入点

zxqhexinswitch(config-if)# switchport access vlan 20

zxqhexinswitch(config-if)# switchport mode access

zxqhexinswitch(config-if)# speed 100

zxqhexinswitch(config-if)# exi

zxqhexinswitch(config)# interface FastEthernet0/3 //英语系接入点

zxqhexinswitch(config-if)# switchport access vlan 30

zxqhexinswitch(config-if)# switchport mode access

zxqhexinswitch(config-if)# speed 100

zxqhexinswitch(config-if)#exi

zxqhexinswitch(config)# interface FastEthernet0/4 //物理系接入点

zxqhexinswitch(config-if)# switchport access vlan 40

zxqhexinswitch(config-if)# switchport mode access

zxqhexinswitch(config-if)# speed 100

zxqhexinswitch(config-if)#exi

zxqhexinswitch(config)# interface FastEthernet0/5 //行政楼接入点

zxqhexinswitch(config-if)# switchport access vlan 50

zxqhexinswitch(config-if)# switchport mode access

zxqhexinswitch(config-if)# speed 100

zxqhexinswitch(config-if)# exi

zxqhexinswitch(config)# interface GigabitEthernet0/1 //上行接口zxqhexinswitch(config-if)# switchport trunk allowed vlan 1,10,20,30,40,50 zxqhexinswitch(config-if)# switchport trunk encapsulation dot1q

zxqhexinswitch(config-if)# switchport mode trunk

zxqhexinswitch(config-if)# duplex full

zxqhexinswitch(config-if)# speed 1000

zxqhexinswitch(config-if)#exi

zxqhexinswitch(config)# interface Vlan10 //配置虚拟接口用于远程登录

zxqhexinswitch(config-if)# ip address 192.168.1.252 255.255.255.0

zxqhexinswitch(config-if)#exi

zxqhexinswitch(config)# interface Vlan20

zxqhexinswitch(config-if)# ip address 192.168.2.252 255.255.255.0 zxqhexinswitch(config-if)#exi

zxqhexinswitch(config)# interface Vlan30

zxqhexinswitch(config-if)# ip address 192.168.3.252 255.255.255.0 zxqhexinswitch(config-if)#exi

zxqhexinswitch(config)# interface Vlan40

zxqhexinswitch(config-if)# ip address 192.168.4.252 255.255.255.0 zxqhexinswitch(config-if)#exi

zxqhexinswitch(config)# interface Vlan50

zxqhexinswitch(config-if)# ip address 192.168.5.252 255.255.255.0 zxqhexinswitch(config-if)#exi

zxqhexinswitch(config)# line con 0 //配置从console登录密码zxqhexinswitch(config-line)# password mjxy

zxqhexinswitch(config-line)#exi

zxqhexinswitch(config)# line vty 0 4 //配置远程登录密码

zxqhexinswitch(config-line)# password mjxy

zxqhexinswitch(config-line)# end

Zxqhexinswitch#write

4.5.3主校区路由器配置:

router(config)# hostname zxqrouter //主机名

zxqrouter(config)# enable secret mjxy //登录密码

zxqrouter(config)# no ip domain-lookup

zxqrouter(config)# interface GigabitEthernet0/0 //下行接口千兆接入

zxqrouter(config-if)# no ip address

zxqrouter(config-if)# duplex full

zxqrouter(config-if)# speed 1000

zxqrouter(config-if)# exi

zxqrouter(config)# interface GigabitEthernet0/0.1 //子接口做vlan10封装,实现单臂路由

zxqrouter(config-subif)# encapsulation dot1Q 10

zxqrouter(config-subif)# ip address 192.168.1.254 255.255.255.0

zxqrouter(config-subif)# ip helper-address 172.16.1.1 //指向DHCP服务器zxqrouter(config-subif)# ip access-group jisuanji out //应用名为jisuanji的访问控制列表,使得该子接口只能访问行政楼

zxqrouter(config-subif)# exi

zxqrouter(config)# interface GigabitEthernet0/0.2

zxqrouter(config-subif)# encapsulation dot1Q 20

zxqrouter(config-subif)# ip address 192.168.2.254 255.255.255.0

zxqrouter(config-subif)# ip helper-address 172.16.1.1

zxqrouter(config-subif)# ip access-group shuxue out

zxqrouter(config-subif)# exit

zxqrouter(config)# interface GigabitEthernet0/0.3

zxqrouter(config-subif)# encapsulation dot1Q 30

zxqrouter(config-subif)# ip address 192.168.3.254 255.255.255.0

zxqrouter(config-subif)# ip helper-address 172.16.1.1

zxqrouter(config-subif)# ip access-group yingyu out

zxqrouter(config-subif)#exit

zxqrouter(config)# interface GigabitEthernet0/0.4

zxqrouter(config-subif)# encapsulation dot1Q 40

zxqrouter(config-subif)# ip address 192.168.4.254 255.255.255.0

zxqrouter(config-subif)# ip helper-address 172.16.1.1

zxqrouter(config-subif)# ip access-group wuli out

zxqrouter(config-subif)# exit

zxqrouter(config)# interface GigabitEthernet0/0.5

zxqrouter(config-subif)# encapsulation dot1Q 50

zxqrouter(config-subif)# ip address 192.168.5.254 255.255.255.0

zxqrouter(config-subif)# ip helper-address 172.16.1.1

zxqrouter(config-subif)# exit

zxqrouter(config)# interface Serial1/0 //接入电信端接口

zxqrouter(config-if)# ip address 12.12.12.1 255.255.255.0

zxqrouter(config-if)# encapsulation frame-relay //封装帧中继

zxqrouter(config-if)# frame-relay interface-dlci 102 //配置由电信给的dlci 号

zxqrouter(config-if)# exit

zxqrouter(config)# router rip //路由信息协议(RIP)动态路由协议

zxqrouter(config-router)#version 2 //版本二(比版本一高级。)

zxqrouter(config-router)#network 12.0.0.0//宣告主校区各个网络

zxqrouter(config-router)#network 192.168.1.0

zxqrouter(config-router)#network 192.168.2.0

zxqrouter(config-router)#network 192.168.3.0

zxqrouter(config-router)#network 192.168.4.0

zxqrouter(config-router)#network 192.168.5.0

zxqrouter(config-router)#exit

zxqrouter(config)# ip route 0.0.0.0 0.0.0.0 Serial1/0 //做默认路由指向接入电信的接口

!

zxqrouter(config)# ip access-list standard jisuanji

//命名的访问控制列表(好处:可以随意删除表内的一条命令,不会整个表删除) zxqrouter(config-std-nacl)#deny 192.168.2.0 0.0.0.255

zxqrouter(config-std-nacl)#deny 192.168.3.0 0.0.0.255

zxqrouter(config-std-nacl)#deny 192.168.4.0 0.0.0.255

zxqrouter(config-std-nacl)#permit any

zxqrouter(config-std-nacl)#exit

zxqrouter(config)# ip access-list standard shuxue

zxqrouter(config-std-nacl)#deny 192.168.1.0 0.0.0.255

zxqrouter(config-std-nacl)#deny 192.168.3.0 0.0.0.255

zxqrouter(config-std-nacl)#deny 192.168.4.0 0.0.0.255

zxqrouter(config-std-nacl)#permit any

zxqrouter(config-std-nacl)#exit

zxqrouter(config)# ip access-list standard yingyu

zxqrouter(config-std-nacl)#deny 192.168.1.0 0.0.0.255

zxqrouter(config-std-nacl)#deny 192.168.2.0 0.0.0.255

zxqrouter(config-std-nacl)#deny 192.168.4.0 0.0.0.255

zxqrouter(config-std-nacl)#permit any

zxqrouter(config-std-nacl)#exit

zxqrouter(config)# ip access-list standard wuli

zxqrouter(config-std-nacl)#deny 192.168.1.0 0.0.0.255

zxqrouter(config-std-nacl)#deny 192.168.2.0 0.0.0.255

zxqrouter(config-std-nacl)#deny 192.168.3.0 0.0.0.255

zxqrouter(config-std-nacl)#permit any

zxqrouter(config-std-nacl)#exit

zxqrouter(config)# line con 0 //console口密码设置为mjxy

zxqrouter(config-line)#password mjxy

zxqrouter(config-line)#exit

zxqrouter(config)# line vty 0 4 //以下配置远程登录用户5个,密码为mjxy zxqrouter(config-line)#password mjxy

zxqrouter(config-line)#end

Zxqrouter#write

4.5.4分校区路由器

router(config)#hostname fxqrouter //主机名

fxqrouter(config)#enable secret mjxy //登录密码密文mjxy

fxqrouter(config)# no ip domain-lookup

fxqrouter(config)#interface GigabitEthernet0/0 //下行接口千兆

fxqrouter(config-if)# duplex full

fxqrouter(config-if)# speed 1000

!

fxqrouter(config)#interface GigabitEthernet0/0.100 //子接口封装vlan100 fxqrouter(config-subif)# encapsulation dot1Q 100

fxqrouter(config-subif)# ip address 172.16.1.254 255.255.255.0

fxqrouter(config-subif)# exit

fxqrouter(config)#interface Serial1/0 //接入电信的边缘接口,封装帧中继fxqrouter(config-if)# ip address 12.12.12.2 255.255.255.0

fxqrouter(config-if)#encapsulation frame-relay

fxqrouter(config-if)#frame-relay interface-dlci 201

fxqrouter(config-if)#exit

fxqrouter(config)#router rip //动态路由协议

fxqrouter(config-router)#version 2

fxqrouter(config-router)#network 12.0.0.0

fxqrouter(config-router)#network 172.16.0.0

fxqrouter(config-router)#no auto-summary

fxqrouter(config-router)# exit

fxqrouter(config)#ip route 0.0.0.0 0.0.0.0 Serial1/0 //建立默认路由,

fxqrouter(config)# line con 0//console口密码设置为mjxy

fxqrouter(config-line)#password mjxy

fxqrouter(config-line)#exit

fxqjieruswitch(config)#line vty 0 4 //以下配置远程登录用户5个,密码为mjxy fxqrouter(config-line)#password mjxy

fxqrouter(config-line)#end

Fxqrouter#write

4.5.5分校区核心交换机

switch(config)#hostname fxqhexinswitch //主机名

fxqhexinswitch(config)#enable secret mjxy //登录密码密文mjxy

fxqhexinswitch(config)#no ip domain-lookup

fxqhexinswitch(config)#spanning-tree portfast default //开启接入端口加速(重新开启端口免等待)

fxqhexinswitch(config)#interface FastEthernet0/1 //下行接口

fxqhexinswitch (config-if)#switchport access vlan 100

fxqhexinswitch (config-if)#switchport mode access

fxqhexinswitch (config-if)#exit

fxqhexinswitch(config)#interface GigabitEthernet0/1 //上行接口封装802.1q 千兆上行

fxqhexinswitch (config-if)#switchport trunk encapsulation dot1q

fxqhexinswitch (config-if)#switchport mode trunk

fxqhexinswitch (config-if)#duplex full

fxqhexinswitch (config-if)#speed 1000

fxqhexinswitch (config-if)#exit

fxqhexinswitch(config)#interface Vlan100 //配置虚拟接口用于远程登录

fxqhexinswitch (config-if)#ip address 172.16.1.253 255.255.255.0

fxqhexinswitch (config-if)#exit

fxqhexinswitch(config)# line con 0//console口密码设置为mjxy

fxqhexinswitch config-line)#password mjxy

fxqhexinswitch (config-line)#exit

fxqhexinswitch(config)#line vty 0 4 //以下配置远程登录用户5个,密码为mjxy fxqhexinswitch (config-line)#password mjxy

fxqhexinswitch (config-line)#end

Fxqhexinswitch#write

4.5.6分校区接入层交换机

switch(config)# hostname fxqjieruswitch // 用户名

!

fxqjieruswitch(config)#enable secret mjxy//密码配置密文mjxy

fxqjieruswitch(config)# no ip domain-lookup

fxqjieruswitch(config)#spanning-tree portfast default //开启端口加速

fxqjieruswitch(config)# interface rang FastEthernet0/1 – f0/23//接入层接口配置

fxqjieruswitch(config-if-range)# switchport access vlan 10 //接入vlan10

fxqjieruswitch(config-if-range)#switchport mode access //配置接口为access模式

fxqjieruswitch(config-if-range)#switchport port-security //开启端口安全

fxqjieruswitch(config-if-range)#switchport port-security mac-address sticky //动态绑定mac

fxqjieruswitch(config-if-range)#switchport port-security maximum 1

//最大的接入地址为1

fxqjieruswitch(config-if-range)#switchport port-security violation shutdown //发生违例时就关掉端口

fxqjieruswitch(config-if-range)#exit

fxqjieruswitch(config-if)#fxqjieruswitch(config)# int f0/24 //配置上行接口 fxqjieruswitch(config-if)#Swi m a

fxqjieruswitch(config-if)#Swi a vlan 100

fxqjieruswitch(config)#interface GigabitEthernet1/1 //接入DHCP服务器

fxqjieruswitch(config-if)#switchport access vlan 100

fxqjieruswitch(config-if)#switchport mode access

fxqjieruswitch(config-if)#exit

fxqjieruswitch(config)#interface GigabitEthernet1/2//接入FTP,TFTP服务器 fxqjieruswitch(config-if)#switchport access vlan 100

fxqjieruswitch(config-if)#switchport mode access

fxqjieruswitch(config-if)#exit

fxqjieruswitch(config)#interface Vlan100 //配置虚拟接口用于远程登录

fxqjieruswitch(config-if)#ip address 172.16.1.252 255.255.255.0

fxqjieruswitch(config-if)#exit

fxqjieruswitch(config)# line con 0//console口密码设置为mjxy

fxqjieruswitch(config-line)#password mjxy

fxqjieruswitch(config-line)#exit

fxqjieruswitch(config)#line vty 0 4 //以下配置远程登录用户5个,密码为mjxy fxqjieruswitch(config-line)#password mjxy

fxqjieruswitch(config-line)#end

Fxqjieruswitch#write

4.5.7 DHCP服务器配置

(1)添加多个DHCP表项,指定对应的起始地址,网关,DNS服务器,TFTP服务器ip地址

网络工程校园网课程设计

网络工程校园网课程设计

(2)主校区路由器配置zxqrouter(config-if)#ip helper-address 172.16.1.1 //指向DHCP服务器。

(3)PC客户端获取IP地址,显示成功。

网络工程校园网课程设计