文档视界 最新最全的文档下载
当前位置:文档视界 > 思科交换机3550配置手册(修改后)

思科交换机3550配置手册(修改后)

交换机简介

?连接方式

Telnet、WebBrower、网管软件、console(控制线)

?性能参数

基本配置

?状态转换

?用户属性及密码修改

?查看MAC地址

#show mac-address-table

?端口基本配置(单/组)

speed/duplex

Description

?保存或更改设置

#copy running-configure startup-configure

#delete flash:vlan.dat

#erase startup-configure

#reload

?MAC地址配置

使用说明

?命令缩写

??及Tab键的使用

?为防止由于输入的命令错误引起的等待,禁止设备查找DNS服务器

#no ip domain-lookup;

?有效的范围:

vlan从1 到4094

fastethernet槽位/{first port} - {last port}, 槽位为0

gigabitethernet槽位/{first port} - {last port},槽位为0

?端口优先及通常为4096的倍数,而权植为16的倍数;

VLAN配置

?VLAN 简介

思科交换机3550配置手册(修改后)

?创建VLAN(基于静态端口)

新建

划分端口

?查看VLAN配置

?删除VLAN

?问题:物理端口与可支持VLAN数目不相匹配;

?命令行:

switch>en

switch #vlan database //新建Vlan1

switch (vlan)vlan 1name VLAN1

switch #configure terminal

switch (config)int g0/1 //划分端口g0/1

switch(config-if)switch mode access

switch(config-if)switch access vlan 1

TRUNK设置

?TRUNK简介

?数据封装类型

dot1

isl

negotiate

?配置trunk

?定义trunk允许通过的

vlan switch trunk allowed vlan …

?Native vlan 意义及更改

(如果trunk链路两端的native vlan不一致时,交换机将会报错)

?DTP简介

对于CISCO交换机之间的链路是否形成TRUNK,可以通过DTP(Dynamic Trunk Protocol)进行协商。

?命令行:

switch>en

switch #configure terminal

switch (config)int g0/1 //设置TRUNK链路

switch(config-if)switch mode trunk

switch(config-if)switch trunk encapsulation dot1q //设置数据封装类型

switch(config-if)switch trunk native vlan 2 //设置Native vlan

VTP设置

?VTP(vlan trunk protocal)简介

提供了一种用于在交换机上管理VLAN的方法,使得我们在同一个或者几个中央点(server)上创建、修改和删除VLAN的现时,VLAN信息可以通过Trunk 链路自动扩散到其他交换机,在VTP 管理域中的交换机都保持相同的VLAN 信息

?VTP模式

思科交换机3550配置手册(修改后)

server(默认模式):允许VLAN操作;

client(客户端模式):无权进行VTP域内的VLAN操作;同时充当VTP中继;

transparent(透明模式):有权进行独立的VLAN操作;主要充当VTP中继;

?VTP配置

vtp模式设定

vtp域名设定

vtp修剪功能#vtp pruning(防止不必要的流量从trunk链路上通过,通常需要启用)

vtp密码设定

?查看VTP

#show vtp status

?关于“configure revision”的说明

VTP通告是以组播帧的方式发送的,VTP通告中有一个字段称为修订号——Revision,初始值为0。只要在VTP server上创建、修改和删除VLAN,通告的Revision就能增加1,通告中还包含了VLAN的变化信息。需要注意的是,高Revision的通告会覆盖了低Revision的通告,而不管发送者是server 还是client。交换机只接受比本地保存的Revision号更高的通告;如果交换机收到比自己的Revision号更低的通告,会用自己的VLAN信息反向覆盖。

?命令行:

switch>en

switch #configure terminal

switch(config) vtp mode {server|client|transparent} //设置VTP模式

switch(config)vtp domain VTP-TEST //配置VTP域名

switch(config)vtp password cisco //配置VTP密码,防止不明身份交换机加入到域中。STP设置

?目的:克服冗余环路(广播风暴、同一个帧的多个拷贝、CMA表的不稳定)?STP(spanning-tree protocol)简介

利用BPDU(Bridge Protocol Data Unit)与其他交换机进行通信,通过BPDU中的关键字段:根桥口、路径代价、端口ID等阻断一些交换机端口,从而构建一棵没有环路的转发树。

?STP步骤

选取根桥(桥ID=网桥优先级+MAC地址)

选取根口(路径COST)

选取指定端口(相对交换机)和指定交换机(相对特定网络)

?查看spanning-tree

#show spanning-tree

?通过优先级设定更改根桥,通常会考虑用新设备充当根桥;

#spanning-tree vlan 1 priority 4096

?命令行:

VLAN间路由

?实现途径:

1、借助路由器——单臂路由;

2、借助交换机三层交换功能——三层交换;

?实验拓扑图:

思科交换机3550配置手册(修改后)

?单臂路由实现:

交换机命令:

switch>en

switch #configure terminal

switch (config)int g0/1 //设置TRUNK链路

switch(config-if)switch mode trunk

switch(config-if)switch trunk encapsulation dot1q //设置数据封装类型

switch(config-if)switch trunk native vlan 2 //设置Native vlan

switch #vlan database //新建Vlan2

switch (vlan)vlan 2 name VLAN2

switch #configure terminal

switch (config)int g0/3 //划分端口g0/3

switch(config-if)switch mode access

switch(config-if)switch access vlan 2

?路由器命令:

Router>enable

Router#confgiure terminal

Router(config)#interface loopback 0

Router(config-if)ip address 1.1.1.1 255.255.255.255

Router(config-if)#interface fastEthernet 1/0

Router(config-if)#no shutdown

Router(config-if)#no ip address

Router(config-if)#interface fastEthernet 1/0.2 //设置逻辑路由端口

Router(config-subif)#no shutdown

Router(config-subif)#encapsulation dot1Q 2 //设置数据封装类型

Router(config-subif)#ip address 10.10.1.1 255.255.255.0 //设置逻辑端口IP = VLAN Gateway

Router(config-subif)#interface fastEthernet 1/0.3

Router(config-subif)#no shutdown

Router(config-subif)#encapsulation dot1Q 3

Router(config-subif)#ip address 192.168.1.1 255.255.255.0

Router#copy running-config startup-config //保存配置文件

Router#show ip route //查看路由信息

如果如下:

1.0.0.0/32 is subnetted, 1 subnets

C 1.1.1.1 is directly connected, Loopback0

10.0.0.0/24 is subnetted, 1 subnets

C 172.16.1.0 is directly connected, FastEthernet0/0.1

C 172.16.2.0/24 is directly connected, FastEthernet0/0.2

?交换机三层路由功能实现:

交换机命令:

switch>enable

switch # confgiure terminal

switch (config)ip routing // 打开(三层)交换机的路由功能

switch (config-if)int vlan 1 // 配置vlan信息

switch(config-if)no shutdown

switch(config-if)ip address 172.16.1.254 255.255.255.0 //配置VLAN IP = Gateway

switch(config-if)exit

switch (config)int vlan 2

switch (config-if)no shutdown

switch(config-if)ip address 172.16.2.254 255.255.255.0

switch (config-if)exit

switch(config)exit

switch#copy running-config startup-config

switch #show ip route

如果如下:

Gateway of last resort is not set

172.16.0.0/24 is subnetted, 2 subnets

C 172.16.1.0 is directly connected, Vlan1

C 172.16.2.0 is directly connected, Vlan2

省略PC机IP设置,具体参数参见拓扑图!

注:PC机在操作时,必须关闭系统防火墙!

负载均衡

?使用ethernet channel

?利用STP端口权植实现

?利用STP路径代价实现

静态路由配置

?拓扑图:

思科交换机3550配置手册(修改后)

?命令行:

(1)在各路由器上配置IP地址:

ROUTER1:

Router1>enable

Router1#confgiure terminal

Router1(config)#interface loopback 0

Router1(config-if)ip address 1.1.1.1 255.255.255.255

Router1(config)#interface s0

Router1(config-if)#ip address 192.168.12.1 255.255.255.0

Router1(config-if)#no shutdown

ROUTER2:

Router2>enable

Router2#confgiure terminal

Router2(config)#interface loopback 0

Router2(config-if)ip address 2.2.2.2 255.255.255.255

Router2(config)#interface s0

Router2(config-if)#ip address 192.168.12.2 255.255.255.0 Router2(config-if)clock rate 128000

Router2(config-if)#no shutdown

Router2(config)#interface s1

Router2(config-if)#ip address 192.168.23.2 255.255.255.0 Router2(config-if)clock rate 128000

Router2(config-if)#no shutdown

ROUTER3:

Router1>enable

Router3#confgiure terminal

Router3(config)#interface loopback 0

Router3(config-if)ip address 3.3.3.3 255.255.255.255

Router3(config)#interface s1

Router3(config-if)#ip address 192.168.23.3 255.255.255.0 Router3(config-if)clock rate 128000

Router3(config-if)#no shutdown

(2)在各ROUTER上配置静态路由

ROUTER1:

Router1(config)#ip route 2.2.2.0 255..255.255.0 s0

Router1(config)#ip route 3.3.3.0 255.255.255.0 192.168.12.2 ROUTER2:

Router2(config)#ip route 1.1.1.0 255.255.255.0 s0

Router2(config)#ip route 3.3.3.0 255.255.255.0 s1

ROUTER3:

Router3(config)#ip route 1.1.1.0 255.255.255.0 s1

Router3(config)#ip route 2.2.2.0 255.255.255.0 s1

(3)在R1,R2,R3上查看路由表:

Router1#show ip route

如果如下:

1.0.0.0/32 is subnetted, 1 subnets

C 192.168.12.0/24 is directly connected, s0

C 1.1.1.0 is directly connected, Loopback0

2.0.0.0/24 is subnetted, 1 subnets

S 2.2.2.0 is directly connected, S0/0.1

S 3.3.3.0[1/0] via 192.168.12.2

(4)从R1上ping2.2.2.2:

结果如下:

Type escape sequence to abort.

Sending 5,100-byte ICMP Echos to 2.2.2.2,timeout is 2 seconds:

!!!!!

Success rate is 100 percent(5/5),round-trip min/avg/max=12/14/16 ms ?默认路由:

?拓扑图

如上

?命令行:

(1)在R1、R3上删除原有静态路由

ROUTER1:

Router1(config)#no ip route 2.2.2.0 255..255.255.0 s0

Router1(config)# no ip route 3.3.3.0 255.255.255.0 192.168.12.2 ROUTER3:

Router3(config)# no ip route 1.1.1.0 255.255.255.0 s1

Router3(config)# no ip route 2.2.2.0 255.255.255.0 s1

(2)在R1、R3上配置默认路由

Router1(config)#ip route 0.0.0.0 0.0.0.0 s0

Router3(config)#ip route 0.0.0.0 0.0.0.0 s0

相关文档
  • 思科三层交换机配置

  • 思科三层交换机

  • 思科交换机基本配置

  • 思科交换机简单配置

  • 思科交换机配置教程

  • cisco三层交换机配置

相关推荐: