文档库

最新最全的文档下载
当前位置:文档库 > 【股票指标公式下载】-【通达信】HMYL指标(黑马线、操盘手、庄拉、大黑马)

【股票指标公式下载】-【通达信】HMYL指标(黑马线、操盘手、庄拉、大黑马)

【通达信】HMYL指标(黑马线、操盘手、庄拉、大黑马)-指标公式源码

{N1:1 100 14}

VAR3:=EMA(100*(CLOSE-LLV(LOW,100))/(HHV(HIGH,100)-LLV(LOW,100)),5); VAR4:=(CLOSE-LLV(CLOSE,N1))/(HHV(CLOSE,N1)-LLV(CLOSE,N1))*100;

VAR5:=EMA(CLOSE,2)-EMA(CLOSE,150);

VAR6:=EMA(VAR5,100);

VAR7:=2*(VAR5-VAR6);

VAR8:=POW(VAR7,3)*0.1+POW(VAR7,1);

VAR9:=SQRT(SQRT(LOW*HIGH*OPEN*CLOSE));

VARA:=EMA(VAR9*0.97,3);

VARB:=(HIGH+LOW+CLOSE)/3;

VARC:=(VARB-MA(VARB,14))/(0.015*AVEDEV(VARB,14));

黑马线1:= IF(VAR7>0.1,VAR8,0)*5;

VARD:=LLV(HIGH,240);

VARE:=100*(CLOSE-VARD)/VARD;

VARF:=AMOUNT/VOL;

VAR10:=EMA((WINNER(CLOSE*1.1)-WINNER(CLOSE*0.9))*80,5);{这句有未来 } VAR11:=INDEXC;

VAR12:=MA(VAR11,5);

VAR13:=MA(VAR11,20);

VAR14:=MA(VAR11,30);

VAR15:=VAR14>VAR12*1.08 AND VAR13>VAR12*1.055;

VAR16:=VAR12>VAR11*1.03 AND VAR13>VAR11*1.13;

VAR17:=VAR16;

VAR18:=IF(FILTER(VAR10<6,5)=1,1,0);

VAR19:=VAR10<6 AND VAR17;

VAR1A:=CROSS(黑马线1,2);

VAR1B:=CROSS(黑马线1,4);

VAR1C:=(CLOSE-MA(CLOSE,6))/MA(CLOSE,6)*100;

VAR1D:=(CLOSE-MA(CLOSE,12))/MA(CLOSE,12)*100;

VAR1E:=(CLOSE-MA(CLOSE,24))/MA(CLOSE,24)*100;

VAR1F:=REF(CLOSE,1);

VAR20:=SMA(MAX(CLOSE-VAR1F,0),5,1)/SMA(ABS(CLOSE-VAR1F),5,1)*100;