文档库

最新最全的文档下载
当前位置:文档库 > 有机质污染判断操作说明

有机质污染判断操作说明

一、操作说明

1.简介

本软件是专为OGE油气评价工作站配套的数据处理软件之一,用于处理仪器的储集岩分析周期所生成的分析数据。

在钻井过程中,由于泥浆中有机物添加剂,或是油基泥浆等有机物可能对钻井岩屑造成污染,而使储集岩热解分析资料出现假象。

本软件则是利用已知的若干常用泥浆添加剂的热解分析典型特征来判断样品是否受到了某种类型有机质的“可能污染”,最终确定还要结合钻井过程中实际泥浆配方语言印证明。2.运行环境:Windows98、Win2000、简体中文

运行程序名:OGE-ORGA.EXE

路径:C:\OGE\OGE-RECE

有机质污染判断操作说明

图1: 储集岩热解有机质污染判断主窗口

有机质污染判断操作说明

3.输入数据

输入数据内容包

括:“文件”下拉式菜单

中的“新建”、“追加数

据”、“合并数据”及“打

开”已编辑过的旧数据

或是从最近曾经处理过

的4个文件中选取一个

旧数据文件。

图2: “文件”下拉式菜单全貌

a.“新建”:指的是要重新组织一份新的分析数据报告时选用。如果此时主窗口中有数

据则会提示你,是否保存这些数据,而后再装入你所挑选的新的数据。

b.“添加数据”:指的是在主窗口中已存在有一份报告数据,而你希望在此报告基础上

再添加一些新的分析数据,从而组成一份更新的数据报告。

“新建”和“添加数据”其操作是一样

有机质污染判断操作说明

的,单击后会弹出如下窗口:

由主菜单的“输入数据”或“追加

数据”进入此窗口。

⑴数据库名:是一个下拉式菜单。

单击下拉箭头,将会出现已存在的所有

热解分析工作名(即子目录),你所想要调集

的分析数据就存放在你作分析时所选用的

工作名下,所以,你应选用与分析样品时完

全相同的工作名。

单击你所想要的工作名即可,此时下拉

菜单消失,而上部则显示有你所选择

的工作名。

图3: 选择数据库名

有机质污染判断操作说明

⑵按日期选择:此是一触发式按钮,单击

一下选中,再击一下取消。

按日期选择的依据是样品分析的日期,选

择此项可以方便的打印出当天的报表,便于录

井队进行当天的工作统计。

触发开此按钮后,在右边的下拉式菜单

中,即出现本工作名下的所有已存在的分析日

期,选择你所希望的日期,单击一下,此时,

你所选的日期会出现在上面的文本框内。

⑶按井号选择:也是一触发式按钮。

该选择依据的是分析样品时,输入样品数

据时的“井号”参数,为的是便于提取某一口

井的全部热解录井数据。操作方法与日期选择

相同。图4: 按日期和/或井号选择分析数据

有机质污染判断操作说明

⑷按深度选择:是一触发式按钮。

触发开此项后,窗口左下部出现“起始深

度”和“终止深度”提示,此时可键盘输入这

两个深度值,程序将自动从数据库中挑选出介

于这两个深度之间的所有样品数据,便于对某

一口井中的某一感兴趣的井段组织报告。(见

图5)

⑸手工选择:此触发式按钮与前述三个按

钮是互斥的,即选择此项,则前三项不起作用,

而选择有前三项,则此手工选择不起作用。

图5: 按深度选择分析数据

⑹“确认”按钮

上述各项选择,按你所要求的选择好后,即可按“确认”键,然后将带着全部选择参数返回主窗口。

⑺“取消”按键

当进入此窗口后,你又不想进行任何数据输入,则按“取消”键,它将什么事不干而返回主窗口。

⑻无论是单击“输入数据”还是“追加数据”都将首先进入“数据库选择窗口”。

当在数据库选择窗口选择好数据库工作名及选择方式后,确认返回主窗口,并按选择参数,采取了不同的处理方法。

⑼当选择自动式(按日期、井号、深度)时,在主窗口工作下,将会自动地从数据库中挑选出你所要求的全部满足选择条件的分析样品原始分析数据。

⑽当选择“人工选择”按“确认”键后,屏幕给出人工选择板。

有机质污染判断操作说明

图6: 人工选择分析数据

在左边的电子报表栏中,给出了该工作名下的全部储集岩分析样品分析号清单。

将你所希望的分析号样品序号键入到右边的起始号和终止号中,如你想调入第3号至第8号样品,共6个样品,就在起始号中键入“3”。在终止号中键入“8”,然后按“确认”键。

如果你只调入这一段序号样品,不再要其它序号样品了,就可以按“返回”键。若你还有所其它序号的样品,则可以连续键入另一连续序号段的起始、终止号,按“确认”键。可以反复如此操作,直至你按“返回”键结束这一过程。

而后就与自动选择一样,屏幕上显示出全部你所挑选的样品分析数据。

c.“合并”:与“添加数据”类似,也是希望组织出一份更新的分析报告,但现在要添

加的数据不是来自原始分析数据库,而是来自以前曾经处理过的一份报告数据,将此份数据合并到当前已有的数据中组成新报告。

d.“打开”:指调出原来已处理过的某一份报告数据,进行重新处理。

“打开文件”和“合并数据”的具体操作,都是单击该栏目后,弹出一输入文件选择窗口,其操作与Windows其它通用软件的相应操作一样。

e.调用最近处理过的数据:直接从“文件”的下拉式菜单下部四条已处理过数据文件的

路径中选取,单击即可。

4.保存数据

当一批数据经过编辑、修改等操作后,用户如果认为这批数据具有保留的价值,则应进行保存,以便以后使用,当然也可以放弃保存,由用户决定。

保存数据的操作,在本软件中有3种方式:“保存为”、“另存为”、“另存为文本文件”。

a.“保存为”:在单击该栏目后,如果待保存的数据是通过“打开”提取的原有旧数据,

则“保存”操作直接将修改后的数据存回原文件中,而复盖原数据。

如果待保存的数据,是通过“新建”而从原始数据库提取的数据,则会立即弹出一个保存文件选择窗口,用户可以选择路径名,输入文件名。确认后,将会把全部数据存入你选择的路径文件中,数据文件名的扩展名,一般默认为“OGE”。

b.“另存为”:当用户希望将数据保存为一个新的数据文件时使用,它允许用户选择新

的路径和文件名,扩展名默认值是“OGE”。若用户想用其它扩展名时,可将“保存类型”改为“所有文件*.*”。

c.“另存为文本文件”:前面提到的两项保存文件方式是采用随机文件方式保存的。不

便于其它应用程序使用该数据,保存为文本格式,则许多应用程序都能使用,如Word 和Execl。都能调用该数据,文件扩展名默认为“TXT”。

5.编辑

有机质污染判断操作说明

编辑菜单有子菜单“浏览修改”、“删除”、

“剪切”、“复制”、“粘贴”、“排序”。

编辑的各项操作与微软的其它应用程序

的操作基本上是一样的,先选择要编辑对象,

然后进行相应的操作。

a.“浏览修改”:

在此工作状态下,电子表格显示了全部

数据项,窗口显示了其中的部分数据,

通过水平和垂直滚动条操作可以看到

全部数据。图7: 编辑子菜单

有机质污染判断操作说明

图8: 编辑工作表单

●在图8工作表中,全部原始分析数据值是不可修改的,这些包括“样品量”、“天然气”、“汽油”、“煤油”、“柴油”、“蜡、重油”、“胶质沥青质”、“残余油”、“总烃”。

●前六项样品基本参数长度定为:

分析号:10个字符, 原编号:10个字符, 井号:10个字符

井深:16个字符(XXXX.XX-XXXX.XX) , 层位:10个字符

岩性:20个字符

有机质污染判断操作说明

●“污染类型”分为两类。单击该栏目下的

单元,则循环为“油品类”、“添加剂类”及

“空白”。在“污染类型”为油品类时,“可

能污染物”栏目下的对应单元将自动判断出

是什么油品。而在“污染类型”为添加剂类

时,“可能污染物”栏目下的对应单元将自动

判断出是一序号,每一序号代表着一组可能

的添加剂。单击该序号所在的单元格会弹出

该序号所代表的一组添加剂名称。图9: 可能污染物表单油品类:柴油

轻质油

中质油

重质油

超重油

沥青

褐煤

添加剂类:Ⅰ"十二醇"

"淀粉DFD"

"十八烷基二甲苄基胺"

"固体润滑剂"

"改性磺化栲胶"

Ⅱ"碘甲基褐煤树脂"

Ⅲ"有机土"

Ⅳ"单压封闭剂"

"CMC"

Ⅴ"FLS无铬木素"

"高改性沥青"

"PH KN"

Ⅵ"防塌润滑剂"

"DO油酸酰胺"

"铁铬盐"

"FT-342"

Ⅶ"碘化褐煤"

"抗盐降失水剂"

"HZN-102-Ⅱ"

Ⅷ"粉状解卡剂"

"平平加EL-40"

"80A-51"

Ⅸ"十二烷基苯磺酸钠"

"钙盐"

"水解双聚铵盐"

"PAC-141"

"钾盐"

"胺盐"

●单击某一可修改单元,则选中该单元,可修改该单元数据,进行“退格”、“删除”、

“剪切”、“复制”、“粘贴”或是键入新内容。

●双击某一可修改单元,则选中该单元,并进入文本编辑状态,有一条光标线出现,

可在光标位置处插入字符,删除等操作。

●单击某一行的最左边单元(序号),则选中整行。

●单击某一列的栏目单元,则选中该列。

●单击最左上角“序号”单元,可使第一例成为固定列。在水平滚动条拉动时,固定

列将不会滚动。再次单项击此左上角单元,则去除此固定列。

b. 删除:可删除选中的单元或单元列、单元行的内容。

c. 剪切、复制:都只对选中的单元有效,在选中单元列的情况下,只对该列的第一个单元有效。剪切、复制都是将单元的内容放到系统剪切板上,但“剪切”同时清除该单元内容,而“复制”则不改变该单元内容。

d. 粘贴:将系统剪切板上的文本内容粘贴到你所选中的单元或单元列中。对于某些栏目,如“井号”、“层位”、“岩性”、“井温”、“存放时间”等可能各样品的这些参数都相同,填写一个后,用“复制”、“粘贴”最为方便。

有机质污染判断操作说明

e. 排序:排序有按“分析号”、“日期”、

“井深”三种排序,均是按递升排序。

另有“手工排序”是一种人工调整样

品先后次序的方法。只要用鼠标指向

某一横行的最左单元并按下拖动到你

希望的位置后松开鼠标左键,即可将

此行数据移动到你松开左键时那一行

的前面插入。

图10: 排序子菜单

6.报告输出

有机质污染判断操作说明

单击“报告”,屏幕显示出将要打印的格式内容。此时可以检察各项数据,如需修改则可再次进入编辑状态,进行修改。如检察后不需再修改,则可从“文件”菜单下的“打印”子菜单进行打印输出。

报告除可以打印输出外,还可以从“文件”菜单下的“报告输出”子菜单输出成文本格式文件存盘保存,以便数据交换。输出文本文件的扩展名为“RP6”。