文档库

最新最全的文档下载
当前位置:文档库 > 【股票指标公式下载】-【大智慧】BS决策(收盘价、能量级别、决策、买卖点决策)

【股票指标公式下载】-【大智慧】BS决策(收盘价、能量级别、决策、买卖点决策)

【股票指标公式下载】-【大智慧】BS决策(收盘价、能量级别、决策、买卖点决策)

【大智慧】BS决策(收盘价、能量级别、决策、买卖点决策)-指标公式源码

INPUT:Q1(5,0,1000),Q2(10,0,1000),Q3(20,0,1000),Q4(30,0,1000),Q5(60,0, 1000),Q6(120,0,1000);

MA1:MA(C,Q1);

MA2:MA(C,Q2);

MA3:MA(C,Q3);

MA4:MA(C,Q4);

MA5:MA(C,Q5);

MA6:MA(C,Q6);

a:="[email=LTFunc4@FORLT2]LTFunc4@FORLT2[/email]";

s1:="[email=LTFunc4@LT_S1]LTFunc4@LT_S1[/email]";

hs:="[email=LTFunc4@LT_HS]LTFunc4@LT_HS[/email]";

ls:="[email=LTFunc4@LT_LS]LTFunc4@LT_LS[/email]";

p1:="[email=LTFunc4@LT_P1]LTFunc4@LT_P1[/email]";

upp:="[email=LTFunc4@LT_UPP]LTFunc4@LT_UPP[/email]";

udd:="[email=LTFunc4@LT_UDD]LTFunc4@LT_UDD[/email]";

{hs;ls;hhs;lls;us;ds;s1;p1;p0;upp;udd};

d1:=ema(abs("日线-DDX.ddx"),60);

d2:=max("日线-DDX.ddx"/d1+7.5,7.5);

d3:=min("日线-DDX.ddx"/d1,10);

fb:=if(s1=0,hs,ls);

tr0:=ifs(p1=1,'明日收盘价<'+numtostrn(udd,2)+',出现S点\n','若明日收盘价>'+numtostrn(upp,2)+',出现B点\n');

tr1:=ifs(s1=1,'明日收盘价<'+numtostrn(ls,2)+',短线卖出机会','若明日收盘价>'+numtostrn(hs,2)+'短线买入机会');

tr2:=ifs(p1=1,ifs(cross(p1,0),'B点','持股'),ifs(cross(1,p1),'S点','持币'));

tr3:=ifs(s1=0,'向下,','向上,');

tr4:='3.能量级别:'+numtostrn(d3,1)+'级';

bs:=''+datestr(date)+'买卖点决策系统提示\n'+'1.BS点:'+tr2+','+tr0+'2.短线:'+tr3+tr1+'\n'+tr4;

drawflagtext(1,fb,bs);

DRAWICON(d3>1,LOW,6),align1;