文档库

最新最全的文档下载
当前位置:文档库 > tumic软件介绍

tumic软件介绍

第一章概述

TUMIC是一套线性微波集成电路(HMIC/MMIC)设计软件,具有完整的界面和仿真功能,运行于Windows 95/Windows98操作系统上。本章介绍TUMIC软件的运行环境、功能和基本操作。

一、运行环境

TUMIC的基本运行环境如下:

?具有486或更高速度CPU的PC机(推荐使用Pentium CPU);

?至少16MB内存、200MB硬盘;

?Windows 95或Windows 98版本的操作系统;

?VGA显示卡和显示器(推荐使用具有800×600分辨率以上的显示卡和显示器);

?光盘驱动器和3.5”软驱(供安装软件)

二、界面功能

TUMIC的用户界面是一种标准的Windows界面,由若干窗口组成,功能包括:电路图编辑,启动并控制电路仿真,仿真结果的图形显示,调入、保存、打印电路图和仿真结果。

TUMIC的窗口

TUMIC的窗口分以下三种,具有中文和英文两种版本形式,窗口功能如下:

?主窗口:用于编辑、显示电路图,执行电路仿真,打开输出窗口显示仿真结果,打开状态窗口显示仿真状态,调入、保存电路文件和仿真结果文件,打印电路图。

?输出窗口:分表格(Table)窗口、方格图(Grid)窗口、Smith圆图(Smith)窗口和直方图(Histogram)窗口四种,用于显示、打印各种仿真结果。

?仿真信息窗口:用于显示仿真过程中的状态和出错信息。

电路图编辑

TUMIC具有一个功能完备的电路图编辑器,可通过鼠标完成元件和连线的添加、删除,并支持元件的旋转、镜像,支持块定义、块操作,支持删除复原,支持电路图的缩放。采用对话框完成参数、变量等的定义和赋值。所编辑的电路图及其所有参数贮存于以.cir为后缀的电路文件中,可反复调用。电路图编辑器除以上电路图编辑功能外,还包括电路仿真所需输入的参数,一并贮存于以.cir为后缀的电路文件中。

1-1

启动并控制电路仿真

通过选择菜单项或快捷按钮即可启动各种类型的电路仿真。仿真前自动检查电路图中电路连接的正确性,自动提取拓扑网表。仿真时自动打开仿真信息窗口显示仿真过程中的状态和出错信息。在电路优化完成后提示用户是否继续优化,输入继续优化次数。通过选择一菜单项或快捷按钮可强制终止电路仿真。通过选择一菜单项可更新电路优化变量值。

显示仿真结果

TUMIC的四种输出窗口能用不同的式样自由显示各种仿真结果数据。其中方格图用于显示各种标量电路特性参数随频率的变化关系,Smith圆图用于显示矢量电路特性参数(一般为S参数)随频率的变化关系,直方图用于显示电路参数的成品率直方图,而表格则用于列表显示上述所有参数的数值。所有这些窗口中显示的参数均由用户从仿真设定的输出参数中选择。一个方格图或Smith 圆图可同时显示至多6个电路性能参数,而一个表格中所能显示的参数不限。方格图中可设置左右两个参数坐标同时显示两种不同类型的参数,并可自由调整坐标的上下限和间隔。在优化过程中,输出窗口中显示的数据能随优化进程及时更新。

调入、保存和打印

TUMIC中电路图(包括所有电路参数和仿真参数)可以.cir为后缀的文件保存在磁盘中,并可随时从磁盘中调入做修改及仿真,所显示的电路图可用打印机以“所见即所得”方式打印。一次电路仿真得到的所有仿真结果参数也可用.out为后缀的文件保存在磁盘中,并可随时从磁盘中调入,不经过仿真直接显示在输出窗口中,各种输出窗口中的输出结果均可打印输出。

三、软件仿真功能

TUMIC能对线性多口HMIC/MMIC做四种类型的电路仿真:电路分析、电路优化、成品率分析和成品率优化,其中侧重于成品率分析和成品率优化。用户可灵活地定义仿真中所需的电路参数和仿真输出参数。仿真中可对任意多口网络做噪声分析。无源元件库包含五十多种HMIC/MMIC 常用元件,其中很多元件采用电磁场分析方法建模,具有相当高的精度。有源器件模型(主要是MESFET)采用多种方法表示,可让用户自由选择,为更有效地做成品率分析和成品率优化,对有源器件模型离散特性的表示也有几种更逼真的方法。

仿真类型

TUMIC的四种仿真类型具体说明如下:

?电路分析:分析线性多口HMIC/MMIC网络的S参数,并由S参数得到用户指定的电路性能参数,如增益、驻波比等;对于有噪声网络还能分析出噪声系数。

?电路优化:在电路分析的基础上,自动搜寻最优的电路参数(如元件值、电路尺寸等),使得电路性能参数逼近用户指定的指标。TUMIC的电路优化包含4种优化算法:单纯形法(Simplex)、鲍威尔法(Powell)、标准随机优化(Random)和遗传算法(Genetic)。单纯形法(Simplex)

1-2

1-3

和鲍威尔法(Powell )为局部优化算法,标准随机优化法(Random )和遗传算法(Genetic )为全局优化算法。

? 成品率分析:给定电路参数的公差,在电路分析的基础上,运用蒙特卡罗(Monte Carlo )抽样

分析方法估计电路的成品率,即符合电路指标的电路个数占全部电路数的百分比。TUMIC 的成品率分析有两种算法,除每抽样一次便分析电路一次的标准Monte Carlo 方法外,还提供一种Monte Carlo 改进方法,运用二次模型方法大幅度减少了Monte Carlo 抽样分析中的实际电路分析次数,使得复杂电路的成品率估计效率大为提高。

? 成品率优化:在成品率分析的基础上,自动搜寻电路参数的最优中心值,使得电路成品率最高。

TUMIC 的成品率优化采用的是高效的多准则中心值选优算法,能使复杂电路的成品率优化得以顺利进行。

电路参数和仿真输出参数的定义

软件中全部电路参数均可定义成两种形式:固定的数值或变量,根据不同仿真类型的需要,对于变量可指定其公差、分布率和优化时的上下限等。电路仿真的基本输出参数为S 参数和噪声系数,用户可在基本参数的基础上定义任意输出参数的表达式,为方便使用,软件中为增益、驻波比等常用参数预定义了表达式,用户可选择使用。

多口噪声分析

通常只对二口网络定义了噪声系数,本软件将噪声系数的定义扩充到多口情况,计算多口网络的噪声系数。

本软件对N 口网络噪声系数的定义如下:

nk

lk N

l i i ni li nal lk P G P G P F ∑≠=+

=,1 式中lk F 定义为以k 口输入l 口输出的噪声系数,nal P 为网络内部噪声在l 口的资用功率输出,li G 为l 口对i 口的资用功率增益,ni P 为i 口的资用输入噪声功率。

无源元件库

本软件的无源元件库包含50余种HMIC/MMIC 常用元件,除基本的集总参数元件和基于半经验公式模型的微带传输线、微带通孔等外,还有几组基于电磁场分析的高精度元件模型, 包括: ? 平面波导模匹配法微带不均匀区模型。不均匀区包括跳变、T 型结、十字结等等。

? 准静态直线法微带多导体耦合线模型。多导体耦合线的范围从2导体耦合线一直到15导体耦

合线。

? 准静态矩量法螺旋电感模型。这种模型采用矩量法计算螺旋电感的对地电容,螺旋电感包括方

形螺旋电感和圆形螺旋电感。

1-4

有源器件模型

本软件中有源器件模型除常用的S 参数文件外,还提供另两种MESFET 模型:MESFET 等效电路模型和MESFET 物理参数等效模型。这两种模型均以集总电路形式表征MESFET ,所不同的是:等效电路模型参数是集总元件值,而物理参数等效模型中有很多参数是MESFET 的物理结构、掺杂等。为在成品率分析和优化中考虑器件的离散性,本软件结合上述几种模型形式提供这样几种统计模型:对于S 参数文件可直接对各参数的模和相角取公差,也可采用“Truth ”模型,即提供大量器件S 参数测量数据供Monte Carlo 抽样时随机抽取;对于等效电路模型对各参数取公差;对于物理参数等效模型,除对各参数取公差外,还可给出修正参数,用于提高模型精度。

四、基本操作

启动TUMIC

TUMIC 的启动与在Windows 95/ Windows 98中启动一般应用程序一样,可在Start Menu 的Programs 菜单中选择TUMIC 的菜单项,也可在桌面上双击TUMIC 的图标。TUMIC 启动后先在屏幕中央显示标明软件名称和版本的画面,待主窗口显示完成后,该画面自动消失,进入接受用户命令状态。

使用主窗口

tumic软件介绍

1-5

TUMIC 启动后即进入主窗口。主窗口是一个标准Windows 窗口,除具有选择执行各种命令的顶部菜单和显示当前状态的底部状态条外,菜单下方有两个工具条,包含与菜单命令一一对应的快捷按钮,窗口左部还有一个工具箱,包含添加所有电路元件的快捷按钮。工具条、状态条和工具箱均可隐藏。这里的两个图分别是中文和英文主窗口。

使用输出窗口

输出窗口用于显示仿真输出结果。四种输出窗口的共同特点是:顶部菜单用于选择所显示的仿真结果和坐标配置,底部的状态条(表格窗口没有状态条)用于显示当前鼠标在图中指向的坐标值。输出窗口的具体使用方法在第四章介绍。

使用菜单

TUMIC 中全部用户操作均可使用菜单完成。主窗口和各输出窗口中的菜单项在下一节中做简单介绍,其具体用法在后几章中详细解释。当用户将鼠标指向任一菜单条时,窗口下端在状态条处给出这一菜单命令的解释,方便用户操作。

使用工具条

TUMIC 主窗口有两个工具条,包含有绝大多数菜单命令的快捷图标按钮。将鼠标移至这些快捷图标按钮上并等待半秒钟后,按钮旁出现黄色工具提示框,显示对应的菜单名;在快捷图标按钮上按下鼠标左键,窗口下端在状态条处同样给出这一菜单命令的解释。

tumic软件介绍

单击快捷图标按钮与选取对

应菜单执行的操作完全相同,但更为便捷。通过选取主窗口的菜单项View/Common Toolbar (查看/常用工具栏)和View/Operator Toolbar(查看/操作工具栏)可以隐藏/显示这两个工具条。

使用浮动菜单

在TUMIC主窗口中,点击鼠标右键激活浮动菜单,包含一些当前操作中常用的菜单命令,选择这些命令可加快操作过程。

使用元件工具箱

TUMIC主窗口左端的元件工具箱与工具条的作用相似,包含添加全部元器件的快捷图标按钮,与菜单中的元器件添加命令完全对应,用法与工具条一致。通过选取主窗口的菜单项View/Element Palette(查看/元件栏)可以隐藏/显示这个工具箱。

使用状态信息条

TUMIC主窗口下端的状态条显示当前电路图编辑状态以及键盘中几个键的当前状态,这些状态显示用于方便用户的操作。几个输出窗口下端也有状态条,显示当前鼠标位置对应的坐标值,并随鼠标的移动及时地更新,便于用户读图。通过选取主窗口的菜单项View/Status Bar(查看/状态信息栏)可以隐藏/显示这个状态条。

使用对话框

TUMIC中全部参数输入均采用对话框完成。各种对话框虽功能不同,但都具有共同的特点。所有对话框均包含有按钮、列表框、组合框、编辑框等几种控制,均含有OK(确定)和Cancel(取消)两个特殊按钮。点按OK (确定)可关闭对话框,并使参数输入生效;点按Cancel(取消)也可关闭对话框,但使参数输入全部失效。

使用计算器工具

计算器窗口可以计算微带线特性和常规算术运算,详见第7 章

使用仿真信息窗口

TUMIC的仿真信息窗口显示正在进行的电路仿真的执行状态、出错信息以及执行结果,如电路的成品率等。用户可根据这些信息来查错、是否继续做优化、是否应强行终止仿真。通过选取主窗口的菜单项View/Simulation Message(查看/仿真信息)可以隐藏/显示这个窗口。

关闭TUMIC

在主窗口中选取菜单项File/Exit(文件/退出),屏幕中央出现提问框,问用户是否想关闭TUMIC 关闭TUMIC,点按OK(确定) 键即可关闭TUMIC。如果当前电路图修改后尚未存盘,在提问框出现前还会询问用户是否存盘。

1-6

1-7 五、菜单命令简述

以下分别列出主窗口和四个输出窗口的全部菜单项。对于主窗口,在菜单项旁边同时列出工具条中对应的快捷鼠标按钮。

主窗口菜单

1. File (文件)

(1) New (新建)

tumic软件介绍

新建一个电路文件 (2) Open (打开)… 打开一个已有电路文件 (3) Save (保存) 将电路图和全部参数保存在打开的电路文件中

tumic软件介绍

(4) Save As (另存为)… 将电路图和全部参数另存在一个电路文件中

tumic软件介绍

(5) Print (打印)…

tumic软件介绍

打印当前窗口显示的电路图 (6) Page Setup (页面设置)… 设置打印页面 (7) Exit (退出)

退出TUMIC 2. Edit (编辑) (1) Rotate (旋转)

tumic软件介绍

旋转一个欲添加或选中的元件 (2) Mirror (镜像)

对一个欲添加或选中的元件镜像 (3) Cut (剪切)

tumic软件介绍

tumic软件介绍

将选中的元件、连线或块剪切入裁剪板 (4) Copy (复制) 将选中的元件、连线或块复制入裁剪板 (5) Paste (粘贴)

tumic软件介绍

将裁切板中的内容粘贴到电路图中 (6) Delete (删除)

tumic软件介绍

删除元件,连线或块 (7) Undelete (恢复)

恢复上一次删除的内容

tumic软件介绍

(8) Select All (全选)

tumic软件介绍

tumic软件介绍

选中电路图中全部的连线和元件 3. View (查看) (1) Redraw (重画)

重画电路(2) Zoom In (放大) 放大电路到原来的两倍

tumic软件介绍

(3) Zoom Out (缩小) 缩小电路到原来的1/2

tumic软件介绍

(4) Full Screen (全屏) 全屏显示电路

tumic软件介绍

(5) Default View (缺省) 恢复最初状态大小的电路显示

tumic软件介绍

(6) Simulation Message (仿真信息) 显示/隐藏分析进度信息显示窗口

tumic软件介绍

(7) Common Toolbar (常用工具栏) 显示/隐藏一般操作工具条

(8) Operating Toolbar (操作工具栏)

显示/隐藏电路操作工具条 (9) Element Palette (元件栏)

显示/隐藏电路元件工具箱 (10) Status Bar (状态信息条)

显示/隐藏状态条 4. Place (放置)

(1) Wire (连线)

添加连线 (2) Element (元件) ?

添加元件

tumic软件介绍

1-8

a.

Lumped (集总元件) 添加各个集总参数元件 b.

Microstrip (微带元件) 添加各个微带元件 c.

S Parameter (S 参数元件) 添加各个S 参数元件 d. Device (有源器件) 添加各个三极管、FET 等元件

(3) Done (结束)

结束添加连线、元件 5. Parameters (参数) (1) Unit (单位)

打开单位定义窗口 (2) Variable (变量)

打开变量定义窗口 (3) Substrate (基片) 打开基片参数定义窗口

(4) Frequency (频率) 打开频率分析范围定义窗口

(5) Output (输出)

打开输出变量定义窗口 (6) Opt/Yield Goal (优化/成品率目标) 打开优化/成品率目标定义窗口 (7) Misc (杂项)

打开其它参数定义窗口 6. Simulate (仿真)

(1) Analysis (分析) 执行电路分析

(2) Optimization (优化) 执行电路优化

(3) Yield Analysis (成品率分析) 执行成品率分析

(4) Yield Optimization (成品率优化) 执行成品率优化

(5) Update Variables (更新

参数) 更新优化变量值 (6) Stop (终止仿真)

强行终止仿真 7. Result (结果)

(1) Table (表格)

打开一个表格输出窗口 (2) Grid (直角坐标)

打开一个直角坐标输出窗口 (3) Smith (圆图)

打开一个Smith 圆图输出窗口 (4) Histogram (直方图) 打开一个直方图输出窗口

(5) Close All Charts (关闭所有结果显示) 关闭全部输出窗口 (6) Load Result (调出已存结果)

调出并显示输出文件 (7) Save Result (保存仿真结果) 将仿真结果保存到输出文件

8. Tools (工具) (1) Input File Viewer (查看输入文件)

启动文本显示程序显示仿真输入文件 (2) Output File Viewer (查看输出文件)

启动文本显示程序显示仿真输出文件 (3) Options (选项)

更改设置 9. Help (帮助)

(1) Content (内容) 查看帮助内容

tumic软件介绍

tumic软件介绍

tumic软件介绍

tumic软件介绍

tumic软件介绍

tumic软件介绍

tumic软件介绍

tumic软件介绍

tumic软件介绍

tumic软件介绍

tumic软件介绍

tumic软件介绍

tumic软件介绍

tumic软件介绍

tumic软件介绍

tumic软件介绍

tumic软件介绍

tumic软件介绍

tumic软件介绍

tumic软件介绍

(2) Elements (元件) 查看元件帮助

(3) About (关于) 查看软件版本信息

表格输出窗口(Table)菜单

1.File (文件)

(1) Print (打印)…打印数据表

(2) Exit (退出) 关闭窗口

2.Option (选项)

(1) Variable (变量)…选择输出变量

方格输出窗口(Grid)菜单

1.File (文件)

(1) Print (打印)…打印曲线

(2) Page setup (页面设置)…打印页面

(3) Exit (退出) 关闭窗口

2.Option (选项)

(1) Variable (变量)…选择输出变量

(2) Coord (坐标)…设置坐标

Smith圆图输出窗口(Smith)菜单

1.File (文件)

(1) Print (打印)…打印曲线

(2) Page setup (页面设置)…打印页面

(3) Exit (退出) 关闭窗口

2.Option (选项)

(1) Variable (变量)…选择输出变量

直方图输出窗口(Histogram)菜单

1.File (文件)

(1) Print (打印)…打印曲线

(2) Page setup (页面设置)…打印页面

(3) Exit (退出) 关闭窗口

2.Option (选项)

(1) Variable (变量)…选择输出变量

1-9