文档库

最新最全的文档下载
当前位置:文档库 > 中兴3928交换机配置

中兴3928交换机配置

4.1 3928交换机的基本操作

3928交换机是中兴公司的3层交换设备。使用CCS2000客户端将1#—5#中任意1台空闲的3928加入到队列中,连接设备串口。

基本操作:

3928#show running-config //查看配置信息

3928#show logfile //查看交换机日志

3928#show logging alarm //查看系统警告信息

3928>enable //进入特权模式

3928#configure terminal //进入全局配置模式

3928(config)#enable secret zxr10 //设置enable密码为zxr10

3928(config)#username zxr10 password zxr10 // 配置一个用户名密码都是zxr10的用户,

远程登陆可用

3928(config)#who //查看当前用户

3928(config)#show username //查看配置的用户信息,可显示用户名和密码

3928(config)#interface //进入端口配置模式

3928(config-if)#shutdown/no shutdown //关闭/打开以太网端口

3928(config-if)#negotiation auto/no negotiation auto //打开/关闭以太网端口自动协商

3928(config-if)#duplex //设置以太网端口双工模式

3928(config-if)#speed //设置以太网端口速率

3928(config-if)#flowcontrol //设置以太网端口流量控制

3928(config-if)#jumbo-fram e/no jumbo-fram e //允许/禁止巨帧通过以太网端口3928(config-if)#byname //设置端口别名

3928(config-if)#broadcast-limit //设置以太网口广播风暴抑制,当设置为100M时,表示不抑制

4.4 3928交换机VLAN配置

3928交换机是中兴公司的3层交换设备。使用CCS2000客户端将1#—5#中任意2台空闲的3928加入到队列中,连接设备串口。分别命名为3928A和3928B,用交叉网线连接两台交换机快速以太网口。任意4台PC编号PC1到PC4,PC1和PC2配线架上的接口用网线连接3928A的快速以太网口,PC3和PC4连接3928B。具体实验拓扑图如下:

3928A具体配置:

3928A(config)#vlan 10 //创建vlan 10

3928A(config-vlan)#exit

3928A(config)#vlan 20

3928A(config-vlan)#exit

3928A(config)#interface fei_1/1

3928A(config-if)#switchport access vlan 10 //把端口fei_1/1加入vlan 10,模式为access

3928A(config-if)#exit

3928A(config)#interface fei_1/2

3928A(config-if)#switchport access vlan 20 //把端口fei_1/2加入vlan 20,模式为access

3928A(config-if)#exit

3928A(config)#interface fei_1/16

3928A(config-if)#switchport m ode trunk

3928A(config-if)#switchport trunk vlan 10 //把端口fei_1/16以trunk模式加入vl an10,20

3928A(config-if)#switchport trunk vlan 20

3928B具体配置:

3928A(config)#vlan 10 //创建vlan 10

3928A(config-vlan)#exit

3928A(config)#vlan 20

3928A(config-vlan)#exit

3928A(config)#interface fei_1/1

3928A(config-if)#switchport access vlan 10 //把端口fei_1/1加入vlan 10,模式为access

3928A(config-if)#exit

3928A(config)#interface fei_1/2

3928A(config-if)#switchport access vlan 20 //把端口fei_1/2加入vlan 20,模式为access

3928A(config-if)#exit

3928A(config)#interface fei_1/16

3928A(config-if)#switchport m ode trunk

3928A(config-if)#switchport trunk vlan 10 //把端口fei_1/16以trunk模式加入vl an10,20

3928A(config-if)#switchport trunk vlan 20

实验结果验证:

PC1和PC2不能互相ping通,PC3和PC4不能互相ping通;

PC1和PC3能互相ping通,PC2和PC4能互相ping通。

实验结论:

同一vlan下的设备可以互通,不同vlan下的设备不能互通;通过trunk端口可以实现vla n透传

4.6 交换机静态路由实验

使用CCS2000客户端将1#—5#中任意2台空闲的3928加入到队列中,连接设备串口。分别命名为3928A和3928B,用交叉网线连接两台交换机快速以太网口。任意2台PC编号PC 1和PC2,分别连接3928A和3928B的快速以太网口。具体实验拓扑图如下:

3928A具体配置:

3928A(config)#vlan 2

3928A(config-vlan)#switchport pvid fei_2/1 //接PC1 3928A(config-vlan)#exit

3928A(config)#interface vlan 2

3928A(config-if)#ip add 10.1.3.1 255.255.255.0

3928A(config-if)#exit

3928A(config)#interface fei_3/1 //接3928B 3928A(config-if)#switchport access vlan 3

3928A(config-if)#exit

3928A(config)#interface vlan 3

3928A(config-if)#ip address 192.168.1.1 255.255.255.252 3928A(config-if)#exit

3928A(config)#ip route 10.2.1.0 255.255.255.0 192.168.1.2 3928A(config)#ip route 10.2.2.0 255.255.255.0 192.168.1.2 3928A(config)#ip route 10.2.3.0 255.255.255.0 192.168.1.2 (以上三行命令可用以下缺省路由命令代替:

3928A(config)#ip route 0.0.0.0 0.0.0.0 192.168.1.2)

3928B具体配置

3928B(config)#vlan 2

3928B(config-vlan)#switchport pvid fei_2/1 //接PC2 3928B(config-vlan)#exit

3928B(config)#interface vlan 2

3928B(config-if)#ip add 10.2.3.1 255.255.255.0

3928B(config-if)#exit

3928B(config)#interface fei_3/1 //接3928A 3928B(config-if)#switchport access vlan 3

3928B(config-if)#exit

3928B(config)#interfac e vlan 3

3928B(config-if)#ip address 192.168.1.2 255.255.255.252 3928B(config-if)#exit

3928B(config)#ip route 10.1.1.0 255.255.255.0 192.168.1.1 3928B(config)#ip route 10.1.2.0 255.255.255.0 192.168.1.1 3928B(config)#ip route 10.1.3.0 255.255.255.0 192.168.1.1 (以上三行命令可用以下缺省路由命令代替:

3928B(config)#ip route 0.0.0.0 0.0.0.0 192.168.1.1)

实验结果验证:

显示路由表(show ip route)查看出现那些路由;

观察PC1与PC2直接能否ping通,有无丢包。