文档库

最新最全的文档下载
当前位置:文档库 > 实验2:多区域集成的IS-IS

实验2:多区域集成的IS-IS

19.3 实验2:多区域集成的IS-IS 1.实验目的

通过本实验可以掌握:

①在路由器上启动IS-IS路由进程;

②启用参与路由协议的接口;

③L1 和L2路由的区别;

④配置L1 或L2路由器;

⑤配置电路类型;

⑥配置区域间路由汇总;

⑦通告默认路由;

⑧配置IS-IS人证;

⑨查看和调试多区域IS-IS路由协议相关信息。

2.拓扑结构

实验拓扑图如图19-2所示。

实验2:多区域集成的IS-IS

图19-2 多区域集成的IS-IS

【说明】

IS-IS区域的划分是基于路由器的,也就是说,一个路由器只能属于一个区域,而OSPF区域的划分是基于链路的。

3.实验步骤

(1)步骤1:配置路由器R1

R1(config)#router isis

R1(config-router)#net 49.0001.1111.1111.1111.00

R1(config-router)#is-type level-1 //将R1配置成L1路由器

R1(config-router)#area-password area //启用区域认证

R1(config)#interface Loopback0

R1(config-if)#ip address 1.1.1.1 255.255.255.0

R1(config-if)#ip router isis

R1(config)#interface Serial0/0/0

R1(config-if)#ip address 192.168.12.1 255.255.255.0

R1(config-if)#ip router isis

R1(config-if)#isis password neighbor level-1 //启用level 1邻居认证

R1(config-if)#no shutdown

(2)步骤2:配置路由器R2

R2(config)#router isis

R2(config-router)#net 49.0001.2222.2222.2222.00

R2(config-router)#default-information originate //想IS-IS区域注入默认路由R2(config-router)#area-password area

R2(config-router)#domain-password domain //启用域认证

R2(config)#interface Serial0/0/0

R2(config-if)#ip address 192.168.12.2 255.255.255.0

R2(config-if)#clockrate 128000

R2(config-if)#ip router isis

R2(config-if)#isis password neighbor level-1

R2(config-if)#no shutdown

R2(config)#interface Serial0/0/1

R2(config-if)#ip address 192.168.12.2 255.255.255.0

R2(config-if)#ip router isis

R2(config-if)#clockrate 128000

R2(config-if)#no shutdown

(3)步骤3:配置路由器R3

R3(config)#router isis

R3(config-router)#net 49.0002.3333.3333.3333.00

R3(config-router)#is-type level-2-only //将R3配置成L2路由器

R3(config-router)#domain-password domain

R3(config-router)#domain-password domain //启用域认证

R3(config)#interface Serial0/0/0

R3(config-if)#ip address 192.168.34.3 255.255.255.0

R3(config-if)#ip router isis

R3(config-if)#isis circuit-type level-2-only //配置接口电路类型

R3(config-if)#isis password neihborpassword level-2 // 启用level-2邻居认证

R3(config-if)#clockrat 128000

R3(config-if)#no shutdown

R3(config)#interface Serial0/0/1

R3(config-if)#ip address 192.168.23.3 255.255.255.0

R3(config-if)#ip router isis

R3(config-if)#no shutdown

(4)步骤4:配置路由器R4

R4(config)#router isis

R4(config-router)#net 49.0003.4444.4444.4444.00

R4(config-router)#summary-address 4.4.0.0 255.255.255.0//配置区域间路由汇总R4(config-router)#is-type level-2-only

R4(config-router)#domain-password domain

R4(config)#interface Loopback0

R4(config-if)#ip address 4.4.0.4 255.255.255.0

R4(config-if)#ip router isis

R4(config)#interface Loopback1

R4(config-if)#ip address 4.4.1.4 255.255.255.0

R4(config-if)#ip router isis

R4(config)#interface Loopback2

R4(config-if)#ip address 4.4.2.4 255.255.255.0

R4(config-if)#ip router isis

R4(config)#interface Loopback3

R4(config-if)#ip address 4.4.3.4 255.255.255.0

R4(config-if)#ip router isis

R4(config-if)#interface Serial0/0/0

R4(config-if)#ip address 192.168.34.4 255.255.255.0

R4(config-if)#ip router issi

R4(config-if)#isis circuit-type lvel-2-only

R4(config-if)#isis password neihborpassword level-2

R4(config-if)#no shutdown

【技术要点】

IS-IS的认证只限于明文口令,Cisco 的IOS支持3个级别的认证:

①邻居认证——相互连接的路由器接口必须配置相同的口令,同时必须为L1和L2类型的邻居关系配置各自的认证,L1邻居认证的密码和L2邻居认证密码可以不同。邻居认证通过命令”isis password”配置。在本实验中,R1和R2之间的串行链路启用Level-1的邻居认证,而且R3和R4之间的串行链路起用Level-2的邻居认证。

②区域认证——区域内的每台路由器必须执行认证,并且必须使用相同的口令。区域认证通过命令”area-password”配置。本实验中区域“49.0001”启用区域认证。

③域认证——域内的每一个L2和L1/L2类型的路由器必须执行认证,并且必须使用相同的口令。域认证通过命令”domain-password”配置。在本实验中R2,R3和R4都配置域认证,因为路由器R1是L1路由器,所以不用配置域认证。

4.实验调试

(1)show isis database

R1#show isis database

IS-IS Level-1 Link State Database;

LsPID LSP Seq Num LSP Checksum LSP Holdtime ATT/P/OL

R1.00-00 *0x0000003B 0x1F72 659 0/0/0

R2.00-00 0x00000039 0x9DEE 658 1/0/0

R2#show isis database

IS-IS Level-1 Link State Database;

LsPID LSP Seq Num LSP Checksum LSP Holdtime ATT/P/OL

R1.00-00 0x00000008 0x8161 993 1/0/0

R2.00-00 *0x00000007 0x02BC 902 1/0/0

IS-IS Level-2 Link State Database;

LsPID LSP Seq Num LSP Checksum LSP Holdtime ATT/P/OL

R1.00-00 0x00000009 0xE455 1120 0/0/0

R2.00-00 *0x00000006 0xFFFD 903 0/0/0

R3.00-00 0x00000009 0xE9C4 1039 0/0/0

R4.00-00 0x0000000B 0xC040 1110 0/0/0

R3#show isis database

IS-IS Level-2 Link State Database;

LsPID LSP Seq Num LSP Checksum LSP Holdtime ATT/P/OL

R2.00-00 0x0000003B 0xC0D2 1036 0/0/0

R3.00-00 *0x00000044 0x0FE3 1043 0/0/0

R4.00-00 0x00000046 0xEC58 1041 0/0/0

以上输出表明:

①R1路由器为L1路由器,只维护L1的链路状态数据库;

②R2路由器为L1/L2路由器,同时为L1和L2维护单独的链路状态数据库,也表明所在区域有另一台路由器R1;

③R3和R4路由器为L2路由器,只维护L2的连接状态数据库。

(2)show ip route

R2#show ip isis

iL1 192.168.23.0/24[115/20]via 192.168.12.2,Serial0/0/0

i*L1 0.0.0.0/0[115/10]via 192.168.12.2,Serial0/0/0

R2#show ip route isis

1.0.0.0/24 is subnetted,1 subnets

iL1 1.1.1.0[115/20]via 192.168.12.1,Serial0/0/0

4.0.0.0/22 is subnetted,1 subnets

iL1 4.4.0.0[115/30]via 192.168.23.3.Serial0/0/1

iL2 192.168.34.0/24[115/20]via 192.168.23.3,Serial0/0/1

R3#show ip route isis

iL2 192.168.12.0/24[115/20]via 192.168.23.2,Serial0/0/1

1.0.0.0/24 is subnetted,1 subnets

iL2 1.1.1.0[115/30]via 192.168.23.2,Serial0/0/1

4.0.0.0/22 is subnetted,1 subnets

iL2 4.4.0.0[115/20]via 192.168.34.4,Serial0/0/0

i*L2 0.0.0.0/0[115/20]via 192.168.23.2,Serial0/0/1

R4#show ip route isis

iL2 192.168.12.0/24[115/30]via 192.168.34.3,Serial0/0/0

1.0.0.0/24 is subnetted,1 subnets

iL2 1.1.1.0[115/40]via 192.168.34.3,Serial0/0/0

4.0.0.0/8 is variably subnetted,5 subnets,2 masks

isu 4.4.0.0/22[115/10]via 0.0.0.0,Null0

iL2 192.168.23.0/24[115/20]via 192.168.34.3,serial0/0/0

i*L2 0.0.0.0/0[115/20]via 192.168.34.3,Serial0/0/0

以上输出表明:

①由于R1为L1路由器,所以只有”i L1”的路由和一条到最近的L1/L2路由器的默认路由”i*L1”;

②由于R1和R2在一个区域,所以R2既有”iL1”的路由,又有”iL2”的路由;

③R3和R4都是L2路由器,所以只有”i L2”的路由;

④R3和R4都收到一条由R2注入的默认路由”i*L2”;

⑤R2和R3都收到R4的汇总路由,同时R4的路由表自动生成一条”i su”的路由条目,主要是为了避免路由环路。

(3)show clns iterface

R3#show clns interface0/0/0

serial0/0/0 is up,line protocol is up

Checksums enabled,MTU 1500,Encapsulation HDLC

ERPDUs enabled,min.interval 10 msec.

CLNS fast switching enabled

CLNS SSE swiching enabled

DEC compatibilty mode OFF for this interface

Next ESH/ISH in 12 seconds

Routing Protocol;IS-IS

Circuit Type;level-2

......

从以上输出可以看到,接口的电路类型为”level-2”