文档库

最新最全的文档下载
当前位置:文档库 > 最详细的C300开局脚本

最详细的C300开局脚本

en(密码zxr10)

进入特权模式

ZXAN#dir cfg

查看是否有过配置

如果看到

startrun.sav

startrun.dat

那么表示有配置,需要删除配置,然后重启设备

ZXAN#:delete cfg startrun.sav

ZXAN#:delete cfg startrun.dat

删除配置

Reboot

重启设备

重启完之后

en(密码zxr10)

进入特权模式

oconfigure terminal

进入全局模式

add-rack rackno 1 racktype IEC19

添加机架

add-shelf rackno 1 shelfno 1 shelftype IEC_SHELF 添加框

add-card rackno 1 shelfno 1 slotno 0 PRWG

add-card rackno 1 shelfno 1 slotno 1 PRWG

add-card rackno 1 shelfno 1 slotno 2 ETGO

add-card rackno 1 shelfno 1 slotno 3 ETGO

add-card rackno 1 shelfno 1 slotno 4 ETGO

add-card rackno 1 shelfno 1 slotno 5 ETGO

add-card rackno 1 shelfno 1 slotno 6 ETGO

add-card rackno 1 shelfno 1 slotno 7 ETGO

add-card rackno 1 shelfno 1 slotno 8 ETGO

add-card rackno 1 shelfno 1 slotno 9 ETGO

add-card rackno 1 shelfno 1 slotno 12 ETGO

add-card rackno 1 shelfno 1 slotno 13 ETGO

add-card rackno 1 shelfno 1 slotno 14 ETGO

add-card rackno 1 shelfno 1 slotno 15 ETGO

add-card rackno 1 shelfno 1 slotno 16 ETGO

add-card rackno 1 shelfno 1 slotno 17 ETGO

add-card rackno 1 shelfno 1 slotno 18 CICG

add-card rackno 1 shelfno 1 slotno 19 GUSQ

add-card rackno 1 shelfno 1 slotno 20 GUSQ

添加板卡,如果当前插槽上没有板卡的话,就不要添加

hostname MXYQQ-C300-16

设备命名

命名规则为:局名缩写+分区缩写-设备名称-序列号

vlan database

vlan 1,6,9-39,2010-2039,2500-2699,3991-3992

vlan 3997,4000

ex

创建VLAN

interface vlan 9

ip address 10.169.104.41 255.255.255.0

ex

进入VLAN 9(OLT管理vlan)

添加IP地址和子网掩码

interface vlan3997

ip proxy-arp

Ex

进入VLAN 3997(VLAN 3997 为语音)

开启代理ARP

interface vlan 6

ip address 172.16.0.1 255.255.224.0

ex

进入VLAN 6(ONU管理VLAN)

添加IP地址

mpnat onu-mng-vlan 6

定义VLAN 6为ONU管理VLAN

ip route 123.124.120.0 255.255.255.0 10.169.104.1

ntp server 123.124.120.66

ntp source 10.169.104.41

ntp enable

添加静态路由

添加时间同步服务器

开启时间同步

clock timezone BJT 8 0

时区为北京时间

interface vlan 3991

ip address 10.100.60.154 255.255.255.252

ip ospf hello-interval 3

ip ospf network point-to-point

ex

进入VLAN 3991(VLAN 3991为OSPF通讯VLAN)添加ip地址

ospf每三秒发送一次hello报文

osfp为点对点模式

interface gei_1/19/1

switchport mode hybrid

switchport default vlan 3991

no negotiation auto

duplex full

speed 100

ex

进入1筐19槽1口

接口模式为混合模式

对VLAN 3991进行剥离标签

关闭接口自动协商

全双工模式

速率为100M?

interface vlan 3992

ip address 10.100.60.158255.255.255.252

ip ospf cost 10000

ip ospf hello-interval 3

ip ospf network point-to-point

ex

进入VLAN 3992(VLAN 3992为OSPF通讯VLAN)添加ip地址

OSPF-COST值设定10000

ospf每三秒发送一次hello报文

osfp为点对点模式

interface gei_1/20/1

switchport mode hybrid

switchport default vlan 3992

no negotiation auto

duplex full

speed 100

ex

进入1筐20槽1口

接口模式为混合模式

对VLAN 3991进行剥离标签

关闭接口自动协商

全双工模式

速率为100M?

router ospf 900

network 10.100.60.152 0.0.0.3 area 20

network 10.100.60.156 0.0.0.3 area 20

ex

创建ospf进程900

发布IP地址并且划分区域20

interface smartgroup1

port-protect disable

switchport mode hybrid

switchport vlan 9-39,2500-2599 tag

ex

进入聚合组1

关闭用户隔离(端口保护)功能

模式为混合模式

定义打标记的VLAN

interface smartgroup2

port-protect disable

switchport mode hybrid

switchport vlan 2010-2039,2600-2699,4000 tag ex

进入聚合组2

关闭用户隔离(端口保护)功能

模式为混合模式

定义打标记的VLAN?

interface gei_1/19/3

hybrid-attribute fiber

no negotiation auto

Speed 1000

duplex full

flowcontrol disable

port-protect disable

uplink-isolate disable

switchport mode hybrid

switchport vlan 9-39,2500-2599 tag smartgroup 1 mode active

ex

进入1筐19槽3口

混合模式为光纤

关闭接口自动协商

速率为1000M

全双工模式

关闭流量控制

关闭用户隔离(端口保护)功能

混合模式

定义打标记的VLAN

属于聚合组1

interface gei_1/19/4

hybrid-attribute fiber

no negotiation auto

Speed 1000

duplex full

flowcontrol disable

port-protect disable

uplink-isolate disable

switchport mode hybrid

switchport vlan 2010-2039,2600-2699,4000 tag smartgroup 2 mode active

ex

进入1筐19槽4口

混合模式为光纤

关闭接口自动协商

速率为1000M?

全双工模式

关闭流量控制

关闭用户隔离(端口保护)功能

混合模式

定义打标记的VLAN

属于聚合组2

interface gei_1/20/3

hybrid-attribute fiber

no negotiation auto

Speed 1000

duplex full

flowcontrol disable

port-protect disable

uplink-isolate disable

switchport mode hybrid

switchport vlan 9-39,2500-2599 tag smartgroup 1 mode active

ex

进入1筐20槽3口

混合模式为光纤

关闭接口自动协商

速率为1000M

全双工模式

关闭流量控制

关闭用户隔离(端口保护)功能

混合模式

定义打标记的VLAN

属于聚合组1

interface gei_1/20/4

hybrid-attribute fiber

no negotiation auto

Speed 1000

duplex full

flowcontrol disable

port-protect disable

uplink-isolate disable

switchport mode hybrid

switchport vlan 2010-2039,2600-2699,4000 tag smartgroup 2 mode active

ex

进入1筐20槽4口

混合模式为光纤

关闭接口自动协商

速率为1000M

全双工模式

关闭流量控制

关闭用户隔离(端口保护)功能

混合模式

定义打标记的VLAN

属于聚合组2

snmp-server community public view allview rw

snmp-server host 123.124.120.66 trap version 2c public enable NOTIFICATIONS isnmsserver server-index 1 udp-port 162

snmp-server host 123.124.120.70 trap version 2c public enable NOTIFICATIONS isnmsserver server-index 2 udp-port 162

创建SNMP并且设置服务器IP地址

epon

ems-report 1/2 unauthonu enable

ems-report 1/3 unauthonu enable

ems-report 1/4 unauthonu enable

ems-report 1/5 unauthonu enable

ems-report 1/6 unauthonu enable

ems-report 1/7 unauthonu enable

ems-report 1/8 unauthonu enable

ems-report 1/9 unauthonu enable

ems-report 1/12 unauthonu enable

ems-report 1/13 unauthonu enable

ems-report 1/14 unauthonu enable

ems-report 1/15 unauthonu enable

ems-report 1/16 unauthonu enable

ems-report 1/17 unauthonu enable

设备PON板卡用户自动认证

voip-vlan profile CNCRMS tag-mode tag cvlan 3997 priority 7

h248-profile CNCRMS register-server ip 10.0.98.2port 2944

h248-profile CNCRMS backup-register-server ip 10.0.98.66port 2944

h248-profile CNCRMS heartbeat-mode h248ctc rtp-link-test disable cycle 120 count 2

h248-profile CNCRMS mg register-mode ip port 2944

onu-sla-profile profile-name create public

onu-sla-profile profile-set public downstream maximum 999994 maxburst 16777215 onu-sla-profile profile-set public upstream assured 10000 maximum 25000

创建语音IP、VLAN、软交换协议模板、带宽模板

auto-dispatch-set ZTE-F821 disable

关闭ZTE-F821

Ex

pon

ip-pool p1 begin 172.16.0.2 end 172.16.31.254 255.255.224.0 vlan 6 priority 5 route 123.124.120.0 255.255.255.0 172.16.0.1

ip-pool-bind epon-olt_1/2/1 p1

ip-pool-bind epon-olt_1/2/2 p1

ip-pool-bind epon-olt_1/2/3 p1

ip-pool-bind epon-olt_1/2/4 p1

ip-pool-bind epon-olt_1/2/5 p1

ip-pool-bind epon-olt_1/2/6 p1

ip-pool-bind epon-olt_1/2/7 p1

ip-pool-bind epon-olt_1/2/8 p1

ip-pool-bind epon-olt_1/3/1 p1

ip-pool-bind epon-olt_1/3/2 p1

ip-pool-bind epon-olt_1/3/3 p1

ip-pool-bind epon-olt_1/3/4 p1

ip-pool-bind epon-olt_1/3/5 p1

ip-pool-bind epon-olt_1/3/6 p1

ip-pool-bind epon-olt_1/3/7 p1

ip-pool-bind epon-olt_1/3/8 p1

ip-pool-bind epon-olt_1/4/1 p1

ip-pool-bind epon-olt_1/4/2 p1

ip-pool-bind epon-olt_1/4/3 p1

ip-pool-bind epon-olt_1/4/4 p1

ip-pool-bind epon-olt_1/4/5 p1

ip-pool-bind epon-olt_1/4/6 p1

ip-pool-bind epon-olt_1/4/7 p1

ip-pool-bind epon-olt_1/4/8 p1

ip-pool-bind epon-olt_1/5/1 p1

ip-pool-bind epon-olt_1/5/2 p1

ip-pool-bind epon-olt_1/5/3 p1

ip-pool-bind epon-olt_1/5/4 p1

ip-pool-bind epon-olt_1/5/6 p1 ip-pool-bind epon-olt_1/5/7 p1 ip-pool-bind epon-olt_1/5/8 p1 ip-pool-bind epon-olt_1/6/1 p1 ip-pool-bind epon-olt_1/6/2 p1 ip-pool-bind epon-olt_1/6/3 p1 ip-pool-bind epon-olt_1/6/4 p1 ip-pool-bind epon-olt_1/6/5 p1 ip-pool-bind epon-olt_1/6/6 p1 ip-pool-bind epon-olt_1/6/7 p1 ip-pool-bind epon-olt_1/6/8 p1 ip-pool-bind epon-olt_1/7/1 p1 ip-pool-bind epon-olt_1/7/2 p1 ip-pool-bind epon-olt_1/7/3 p1 ip-pool-bind epon-olt_1/7/4 p1 ip-pool-bind epon-olt_1/7/5 p1 ip-pool-bind epon-olt_1/7/6 p1 ip-pool-bind epon-olt_1/7/7 p1 ip-pool-bind epon-olt_1/7/8 p1 ip-pool-bind epon-olt_1/8/1 p1 ip-pool-bind epon-olt_1/8/2 p1 ip-pool-bind epon-olt_1/8/3 p1 ip-pool-bind epon-olt_1/8/4 p1 ip-pool-bind epon-olt_1/8/5 p1 ip-pool-bind epon-olt_1/8/6 p1 ip-pool-bind epon-olt_1/8/7 p1 ip-pool-bind epon-olt_1/8/8 p1 ip-pool-bind epon-olt_1/9/1 p1 ip-pool-bind epon-olt_1/9/2 p1 ip-pool-bind epon-olt_1/9/3 p1 ip-pool-bind epon-olt_1/9/4 p1 ip-pool-bind epon-olt_1/9/5 p1 ip-pool-bind epon-olt_1/9/6 p1 ip-pool-bind epon-olt_1/9/7 p1 ip-pool-bind epon-olt_1/9/8 p1

ip-pool-bind epon-olt_1/12/1 p1 ip-pool-bind epon-olt_1/12/2 p1 ip-pool-bind epon-olt_1/12/3 p1 ip-pool-bind epon-olt_1/12/4 p1 ip-pool-bind epon-olt_1/12/5 p1 ip-pool-bind epon-olt_1/12/6 p1 ip-pool-bind epon-olt_1/12/7 p1

ip-pool-bind epon-olt_1/13/1 p1 ip-pool-bind epon-olt_1/13/2 p1 ip-pool-bind epon-olt_1/13/3 p1 ip-pool-bind epon-olt_1/13/4 p1 ip-pool-bind epon-olt_1/13/5 p1 ip-pool-bind epon-olt_1/13/6 p1 ip-pool-bind epon-olt_1/13/7 p1 ip-pool-bind epon-olt_1/13/8 p1 ip-pool-bind epon-olt_1/14/1 p1 ip-pool-bind epon-olt_1/14/2 p1 ip-pool-bind epon-olt_1/14/3 p1 ip-pool-bind epon-olt_1/14/4 p1 ip-pool-bind epon-olt_1/14/5 p1 ip-pool-bind epon-olt_1/14/6 p1 ip-pool-bind epon-olt_1/14/7 p1 ip-pool-bind epon-olt_1/14/8 p1 ip-pool-bind epon-olt_1/15/1 p1 ip-pool-bind epon-olt_1/15/2 p1 ip-pool-bind epon-olt_1/15/3 p1 ip-pool-bind epon-olt_1/15/4 p1 ip-pool-bind epon-olt_1/15/5 p1 ip-pool-bind epon-olt_1/15/6 p1 ip-pool-bind epon-olt_1/15/7 p1 ip-pool-bind epon-olt_1/15/8 p1

ip-pool-bind epon-olt_1/16/1 p1 ip-pool-bind epon-olt_1/16/2 p1 ip-pool-bind epon-olt_1/16/3 p1 ip-pool-bind epon-olt_1/16/4 p1 ip-pool-bind epon-olt_1/16/5 p1 ip-pool-bind epon-olt_1/16/6 p1 ip-pool-bind epon-olt_1/16/7 p1 ip-pool-bind epon-olt_1/16/8 p1 ip-pool-bind epon-olt_1/17/1 p1 ip-pool-bind epon-olt_1/17/2 p1 ip-pool-bind epon-olt_1/17/3 p1 ip-pool-bind epon-olt_1/17/4 p1 ip-pool-bind epon-olt_1/17/5 p1 ip-pool-bind epon-olt_1/17/6 p1 ip-pool-bind epon-olt_1/17/7 p1 ip-pool-bind epon-olt_1/17/8 p1 向ONU下发IP

onu-type ZTE-F400 epon description 4FE

onu-type-if ZTE-F400 eth_0/1

onu-type-if ZTE-F400 eth_0/2

onu-type-if ZTE-F400 eth_0/3

onu-type-if ZTE-F400 eth_0/4

onu-type F407 epon description 2FE,1POTS

onu-type-if F407 eth_0/1

onu-type-if F407 eth_0/2

onu-type-if F407 pots_1/1

onu-type F417 epon description 4FE,2POTS

onu-type-if F417 eth_0/1

onu-type-if F417 eth_0/2

onu-type-if F417 eth_0/3

onu-type-if F417 eth_0/4

onu-type-if F417 pots_1/1

onu-type-if F417 pots_1/2

onu-type F427 epon description 4FE,2POTS,WIFI onu-type-if F427 eth_0/1

onu-type-if F427 eth_0/2

onu-type-if F427 eth_0/3

onu-type-if F427 eth_0/4

onu-type-if F427 pots_1/1

onu-type-if F427 pots_1/2

onu-type 220G epon description 4FE,2POTS,WIFI onu-type-if 220G eth_0/1

onu-type-if 220G eth_0/2

onu-type-if 220G eth_0/3

onu-type-if 220G eth_0/4

onu-type-if 220G pots_1/1

onu-type-if 220G pots_1/2

onu-type 221G epon description 2FE,1POTS

onu-type-if 221G eth_0/1

onu-type-if 221G eth_0/2

onu-type-if 221G pots_1/1

onu-type 226G epon description 4FE,2POTS

onu-type-if 226G eth_0/1

onu-type-if 226G eth_0/2

onu-type-if 226G eth_0/3

onu-type-if 226G eth_0/4

onu-type-if 226G pots_1/1

onu-type-if 226G pots_1/2

onu-type 321R epon description 2FE,1POTS

onu-type-if 321R eth_0/1

onu-type-if 321R eth_0/2

onu-type-if 321R pots_1/1

onu-type 342R epon description 4FE,2POTS

onu-type-if 342R eth_0/1

onu-type-if 342R eth_0/2

onu-type-if 342R eth_0/3

onu-type-if 342R eth_0/4

onu-type-if 342R pots_1/1

onu-type-if 342R pots_1/2

onu-type 346R epon description 4FE,2POTS,WIFI onu-type-if 346R eth_0/1

onu-type-if 346R eth_0/2

onu-type-if 346R eth_0/3

onu-type-if 346R eth_0/4

onu-type-if 346R pots_1/1

onu-type-if 346R pots_1/2

onu-type P800 epon description 4FE,2POTS,WIFI onu-type-if P800 eth_0/1

onu-type-if P800 eth_0/2

onu-type-if P800 eth_0/3

onu-type-if P800 eth_0/4

onu-type-if P800 pots_1/1

onu-type-if P800 pots_1/2

onu-type R200 epon description 4FE,2POTS,WIFI onu-type-if R200 eth_0/1

onu-type-if R200 eth_0/2

onu-type-if R200 eth_0/3

onu-type-if R200 eth_0/4

onu-type-if R200 pots_1/1

onu-type-if R200 pots_1/2

onu-type R201 epon description 4FE,2POTS

onu-type-if R201 eth_0/1

onu-type-if R201 eth_0/2

onu-type-if R201 eth_0/3

onu-type-if R201 eth_0/4

onu-type-if R201 pots_1/1

onu-type-if R201 pots_1/2

ex

新增ONU类型

acl standard number 1

rule 10 permit 123.124.120.64 0.0.0.31

ex

acl standard number 99

rule 10 permit 123.124.120.64 0.0.0.31

rule 20 permit 10.169.104.0 0.0.0.255

访问控制列表

ex

line telnet access-class 99

line telnet idle-timeout 5

snmp-server access-list 1

Telnet 允许的最大数和失联时间

访问列表加在SNMP里

igmp enable

igmp mvlan 4000

igmp mvlan 4000 enable

igmp mvlan 4000 work-mode proxy

igmp mvlan 4000 host-ip 0.0.0.0

igmp mvlan 4000 max-group 1024

igmp mvlan 4000 group-filter enable

igmp mvlan 4000 group 239.1.1.1 to 239.1.1.255 igmp mvlan 4000 group 239.2.1.1 to 239.2.1.255 igmp mvlan 4000 group 239.3.1.1 to 239.3.1.255 igmp mvlan 4000 source-port smartgroup2 mvlan-translate 4000 to 3996

配置IPTV组播数据

mpnat onu-telnet idle-time 5

ONU远程登录的空闲时间为5

fan speed-percent-set 75 80 85 90

风扇转速分75 80 85 90

Auto-write enable

Auto-write 00:00:00 everyday

自动保存

snmp-server packetsize 3000

security port-protect enable

SNMP保护

cpe task V2P2T2H

action Update-reonline

equipment-type F420

match-vertag Equal V2.0.0P2T2H

parallel-limitation 16

mode Both

range ne

service-type EPON

vendor-name ZTE

version-file V2P2T7CP.bin

task add

exit

cpe task V2P2T6DG_H

action Update-reonline

equipment-type F420

match-vertag Equal V2.0.0P2T6DG_H

parallel-limitation 16

mode Both

range ne

service-type EPON

vendor-name ZTE

version-file V2P2T7CP.bin

task add

exit

cpe task V2P2T6H

action Update-reonline

equipment-type F420

match-vertag Equal V2.0.0P2T6H

parallel-limitation 16

mode Both

range ne

service-type EPON

vendor-name ZTE

version-file V2P2T7CP.bin

exit

cpe task V2P2T7BJ_H

action Update-reonline

equipment-type F420

match-vertag Equal V2.0.0P2T7BJ_H parallel-limitation 16

mode Both

range ne

service-type EPON

vendor-name ZTE

version-file V2P2T7CP.bin

task add

exit

cpe task V2P2T7H

action Update-reonline

equipment-type F420

match-vertag Equal V2.0.0P2T7H parallel-limitation 16

mode Both

range ne

service-type EPON

vendor-name ZTE

version-file V2P2T7CP.bin

task add

exit

cpe task V2P2T7HG_H

action Update-reonline

equipment-type F420

match-vertag Equal V2.0.0P2T7HG_H parallel-limitation 16

mode Both

range ne

service-type EPON

vendor-name ZTE

version-file V2P2T7CP.bin

task add

exit

cpe task V2P2T7ZY_H

action Update-reonline

equipment-type F420

match-vertag Equal V2.0.0P2T7ZY_H parallel-limitation 16

mode Both

service-type EPON

vendor-name ZTE

version-file V2P2T7CP.bin

task add

exit

cpe task V2P2T8H

action Update-reonline equipment-type F420

match-vertag Equal V2.0.0P2T8H parallel-limitation 16

mode Both

range ne

service-type EPON

vendor-name ZTE

version-file V2P2T7CP.bin

task add

exit

cpe task V3P1T4H

action Update-reonline equipment-type F420

match-vertag Equal V3.30.00P1T4H parallel-limitation 16

mode Both

range ne

service-type EPON

vendor-name ZTE

version-file V3P3T4.bin

task add

exit

cpe task V3P2T1H

action Update-reonline equipment-type F420

match-vertag Equal V3.30.00P2T1H parallel-limitation 16

mode Both

range ne

service-type EPON

vendor-name ZTE

version-file V3P3T4.bin

task add

exit

cpe task V3P2T2H

action Update-reonline

equipment-type F420

match-vertag Equal V3.30.00P2T2H parallel-limitation 16

mode Both

range ne

service-type EPON

vendor-name ZTE

version-file V3P3T4.bin

task add

exit

cpe task V3P2T3H

action Update-reonline equipment-type F420

match-vertag Equal V3.30.00P2T3H parallel-limitation 16

mode Both

range ne

service-type EPON

vendor-name ZTE

version-file V3P3T4.bin

task add

exit

cpe task V3P3T1H

action Update-reonline equipment-type F420

match-vertag Equal V3.30.00P3T1H parallel-limitation 16

mode Both

range ne

service-type EPON

vendor-name ZTE

version-file V3P3T4.bin

task add

exit

cpe task V3P3T3H

action Update-reonline equipment-type F420

match-vertag Equal V3.30.00P3T3H parallel-limitation 16

mode Both

range ne

service-type EPON

vendor-name ZTE

version-file V3P3T4.bin

task add

exit

ONU补丁

interface epon-olt_1/2/1-8 Shutdown

Ex

interface epon-olt_1/3/1-8 Shutdown

Ex

interface epon-olt_1/4/1-8 Shutdown

ex

interface epon-olt_1/5/1-8 Shutdown

ex

interface epon-olt_1/6/1-8 Shutdown

ex

interface epon-olt_1/7/1-8 Shutdown

ex

interface epon-olt_1/8/1-8 Shutdown

ex

interface epon-olt_1/9/1-8 Shutdown

ex

interface epon-olt_1/12/1-8 Shutdown

ex

interface epon-olt_1/13/1-8 Shutdown

ex

interface epon-olt_1/14/1-8 Shutdown

ex

interface epon-olt_1/15/1-8 Shutdown

ex

关闭接口

clock set 17:14:30 NOV 4 2013 配置时间

EX

write 保存