文档库

最新最全的文档下载
当前位置:文档库 > 王国强波段流星和波段恒星指标公式

王国强波段流星和波段恒星指标公式

1.波段流星指标源码

VAR1:=(CLOSE-LLV(LOW,36))/(HHV(HIGH,36)-LLV(LOW,36))*100; VAR2:=SMA(VAR1,3,1);

VAR3:=SMA(VAR2,3,1);

VAR4:=SMA(VAR3,3,1);

波: VAR3;

段: VAR4;

VAR6:=CROSS(VAR3,VAR4) AND VAR3<20;

DRAWTEXT(FILTER(VAR6,10)=1,40,'底'),LINETHICK3 ;

STICKLINE(FILTER(VAR6,10)=1,0,30,10,0),COLORGREEN ;

VAR7:=CROSS(VAR4,VAR3) AND VAR3>80;

STICKLINE(FILTER(VAR7,5)=1,80,100,10,0),COLORYELLOW ; DRAWTEXT(FILTER(VAR7,5)=1,70,'顶'),LINETHICK3 ,COLORYELLOW; VAR8:=CROSS(VAR2,VAR3) AND VAR3>80 AND VAR3>VAR4; STICKLINE(VAR8,85,100,10,0) ;

RSV:=(CLOSE-LLV(LOW,89))/(HHV(HIGH,89)-LLV(LOW,89))*100;

K89:=SMA(RSV,30,1);

D89:=SMA(K89,3,1);

长K:STICKLINE(D89>=REF(D89,1),D89,REF(D89,1),8,0),COLORWHITE; 长D:STICKLINE(D89

VABR3:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;

VABR4:=SMA(VABR3,3,1);

VABR5:=SMA(VABR4,3,1)+100;

趋势线: 3*SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1)- 2*SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1),3,1),

COLOR00FF00,LINETHICK1;

{WN万能超短买卖}

VAAR1:=CLOSE>REF(CLOSE,1) AND CLOSE>REF(CLOSE,2);

VAAR2:=REF(VAAR1,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2); VAAR3:=REF(VAAR2,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2); VAAR4:=REF(VAAR3,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2); VAAR5:=REF(VAAR4,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2); VAAR6:=REF(VAAR5,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2); VAAR7:=REF(VAAR6,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2); VAAR8:=REF(VAAR7,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2); VAAR9:=REF(VAAR8,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2); VAARA:=REF(VAAR9,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2); VAARB:=REF(VAARA,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2); VAARC:=REF(VAARB,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2); VAARD:=CLOSE

VAARE:=REF(VAARD,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2); VAARF:=REF(VAARE,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);

VAAR10:=REF(VAARF,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2); VAAR11:=REF(VAAR10,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2); VAAR12:=REF(VAAR11,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2); VAAR13:=REF(VAAR12,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2); VAAR14:=REF(VAAR13,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2); VAAR15:=REF(VAAR14,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2); VAAR16:=REF(VAAR15,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2); VAAR17:=REF(VAAR16,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2); VAAR18:=REF(VAAR17,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2); VAAR19:=REF(VAARD OR VAARE OR VAARF OR VAAR10 OR VAAR11 OR VAAR12 OR VAAR13 OR VAAR14 OR VAAR15 OR VAAR16 OR VAAR17 OR VAAR18,1) AND VAAR1;

DRAWTEXT(VAAR19,40,'B'),COLORWHITE;

VAAR1A:=REF(VAAR1 OR VAAR2 OR VAAR3 OR VAAR4 OR VAAR5 OR VAAR6 OR VAAR7 OR VAAR8 OR VAAR9 OR VAARA OR VAARB OR VAARC,1) AND VAARD;

DRAWTEXT(VAAR1A,100,'S'),COLORYELLOW;

0,COLORAAAAAA;

20,POINTDOT,COLORAAAAAA;

50,COLORAAAAAA;

80,POINTDOT,COLORAAAAAA;

100,COLORAAAAAA;

----------------------------------------------------------------------------------------------------------

2.波段恒星指标公式源码

VAR1:=(CLOSE+HIGH+LOW+OPEN)/4;

VAR2:=SUMBARS(VOL,CAPITAL);

VAR3:=HHV(VAR1,VAR2);

VAR4:=LLV(VAR1,VAR2);

VAR5:=(2*VAR1-VAR4-REF(VAR4,1))/(VAR3-VAR4);

VAR6:=(VAR1-VAR4)/(VAR3-VAR4);

VAR7:=IF(VAR1<=VAR4,VAR5*60,VAR6*60);

VAR8:=600*(EMA(CLOSE,3)-EMA(LOW,30))/EMA(LOW,30);

VAR9:=EMA(VAR8,7);

VARA:=(WINNER(120*CLOSE/100)-WINNER(100*CLOSE/100))*100;

VARB:=(-100)*(WINNER(120*CLOSE/100)-WINNER(100*CLOSE/100))+5;

VARC:=HHV(HIGH,9)-LLV(LOW,9);

VARD:=HHV(HIGH,9)-CLOSE;

VARE:=CLOSE-LLV(LOW,9);

VARF:=VARD/VARC*100-70;

VAR10:=(CLOSE-LLV(LOW,60))/(HHV(HIGH,60)-LLV(LOW,60))*100;

VAR11:=(2*CLOSE+HIGH+LOW)/4;

VAR12:=SMA(VARE/VARC*100,3,1);

VAR13:=LLV(LOW,34);

VAR14:=SMA(VAR12,3,1)-SMA(VARF,9,1);

VAR15:=IF(VAR14>100,VAR14-100,0);

VAR16:=HHV(HIGH,34);

VAR17:=EMA((VAR11-VAR13)/(VAR16-VAR13)*100,8);

VAR18:=EMA(VAR17,5);

STICKLINE(VAR17-VAR18>0,VAR17,VAR18,3,1),COLORRED ;

STICKLINE(VAR17-VAR18<0,VAR17,VAR18,3,1),COLORGREEN ;