文档库

最新最全的文档下载
当前位置:文档库 > 第八章 网络地址转换练习题

第八章 网络地址转换练习题

《网络互联技术》练习题

第八章:网络地址转换

一、填空题

1、_________是用于将一个地址域(如企业内部网Intranet)映射到另一个地址域(如国际互联网Internet)的标准方法。

2、网络地址转换共有四种类型,它们是:静态地址转换、动态地址转换、

_______________和TCP负载均衡。

二、选择题

1、网络地址和端口翻译(NAPT)用(),这样做的好处是()。(1)A、把内部的大地址空间映射到外部的小地址空间

B、把外部的大地址空间映射到内部的小地址空间

C、把内部的所有地址映射到一个外部地址

D、把外部的所有地址映射到一个内部地址

(2)A、可以快速访问外部主机

B、限制了内部对外部主机的访问

C、增强了访问外部资源的能力

D、隐藏了内部网络的IP配置

2、NAT(网络地址转换)的功能是什么?()

A、将IP协议改为其它网络协议

B、实现ISP(因特网服务提供商)之间的通讯

C、实现拨号用户的接入功能、

D、实现私有IP地址与公共IP地址的相互转换

3、如果企业内部需要连接入Internet的用户一共有400个,但该企业只申请到一

个C类的合法IP地址,则应该使用哪种NAT方式实现()。

A、静态NAT

B、动态NAT

C、PAT

D、TCP负载均衡

4、Tom的公司申请到5个IP地址,要使公司的20台主机都能联到INTERNET上,他需要防火墙的那个功能?( )

A、假冒IP地址的侦测

B、网络地址转换技术

C、内容检查技术

D、基于地址的身份认证

三、多项选择题

1、下列关于地址转换的描述,正确的是()。

A、地址转换有效地解决了因特网地址短缺所面临的问题

B、地址转换实现了对用户透明的网络外部地址的分配

C、使用地址转换后,对IP包加密、快速转发不会造成什么影响

D、地址转换为内部主机提供了一定的“隐私”保护

E、地址转换使得网络调试变得更加简单

2、下面有关NAT叙述正确的是()。

A、NAT是英文“地址转换”的缩写,又称地址翻译

B、NAT用来实现私有地址与公用网络地址之间的转换

C、当内部网络的主机访问外部网络的时候,一定不需要NAT

D、地址转换的提出为解决IP地址紧张的问题提供了一个有效途径

3、下列关于地址池的描述,正确的说法是()。

A、只能定义一个地址池

B、地址池中的地址必须是连续的

C、当某个地址池已和某个访问控制列表关联时,不允许删除这个地址池

D、以上说法都不正确

4、3

5、下列地址表示私有地址的是()。

A、202.118.56.21

B、1.2.3.4

C、192.118.2.1

D、172.16.33.78

E、10.0.1.2

E、10.0.1.2

四、简答题

1、请简述解决IP地址不足的四大措施。

2、请简述NAT的四种类型。

3、请简述NAT地址转换的工作原理。

五、综合操作题

随着互联网迅速发展,加剧了IP地址缺乏的问题,为了缓解这一问题,一个重要的应用:NAT(Netword Address Translation—网络地址转换),日益广泛地应用起来。NAT通过地址转换的方式,使企业可以仅使用较少的互联网有效IP地址,就能获得互联网接入的能力,有效地缓解了地址不足的问题,同时提供了一定安全性。

企业从ISP获得6个有效IP地址(203.104.100.128~203.104.100.135,掩码为255.255.255.248,128和135为网络地址和广播地址,不可用),通过一台cisco路由器接入互联网。内部网络根据职能分成若干子网,并期望服务器子网对外提供WEB服务,人力资源部门使用独立的地址池接入互联网,其它部门共用剩余的地址池。地址具体分配如下表:

分配对象地址空间地址转换类分配的IP地址地址数量

接入路由器SO口203.104.100.129/29 203.104.100.129/29 1

WEB服务器193.168.10.2/24 静态203.104.100.130/29 1

人力资源部门193.168.20.2/24 端口复用203.104.100.131/29 1

财务部门193.168.30.0/24 动态203.104.100.132/29 3

第八章 网络地址转换练习题

具体配置步骤如下:

(1)选择E0作为内部接口,S0作为外部接口

interface ethernet 0

ip address 193.168.100.1 255.255.255.0

ip nat inside ______(1)________(解释命令含义)

interface serial 0

ip address 203.104.100.129 255.255.255.248

ip nat outside _______(2)_______(解释命令含义)(2)为WEB服务器设置静态地址转换

ip nat inside source static ________(3)________

(3)为人力资源部门设置地址转换池(地址池名称:finance)

ip nat pool finance 203.104.100.131 203.104.100.131 netmask ________(4)__________

(4)为财务部门设置地址转换池(地址池名称:other)

ip nat pool other ________(5)_________ netmask 255.255.255.248 (5)将访问控制列表1并映射到 finance地址池

ip nat inside source list 1 pool finance ______(6)______ (6)将访问控制列表2并映射到other地址池

ip nat inside source list 2 pool other

(7)、定义访问控制列表

access-list 1 permit ______(7)______

access-list 2 permit 193.168.30.0 0.0.0.255

(8)设置缺省路由

ip route 0.0.0.0 0.0.0.0 serial 0

2、某公司通过专线上网,申请的合法Internet IP地址段为192.1.1.1~192.1.1.10,使用路由器的NAT功能进行地址转换,具体配置如下:

Current configuration:

version 11.3

no service password-encryption

hostname 2501

ip nat pool aaa 192.1.1.2 192.1.1.10 netmask 255.255.255.0 ip nat inside source list 1 pool aaa

interface Ethernet0

ip address 10.1.1.1 255.255.255.0

ip nat inside

interface Seria1 0

ip address 192.1.1.1 255.255.255.0

ip nat outside

clockrate 2000000

interface Serial l

no ip address

shutdown

no ip classless

ip route 0.0.0.0 0.0.0.0 Serial 0

access-list 1 permit 10.1.1.0 0.0.0.255

line con 0

line aux 0

line vty 0 4

password cisco

end

[问题1]NAT按技术类型分为哪3种转换方式?

[问题2]请解释画线部分内容含义?

[问题3]此配置中采用了那种转换方式?