文档库

最新最全的文档下载
当前位置:文档库 > CCNP实验大全--eigrp troubleshooting

CCNP实验大全--eigrp troubleshooting

Eigrp Troubleshooting

【实验拓扑】

2.2

1.2

3.2

20.1

2.1

2.1

3.1

1.3

环回网络

2.3

172.168.4.0/24

说明:以RTE为界分为内部网络(左边)和外部网络(右边),内部网络运行EIGRP 协议,外部网络运行RIP协议。

【实验目的】

1.网络可以正常工作,所有路由器可以看以网络172.168.1.0/24, 172.168.2.0/24, 172.168.2.0/24, 172.168.4.0/24, 162.16.1.0/24, 150.150.0.0/16。

2.RTD上有两条到达网络172.168.2.0/24的路径,而只有一条到达网络172.168.4.0/24的路径(事先已经配置好让RTC不在以太网口发布这个网络)。

3.外部网络除150.150.0.0/16外全部不能被内部网络看到,内部网络只能通过缺省网络访问其它外部网络。

【错误设计】

一、二层出错,帧中继交换机被配成单向链路(即少一条frame-relay map)

RTA#sh ip route

172.168.0.0/24 is subnetted, 3 subnets

C 172.168.1.0 is directly connected, FastEthernet0

C 172.168.2.0 is directly connected, Serial0.1

D 172.168.3.0 [90/21026560] via 172.168.2.3, 00:34:08, Serial0.1

162.16.0.0/24 is subnetted, 1 subnets

D 162.16.1.0 [90/20514560] via 172.168.2.3, 00:37:34, Serial0.1

D EX 150.150.0.0/16 [170/21282560] via 172.168.2.3, 00:24:00, Serial0.1

RTA#sh ip eigrp neighbors

IP-EIGRP neighbors for process 1

H Address Interface Hold Uptime SRTT RTO Q Seq Type

(sec) (ms) Cnt Num

1 172.168.2.3 Se0.1 13 00:38:21 308 1848 0 23 RTA#sh frame-relay pvc

PVC Statistics for interface Serial0 (Frame Relay DTE)

Active Inactive Deleted Static

Local 1 0 1 0

Switched 0 0 0 0

Unused 0 0 0 0

DLCI = 101, DLCI USAGE = LOCAL, PVC STATUS = DELETED, INTERFACE = Serial0.1

input pkts 886 output pkts 97 in bytes 73955

out bytes 7548 dropped pkts 0 in FECN pkts 0

in BECN pkts 0 out FECN pkts 0 out BECN pkts 0

in DE pkts 0 out DE pkts 0

out bcast pkts 40 out bcast bytes 2560

5 minute input rate 0 bits/sec, 0 packets/sec

5 minute output rate 0 bits/sec, 0 packets/sec

pvc create time 01:04:01, last time pvc status changed 00:01:42

DLCI = 201, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE = Serial0.1

input pkts 874 output pkts 97 in bytes 70019

out bytes 7068 dropped pkts 0 in FECN pkts 0

in BECN pkts 0 out FECN pkts 0 out BECN pkts 0

in DE pkts 0 out DE pkts 0

out bcast pkts 42 out bcast bytes 2688

5 minute input rate 0 bits/sec, 0 packets/sec

5 minute output rate 0 bits/sec, 0 packets/sec

pvc create time 01:03:55, last time pvc status changed 01:00:26

RTB#sh frame-relay pvc

PVC Statistics for interface Serial0 (Frame Relay DTE)

Active Inactive Deleted Static

Local 0 1 0 0

Switched 0 0 0 0

Unused 0 0 0 0

DLCI = 102, DLCI USAGE = LOCAL, PVC STATUS = INACTIVE, INTERFACE = Serial0.1

input pkts 97 output pkts 891 in bytes 7548

out bytes 74544 dropped pkts 0 in FECN pkts 0

in BECN pkts 0 out FECN pkts 0 out BECN pkts 0

in DE pkts 0 out DE pkts 0

out bcast pkts 863 out bcast bytes 72401

5 minute input rate 0 bits/sec, 0 packets/sec

5 minute output rate 0 bits/sec, 0 packets/sec

pvc create time 01:17:38, last time pvc status changed 00:02:43

RTB#sh ip route

172.168.0.0/24 is subnetted, 3 subnets

D 172.168.1.0 [90/20517120] via 162.16.1.3, 00:03:03, FastEthernet0

D 172.168.2.0 [90/20514560] via 162.16.1.3, 00:03:03, FastEthernet0

D 172.168.3.0 [90/2172416] via 162.16.1.1, 00:36:45, FastEthernet0

162.16.0.0/24 is subnetted, 1 subnets

C 162.16.1.0 is directly connected, FastEthernet0

D EX 150.150.0.0/16 [170/2428416] via 162.16.1.1, 00:26:38, FastEthernet0

二、共亨链路带宽问题,让B和C到帧中继网络有不同的带宽,但必须让D有两条到A的路由。

RTB#conf t

Enter configuration commands, one per line. End with CNTL/Z.

RTB(config)#int s0.1

RTB(config-subif)#bandwidth 2040

RTC(config)#int s0.1

RTC(config-subif)#bandwidth 2048

RTD#sh ip route

172.168.0.0/24 is subnetted, 3 subnets

D 172.168.1.0 [90/1789952] via 162.16.1.3, 00:00:03, FastEthernet0/0

D 172.168.2.0 [90/1787392] via 162.16.1.3, 00:00:03, FastEthernet0/0

C 172.168.3.0 is directly connected, Serial0/0

162.16.0.0/24 is subnetted, 1 subnets

C 162.16.1.0 is directly connected, FastEthernet0/0

D EX 150.150.0.0/16 [170/2425856] via 172.168.3.2, 00:00:03, Serial0/0

RTD#sh ip eigrp topology 172.168.2.0 255.255.255.0

IP-EIGRP (AS 1): Topology entry for 172.168.2.0/24

State is Passive, Query origin flag is 1, 1 Successor(s), FD is 1787392

Routing Descriptor Blocks:

162.16.1.3 (FastEthernet0/0), from 162.16.1.3, Send flag is 0x0

Composite metric is (1787392/1761792), Route is Internal

Vector metric:

Minimum bandwidth is 2048 Kbit

Total delay is 21000 microseconds

Reliability is 255/255

Load is 1/255

Minimum MTU is 1500

Hop count is 1

162.16.1.2 (FastEthernet0/0), from 162.16.1.2, Send flag is 0x0

Composite metric is (1792256/1766656), Route is Internal

Vector metric:

Minimum bandwidth is 2040 Kbit

Total delay is 21000 microseconds

Reliability is 255/255

Load is 1/255

Minimum MTU is 1500

Hop count is 1

加入Variance 2

RTD#sh ip route

172.168.0.0/24 is subnetted, 3 subnets

D 172.168.1.0 [90/1789952] via 162.16.1.3, 00:00:03, FastEthernet0/0

D 172.168.2.0 [90/1787392] via 162.16.1.3, 00:00:03, FastEthernet0/0

[90/1792256] via 162.16.1.2, 00:00:03, FastEthernet0/0

C 172.168.3.0 is directly connected, Serial0/0

162.16.0.0/24 is subnetted, 1 subnets

C 162.16.1.0 is directly connected, FastEthernet0/0

D EX 150.150.0.0/16 [170/2425856] via 172.168.3.2, 00:00:03, Serial0/0

三、水平分割问题,A的多少接口上的水平分割让网络172.168.4.0/25只能被A收到,当然还要配分发列表。

RTC(config)#int loopback 0

RTC(config-if)#ip addr 172.168.4.1 255.255.255.0

RTC(config-if)#exit

RTC(config)#router eigrp 1

RTC(config-router)#distribute-list 1 out fastEthernet 0

RTC(config-router)#exit

RTC(config)#access

RTC(config)#access-list 1 deny 172.168.4.0 0.0.0.255

RTC(config)#access-

RTC(config)#access-list 1 permit any

RTA#sh ip rout

172.168.0.0/24 is subnetted, 4 subnets

D 172.168.4.0 [90/20640000] via 172.168.2.3, 00:01:47, Serial0.1

C 172.168.1.0 is directly connected, FastEthernet0

C 172.168.2.0 is directly connected, Serial0.1

D 172.168.3.0 [90/21026560] via 172.168.2.2, 00:01:06, Serial0.1

[90/21026560] via 172.168.2.3, 00:01:06, Serial0.1

162.16.0.0/24 is subnetted, 1 subnets

D 162.16.1.0 [90/20514560] via 172.168.2.3, 00:12:05, Serial0.1

[90/20514560] via 172.168.2.2, 00:12:06, Serial0.1

D EX 150.150.0.0/16 [170/21282560] via 172.168.2.2, 00:01:07, Serial0.1

[170/21282560] via 172.168.2.3, 00:01:07, Serial0.1

RTB#sh ip route

172.168.0.0/24 is subnetted, 3 subnets

D 172.168.1.0 [90/1769216] via 172.168.2.1, 00:02:21, Serial0.1

C 172.168.2.0 is directly connected, Serial0.1

D 172.168.3.0 [90/2172416] via 162.16.1.1, 00:12:38, FastEthernet0

162.16.0.0/24 is subnetted, 1 subnets

C 162.16.1.0 is directly connected, FastEthernet0

D EX 150.150.0.0/16 [170/2428416] via 162.16.1.1, 00:12:38, FastEthernet0

RTA(config-subif)#no ip split-horizon eigrp 1

RTB#sh ip route

172.168.0.0/24 is subnetted, 4 subnets

D 172.168.4.0 [90/21152000] via 172.168.2.1, 00:00:06, Serial0.1

D 172.168.1.0 [90/1769216] via 172.168.2.1, 00:00:06, Serial0.1

C 172.168.2.0 is directly connected, Serial0.1

D 172.168.3.0 [90/2172416] via 162.16.1.1, 00:00:06, FastEthernet0

162.16.0.0/24 is subnetted, 1 subnets

C 162.16.1.0 is directly connected, FastEthernet0

D EX 150.150.0.0/16 [170/2428416] via 162.16.1.1, 00:00:06, FastEthernet0

四、是否允许广播,当在多点接口上不加入关键字broadcast时,会出现hello包无法发送因为它使用了组播地址。

RTA(config-subif)#no frame-relay map ip 172.168.2.2 101 broadcast

RTA(config-subif)#frame-relay map ip 172.168.2.2 101

RTA(config-subif)#no frame-relay map ip 172.168.2.3 201 broadcast

RTA(config-subif)#frame-relay map ip 172.168.2.3 201

RTA(config-subif)#

RTA#sh ip eigrp nei

IP-EIGRP neighbors for process 1

为空,加入后的输出:

RTA#sh ip eigrp nei

IP-EIGRP neighbors for process 1

H Address Interface Hold Uptime SRTT RTO Q Seq Type

(sec) (ms) Cnt Num

1 162.16.1.3 Fa0 11 00:00:18 4 200 0 104

0 162.16.1.1 Fa0 10 00:00:18 8 200 0 106

五、不连续子网问题,B、C、D之间的网络把172.168.0.0/16分开,如果不在这些路由器中配置no auto-summary命令会造成有的网络收不到。

RTD(config)#router eigrp 1

RTD(config-router)#auto-summary

RTB#sh ip route

172.168.0.0/16 is variably subnetted, 4 subnets, 2 masks

D 172.168.4.0/24 [90/21152000] via 172.168.2.1, 00:02:15, Serial0.1

D 172.168.0.0/16 [90/1794816] via 162.16.1.1, 00:00:32, FastEthernet0

D 172.168.1.0/24 [90/1769216] via 172.168.2.1, 00:02:15, Serial0.1

C 172.168.2.0/24 is directly connected, Serial0.1

162.16.0.0/24 is subnetted, 1 subnets

C 162.16.1.0 is directly connected, FastEthernet0

D EX 150.150.0.0/16 [170/2428416] via 162.16.1.1, 00:00:35, FastEthernet0

六、不共同子网,当配错D的以太网口时,无法建立邻居关系,而且有错误提示。

RTD(config-if)#ip addr 162.16.11.1 255.255.255.0

RTD(config-if)#

02:32:24: IP-EIGRP: Neighbor 162.16.1.2 not on common subnet for FastEthernet0/0 (162.16.11.1 255.255.255.0

七、K不同也会造成邻居问题

RTD(config)#router eigrp 1

RTD(config-router)#metric weights 0 1 1 1 1 0

RTD(config)#^Z

RTD#

02:36:36: %SYS-5-CONFIG_I: Configured from console by consoleear

RTD#sh ip eigrp nei

IP-EIGRP neighbors for process 1

RTD(config-router)#metric weights 0 1 0 1 0 0

RTD(config-router)#exit

RTD(config)#exit

RTD#

02:37:57: %SYS-5-CONFIG_I: Configured from console by console

RTD#clear ip eigrp nei

RTD#sh ip eigrp ne i

IP-EIGRP neighbors for process 1

H Address Interface Hold Uptime SRTT RTO Q Seq Type

(sec) (ms) Cnt Num

2 162.16.1.

3 Fa0/0 1

4 00:00:02 1 3000 2 167

1 162.16.1.

2 Fa0/0 1

3 00:00:03 1 3000 2 191

0 172.168.3.2 Se0/0 14 00:00:05 26 200 0 70

八、发布列表,在E上不进行路由发布过滤时会让内部路由器看到所有路由。

RTD#sh ip route

D EX 170.170.0.0/16 [170/2425856] via 172.168.3.2, 00:00:06, Serial0/0

172.168.0.0/24 is subnetted, 4 subnets

D 172.168.4.0 [90/21177600] via 162.16.1.2, 00:01:33, FastEthernet0/0

D 172.168.1.0 [90/1794816] via 162.16.1.3, 00:01:33, FastEthernet0/0

[90/1794816] via 162.16.1.2, 00:01:33, FastEthernet0/0

D 172.168.2.0 [90/1792256] via 162.16.1.3, 00:01:33, FastEthernet0/0

[90/1792256] via 162.16.1.2, 00:01:33, FastEthernet0/0

C 172.168.3.0 is directly connected, Serial0/0

162.16.0.0/24 is subnetted, 1 subnets

C 162.16.1.0 is directly connected, FastEthernet0/0

D EX 160.160.0.0/16 [170/2425856] via 172.168.3.2, 00:00:06, Serial0/0

131.66.0.0/24 is subnetted, 1 subnets

D EX 131.66.20.0 [170/2425856] via 172.168.3.2, 00:00:07, Serial0/0

D EX 150.150.0.0/16 [170/2425856] via 172.168.3.2, 00:00:15, Serial0/0

RTE(config)#router eigrp 1

RTE(config-router)#distribute-list 1 out

Access-list 1 permit 150.150.0.0 0.0.255.255

RTD#sh ip route

172.168.0.0/24 is subnetted, 4 subnets

D 172.168.4.0 [90/21177600] via 162.16.1.2, 00:03:26, FastEthernet0/0

D 172.168.1.0 [90/1794816] via 162.16.1.3, 00:03:26, FastEthernet0/0

[90/1794816] via 162.16.1.2, 00:03:26, FastEthernet0/0

D 172.168.2.0 [90/1792256] via 162.16.1.3, 00:03:26, FastEthernet0/0

[90/1792256] via 162.16.1.2, 00:03:26, FastEthernet0/0

C 172.168.3.0 is directly connected, Serial0/0

162.16.0.0/24 is subnetted, 1 subnets

C 162.16.1.0 is directly connected, FastEthernet0/0

D EX 150.150.0.0/16 [170/2425856] via 172.168.3.2, 00:00:03, Serial0/0

九、重发布,没有default-metric命令的话重发布是不会发生。

RTD#sh ip route

172.168.0.0/24 is subnetted, 4 subnets

D 172.168.4.0 [90/21177600] via 162.16.1.2, 00:05:01, FastEthernet0/0

D 172.168.1.0 [90/1794816] via 162.16.1.3, 00:05:01, FastEthernet0/0

[90/1794816] via 162.16.1.2, 00:05:01, FastEthernet0/0

D 172.168.2.0 [90/1792256] via 162.16.1.3, 00:05:01, FastEthernet0/0

[90/1792256] via 162.16.1.2, 00:05:01, FastEthernet0/0

C 172.168.3.0 is directly connected, Serial0/0

162.16.0.0/24 is subnetted, 1 subnets

C 162.16.1.0 is directly connected, FastEthernet0/0

RTE(config)#router eigrp 1

RTE(config-router)#default-metric 10000 1000 255 1 1500

RTD#sh ip route

172.168.0.0/24 is subnetted, 4 subnets

D 172.168.4.0 [90/21177600] via 162.16.1.2, 00:06:45, FastEthernet0/0

D 172.168.1.0 [90/1794816] via 162.16.1.3, 00:06:45, FastEthernet0/0

[90/1794816] via 162.16.1.2, 00:06:45, FastEthernet0/0

D 172.168.2.0 [90/1792256] via 162.16.1.3, 00:06:45, FastEthernet0/0

[90/1792256] via 162.16.1.2, 00:06:45, FastEthernet0/0

C 172.168.3.0 is directly connected, Serial0/0

162.16.0.0/24 is subnetted, 1 subnets

C 162.16.1.0 is directly connected, FastEthernet0/0

D EX 150.150.0.0/16 [170/2425856] via 172.168.3.2, 00:00:25, Serial0/0

十、从复ID,A和E都使用环回地址192.168.1.1,所以E重发布的路由A不接爱。RTA#sh ip route

172.168.0.0/24 is subnetted, 4 subnets

D 172.168.4.0 [90/20640000] via 172.168.2.3, 00:00:30, Serial0.1

C 172.168.1.0 is directly connected, FastEthernet0

C 172.168.2.0 is directly connected, Serial0.1

D 172.168.3.0 [90/21026560] via 172.168.2.3, 00:00:30, Serial0.1

[90/21026560] via 172.168.2.2, 00:00:30, Serial0.1

162.16.0.0/24 is subnetted, 1 subnets

D 162.16.1.0 [90/20514560] via 172.168.2.3, 00:00:30, Serial0.1

[90/20514560] via 172.168.2.2, 00:00:30, Serial0.1

C 192.168.1.0/24 is directly connected, Loopback0

RTD#sh ip route

172.168.0.0/24 is subnetted, 4 subnets

D 172.168.4.0 [90/21177600] via 162.16.1.2, 00:01:15, FastEthernet0/0

D 172.168.1.0 [90/1794816] via 162.16.1.3, 00:01:15, FastEthernet0/0

[90/1794816] via 162.16.1.2, 00:01:15, FastEthernet0/0

D 172.168.2.0 [90/1792256] via 162.16.1.3, 00:02:15, FastEthernet0/0

[90/1792256] via 162.16.1.2, 00:02:15, FastEthernet0/0

C 172.168.3.0 is directly connected, Serial0/0

162.16.0.0/24 is subnetted, 1 subnets

C 162.16.1.0 is directly connected, FastEthernet0/0

D EX 150.150.0.0/16 [170/2425856] via 172.168.3.2, 00:02:53, Serial0/0

改了E的环回地址,重启后就正常了。

RTA#sh ip route

172.168.0.0/24 is subnetted, 4 subnets

D 172.168.4.0 [90/20640000] via 172.168.2.3, 00:09:38, Serial0.1

C 172.168.1.0 is directly connected, FastEthernet0

C 172.168.2.0 is directly connected, Serial0.1

D 172.168.3.0 [90/21026560] via 172.168.2.3, 00:00:41, Serial0.1

[90/21026560] via 172.168.2.2, 00:00:41, Serial0.1

162.16.0.0/24 is subnetted, 1 subnets

D 162.16.1.0 [90/20514560] via 172.168.2.3, 00:09:38, Serial0.1

[90/20514560] via 172.168.2.2, 00:09:38, Serial0.1

C 192.168.1.0/24 is directly connected, Loopback0

D EX 150.150.0.0/16 [170/21282560] via 172.168.2.3, 00:00:27, Serial0.1

[170/21282560] via 172.168.2.2, 00:00:27, Serial0.1

十一、认证问题,当D上没有配论证,而E上配了时,它们会无法建立邻居关系。RTE(config)#int s0/0

RTE(config-if)#ip authentication mode eigrp 1 md5

RTE(config-if)#ip authentication key-chain eigrp 1 holly

RTE(config-if)#key chain holly

RTE(config-keychain)#key 1

RTE(config-keychain-key)#key-string 123

RTE#sh ip eigrp nei

IP-EIGRP neighbors for process 1

RTD(config)#int s0/0

RTD(config-if)#ip au

RTD(config-if)#ip authentication mode ei

RTD(config-if)#ip authentication mode eigrp 1 md5

RTD(config-if)#ip au

RTD(config-if)#ip authentication key

RTD(config-if)#ip authentication key-chain eig

RTD(config-if)#ip authentication key-chain eigrp 1 mikey

RTD(config-if)#key chain mikey

RTD(config-keychain)#key 1

RTD(config-keychain-key)#key

RTD(config-keychain-key)#key-string 123

RTD(config-keychain-key)#^Z

RTD#

03:22:16: %SYS-5-CONFIG_I: Configured from console by console

RTD#sh ip eigrp nei

IP-EIGRP neighbors for process 1

H Address Interface Hold Uptime SRTT RTO Q Seq Type

(sec) (ms) Cnt Num

2 172.168.3.2 Se0/0 14 00:00:00 1 2000 1 0

1 162.16.1.

2 Fa0/0 14 00:00:04 1 3000

3 291

0 162.16.1.3 Fa0/0 14 00:00:05 4 200 0 276 RTD#sh ip route

172.168.0.0/24 is subnetted, 4 subnets

D 172.168.4.0 [90/21177600] via 162.16.1.2, 00:00:10, FastEthernet0/0

D 172.168.1.0 [90/1794816] via 162.16.1.2, 00:00:10, FastEthernet0/0

[90/1794816] via 162.16.1.3, 00:00:10, FastEthernet0/0

D 172.168.2.0 [90/1792256] via 162.16.1.2, 00:00:10, FastEthernet0/0

[90/1792256] via 162.16.1.3, 00:00:10, FastEthernet0/0

C 172.168.3.0 is directly connected, Serial0/0

162.16.0.0/24 is subnetted, 1 subnets

C 162.16.1.0 is directly connected, FastEthernet0/0

D EX 150.150.0.0/16 [170/2425856] via 172.168.3.2, 00:00:06, Serial0/0

十二、默认路由问题

在EIGRP中是不能用ip route 0.0.0.0 0.0.0.0 next-hop命令来通告默认路由的,只能用ip default-network命令来进行配置,比如在RTE上使用ip default-network 150.150.0.0 255.255.0.0,这样将使其它路由器上的150.150.0.0/16网络变成缺省网络(有*号)。

2513#show ip route

Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP

D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP

i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, * - candidate default

Gateway of last resort is 161.44.192.2 to network 198.10.1.0

161.44.0.0 255.255.255.0 is subnetted, 1 subnets

C 161.44.192.0 is directly connected, Ethernet0

S 161.44.0.0 255.255.0.0 [1/0] via 161.44.192.0

S* 198.10.1.0 [1/0] via 161.44.192.2

131.108.0.0 255.255.255.0 is subnetted, 1 subnets

C 131.108.99.0 is directly connected, TokenRing0

注:上面的输出不是基于本实验拓扑,只作为说明用。在上面的结果的蓝色部分可以看到有最后的网关了。

【路由器上的错误配置】

注:蓝色为正常时要用的,排错时去掉;绿色为在设错时添加的

帧中继交换机

(Config) # frame-relay switching

s0

int

(Config)

#

! 进入s0端口

(config-if) # enacapsulation frame-relay

(config-if) # frame-relay intf-type dce

! 设置端口类型为DCE

(config-if) # frame-relay lmi-type cisco

! 配置lmi类型

(config-if) # clock rate 56000

(config-if) # frame-relay route 101 interface s1 102!建立一条交换记录

(config-if) # frame-relay route 201 interface s2 202 ! 建立第二条交换记

(config-if) # no shut

(config-if) # exit

(Config) # int s1

!进入s1端口

(config-if) # encapsulation frame-relay

(config-if) # frame-relay intf-type dce

(config-if) # frame-relay lmi-type cisco

(config-if) # clock rate 56000

(config-if) # frame-relay route 102 interface s0 101

(config-if) # no shut

(config-if) # exit

(Config) # int s2

!进入s2端口

(config-if) # enacapsulation frame-relay

(config-if) # frame-relay intf-type dce

(config-if) # frame-relay lmi-type cisco

(config-if) # clock rate 56000

(config-if) # frame-relay route 202 interface s0 201

(config-if) # no shut

(config-if) # exit

路由器RTA的配置

int e 0

ip addr 172.168.1.1 255.255.255.0

no shut

int s0

encapsulation frame-relay

frame-relay lmi-type cisco

int s0.1 multipoint

ip addr 172.168.2.1 255.255.255.0

frame-relay map ip 172.168.2.2 101 broadcast(frame-relay map ip 172.168.2.2 102) frame-relay map ip 172.168.2.3 201 broadcast(frame-relay map ip 172.168.2.2 202) no ip split-horizon eigrp 1

no shut

int loopback 0

ip addr 192.168.1.1 255.255.255.0

exit

router eigrp 1

network 172.168.0.0

exit

路由器RTB的配置

int e 0

ip addr 162.16.1.2 255.255.255.0

no shut

int s0

no ip addr

encapsulation frame-relay

frame-relay lmi-type cisco

int s0.1 point-to-point

bandwidth 2048 (bandwidth 2040)

ip addr 172.168.2.2 255.255.255.0

frame-relay interface-dlci 102

exit

no shut

router eigrp 1

network 172.168.0.0

network 162.16.0.0

no auto-summary

exit

路由器RTC的配置

int e 0

ip addr 162.16.1.3 255.255.255.0

no shut

RTC(config)#int loopback 0

RTC(config-if)#ip addr 172.168.4.1 255.255.255.0

int s0

encapsulation frame-relay

frame-relay lmi-type cisco

int s0.1 point-to-point

bandwidth 2048

ip addr 172.168.2.3 255.255.255.0

frame-relay interface-dlci 202

exit

no shut

router eigrp 1

distribute-list 1 out fastEthernet 0

network 172.168.0.0

network 162.16.0.0

no auto-summary

Exit

access-list 1 deny 172.168.4.0 0.0.0.255

access-list 1 permit any

路由器RTD的配置

int e 0

ip addr 162.16.1.1 255.255.255.0 (ip addr 162.16.11.1 255.255.255.0) no shut

int s0

RTD(config-if)#ip authentication mode eigrp 1 md5

RTD(config-if)#ip authentication key-chain eigrp 1 mikey

RTD(config-if)#key chain mikey

RTD(config-keychain)#key 1

RTD(config-keychain-key)#key-string 123

ip addr 172.168.3.1 255.255.255.0

clock rate 56000

no shut

router eigrp 1

network 172.168.0.0

network 162.16.0.0

no auto-summary

metric weights 0 1 1 1 1 0

exit

路由器RTE的配置

int s 0

RTE(config-if)#ip authentication mode eigrp 1 md5

RTE(config-if)#ip authentication key-chain eigrp 1 holly

RTE(config-if)#key chain holly

RTE(config-keychain)#key 1

RTE(config-keychain-key)#key-string 123

ip addr 172.168.3.2 255.255.255.0

clock rate 56000

no shut

int s1

ip addr 131.66.20.1 255.255.255.0

clock rate 56000

no shut

int loopback 0

ip addr 192.168.6.1 255.255.255.0(ip addr 192.168.1.1 255.255.255.0) exit

router eigrp 1

network 172.168.0.0

redistribute rip

default-metric 10000 100 255 1 1500

distribute-list 1 out

exit

router rip

network 131.66.0.0

access-list 1 permit 150.150.0.0 0.0.255.255

外部的配置

int s0

ip addr 131.66.20.2

clock rate 56000

no shut

int loopback 0

ip addr 150.150.0.1 255.255.0.0

int loopback 1

ip addr 160.160.0.1 255.255.0.0

int loopback 2

ip addr 170.170.0.1 255.255.0.0

router rip

network 150.150.0.0 network 160.160.0.0 network 170.170.0.0