文档库

最新最全的文档下载
当前位置:文档库 > CAD技巧

CAD技巧

CAD技巧

3. 在AutoCAD中有时有交叉点标记在鼠标点击处产生,用BLIPMODE命令,在提示行下输入OFF可消除它。

4. 有的用户使用AutoCAD时会发现命令中的对话框会变成提示行,如打印命令,控制它的是系统变量CMDDIA,关掉它就行了。

5. 椭圆命令生成的椭圆是以多义线还是以椭圆为实体的是由系统变量PELLIPSE决定,当其为1时,生成的椭圆是PLINE。

6. CMDECHO变量决定了命令行回显是否产生,其在程序执行中应设为0。

7. DIMSCALE决定了尺寸标注的比例,其值为整数,缺省为1,在图形有了一定比例缩放时应最好将其改成为缩放比例。

10. AutoCAD R14的BONUS中有一个ARCTEXT命令,可实现弧形文本输出,使用方法为先选圆弧,再输入文本内容,按OK。

11. BONUS中有一个有用的命令,即MPEDIT,用它将多个线一齐修改为多义线,再改它的线宽。

14. AutoCAD R14中提供了大量的命令缩写,许多R13中无缩写的命令也有了缩写,下面提供了CAD中的单字符缩写:A:ARC,B:Bmake,C:Circle,D:ddim,E:erase,F:fillet,G:group,H:bhatch,I:ddinsert,L:line,M:move,O:offset,P:pan,R:redraw,S:stretch,T:mext,U:undo,V:ddview,W:Wblock,X;explode,Z:zoo,可大量使用之,使用后会发现比鼠标点取快(尤其在ls输5个字符的速度下)。

AutoCAD R14大量扩充了简化命令,不仅增加了以首字母简化的命令(这里不列出),而用增加了用前两个字母简化的命令,常的如:array 、copy、dist、donut 、dtext 、filter 、mirror、pline 、rotate 、trim、scale 、snap 、style、units等,更加提高了用键盘输入命令的速度,对熟悉键盘的朋友来说简直是如虎添翼。

15. AutoCAD R14命令的缩写也可用在R13,方法是将AutoCAD R14下的Support子目录下的ACAD.pgp拷贝至AutoCAD R13中的Support子目录下。

16. AutoCAD 中ACAD.pgp文件十分重要,它记录命令缩写内容,用户可自定义它们,格式如下:<命令缩写> *命令名称。也可定义系统命令,A

utoCAD R14提供了sh命令,可执行DOS命令,但在Windows作用下不大。

17. AutoCAD R14中用NOTEPAD、EDIT、DIR、DEL等系统命令,笔者认为其中NOTEPAD 对自定义CAD用途较大,但使用起来会发现屏幕一闪(进了DOS),又返回,十分让人不愉快,让我们来编一个小程序,取名为note.lsp:

(defun c:notepad()

(startapp″notepad″)

)

先将ACAD.pgp中的NOTEPAD命令定义行删除,重入CAD后,再将此程序命令:(load″note″)装入,下一次用NOTEPAD命令会有更好效果,最好将(load″note″)加入Support 子目录下的ACADR14.lsp中。

18. AutoCAD R14中打印线宽可由颜色设定,这样机械制图中的各种线型不同、、线宽不同的线条可放入不同的层,在层中定义了线型的颜色,

而在打印设置中设定线型与颜色的关系,效果良好。

19. AutoCAD R14的Support中ACAD.dwt为缺省模板,要好好加工它,把常用的层、块、标注类型定义好,再加上标准图框,可省去大量重复工作。

22. 用户自定义的Lisp文件一定要自动装入AutoCAD,这样就需要在acadr14.lsp中加入用户Lisp文件的装入语句,acadr14.lsp(早期版本为acad14.lsp)好似DOS的Autoexec.bat,一定要好好利用,在其中如定义了名为S::STARTUP()的函数可自动运行它。(给CAD加个启用画面如何,可用ST

ARTUP加startapp函数,也可加登录密码)。

23. 将AutoCAD中的图形插入WORD中,有时会发现圆变成了正多边形,用一下VIEWRES 命令,将它设得大一些,可改变图形质量。

24. 形如φ30H11(+0.1,-0.2)的标注如何去标呢,请在文本内容中输入%%c30{H11(}{\H0.7X;\S+0.1^-0.2;})”,可以实现,如嫌太麻烦,就编程序来简化操作。

25. AutoCAD中文件可当作块插入其他文件中,但这样一来过多的块使文件过于庞大,用PURGE来清除它们吧,一次清一层,一定要多用几次呀!

30. 在AutoCAD中的菜单源文件为.mnu文件,将其修改可将自己的命令加入菜单中,再用menu命令装入,加参加AutoCAD帮助了解菜单文件格式。图标工具条中加入自己的命令相对简单,可在工具条上点右键,在toolbar对话中,点new 按钮,输入工具条后,一个新工具条产生,再选Customize按钮,选定custom,将空按钮拖入工具条中,再在空按钮上按右键,这样就可定义自己的按钮图标和命令。

31. AutoCAD的状态行也可处定义,用DIESEL语言可以访问它,最简单的方法用modemacro 命令,后输入$(getvar,clayer),以后当前层名就显在准确无误行上,用户化可谓无孔不入吧!

32. AutoCAD的图形格式为.dwg,也可导出为.bmp及.wmf或.eps、.dxf、.3ds,是如果用render 命令可存为.pcx、.tga、.tif格式,AutoCAD还可将文件直接存为这几种格式,要为系统装一

个名为“Raster file export”的打印机,用它打印到文件,ACAD2000还可将文件存为JPG 格式。

34. dimzin系统变量最好要设定为8,这时尺寸标注中的缺省值不会带几个尾零,用户直接接受缺省值十分方便快捷。

35. 如遇到快捷失效,如^0失去作用变为正交模式切换的情况,请用menu将当前使用菜单.mnu菜单源文件重装一遍即可。

36. 在多行文字(mtext)命令中Word97编辑文本。Mtext多行文字编辑器是AuotCAD R14中的新增功能,它提供了Windows文字处理软件所具备

打开“Tools”菜单选“Preferences”命令,“Preferences”对话框弹出后,打开“Files/Text Editor,Dictionary,and Font File Name/Text Editor Application Iinternal”,双击“Internal”,出现“Select a file”对话框,接着找到“Winword.exe”应用程序文件,击“打开”钮,最后单击“OK”返回。完成以上设置后,用户如再使用mtext命令时系统将自动调用我们熟悉的Word97应用程序,为AotoCAD中的文本锦上添花。

38. “Stretch”命令也是一个常用命令,但输入命令后,系统总要提示“select object to stretch by crossing_window or crossing_polygon…”,要求你再输入一个“C”后才能用鼠标去选择目标。为了使操作简化,用户只需将系统提供的工具按钮做些小小的修改即可。右击任意工具钮弹出“Toolbars”对话框,再右击“stretch”工具钮弹出“Toolbars”对话框,在“Macro:”框中的“^c^c_stretch”后键入空格和“C”。以后你再点击处理后的工具钮可以接选择目标进行操作。

39. AuotCAD R14用户均采用系统给出的缺省格式存盘,这种格式存盘的缺点是文件所占空间大,不能用低版本的应用程序(如:AuotCAD R12、AuotCAD R13)打开,为避免磁盘空间的浪费,你可以在“Save Drawing As”对话框的“保存类型”中选“AuotCAD R12/LT2 Drawing”格式存盘。例如:同一dwg文件用两种方式存盘,它们的大小分别是87KB、58KB。可见差别还是很可观的。而且后者文件可以在R12、R13版本的应用程序中打开。这种方式对配置较低的用户尤为实用。

40. 有时在打开dwg文件时,系统弹出“AutoCAD Message”对话框提示“Drawing file is not valid ”,告诉用户文件不能打开。这种情况下你可以先退出打开操作,然后打开“File”菜单,选“Drawing Utilities/Recover”,或者在命令行直接用键盘输入“recover”,接着在“Select File”对话框中输入要恢复的

43. trim命令中提示选取要剪切的图形时,不支持常用的window和crossing选取方式。当要剪切多条线段时,要选取多次才能完成。这时可以使用fence命令提示选择要剪除的图形时,输入“f”,然后在屏幕上画出一条虚线,回车,这时被该虚线接触到的图形全部被剪切掉。

46. 在AutoCAD中有时尺寸箭头及Trace画的轨迹线变为空心,用TRIMMODE命令,在提示行下输新值1可将其重新变为实心。

47. 用AutoCAD打开一张旧图,有时会遇到异常错误而中断退出,这时首先使用40介绍的

方法,如果问题仍然存在,则可以新建一个图形文件,而把旧图用图块形式插入,可以解决问题。

在打开CAD文件的是否经常发现自己并没有所需要的字体,显示的是???

解决的办法是找到需要的字体,另外可以另外指定字体.

可以在自己设置菜单中进行选择.

1.cad最好多使用图块,把常用的东东按照1:1比例保存为块,使用时调出即可。修改也方便。

2.输入文字时一定使用单行文字,慎用多行文字,否则~~~~~~呵呵~~~~文件肥大啊~~~~~~

3.要有自己的统一绘图格式,画图久了,你会觉得事半功倍,因为并不是每一张图纸都是不一样的

建议水电与暖通的把土建图纸作成外部参照 1.文件容量减小 2.土建图纸修改后,直接插入土建图纸,就会知道水电如何修改 3.水电,暖通各系统之间套图,检查标高是否冲突

请问为什么我用CAD2000绘制的图纸打印的字体为空心的?

那你在CAD里的文字格式是什么?看看它的属性。

提高AUTOCAD绘图速度的技巧

现在利用计算机绘制建筑图已经十分普遍,AUTOCAD2000便是其中应用较为广泛的软件之一。AUTOCAD2000以其强大的绘图、编辑、出图等功能,成为建筑行业中的标准制图软件,也是部分国产建筑制图软件的平台。现将我在使用AUTOCAD绘图中积累的一些经验和技巧与大家分享。其中一些部分都是在CAD教材中提及较少,但在绘图中却十分实用的一些技巧。

1.在AUTOCAD中尽量多使用命令行直接输入命令的方式,而减少使用下拉菜单和点击命令图标的方式,这样可以有效的提高绘图的速度。为了更好的使用命令别名,我们还可以通过编辑ACAD2000\SUPPORT\ACAD.PGP文件来自定义符合自己习惯的命令别名。例如将常用的COPY命令定义为C,而将不常用的CIRCLE命令定义为CI。但另一方面,太多的更改命令别名,会使你在别的计算机上绘图时感到不适应,所以应根据实际需要,有选择的自定义一部分命令别名。

2.很好地使用智能鼠标滚轮的作用。智能鼠标滚轮可以方便的实现图形的缩放和平移,减少因使用ZOOM命令而浪费的时间。在AUTOCAD中使用SETV AR来设置系统变量MBUTTONPAN的值为1,按住鼠标滚轮拖动时即实现命令PAN的功能,双击鼠标滚轮即显示图形的全部范围。自定义右键的功能:通过下拉菜单:工具?选项,选择“用户系统配置”选项卡,点击“自定义右键单击”出现如图1提示框,设定成如图1所示,单击“应用并关闭”按钮,完成设置。

3.对象属性管理器[OPM]是AUTOCAD2000新增加的一项重要功能,对象属性面板如图2所示。使用OPM可以使用户用更快、更精确、更简单的方法修改对象的任何属性,从而提高了绘图效率。在选择单一对象时,OPM显示它的全部属性。多重选择时,OPM显示它们共有的属性。当没有对象被选中,OPM将显示整个图纸的属性。在OPM中,可以使用“快速选择”功能,从而方便的建立供编辑用的选择集。

4.在编辑对象时选择集的构造。在执行一个编辑命令时,当命令行提示“选择对象”时,可以用以下各种方式来选择对象,构造选择集:

①直接点选对象;

②使用选择窗口选择对象:指定了第一个角点以后,从左向右拖动(选择窗口)仅选择完全包含在选择区域内的对象,选择结果如图3左上角图所示;

③使用交叉选择来选择对象:从右向左拖动(交叉选择)可选择包含在选择区域内以及与选择区域的边框相交叉的对象,选择结果如图3左下角图所示;

④在“选择对象”提示下输入WP,指定多边形各角点,窗口多边形只选择它完全包含的对象,选择结果如图3右上角图所示;

⑤在“选择对象”提示下输入CP,指定多边形各角点,交叉多边形选择包含或相交的对象,选择结果如图3右下角图所示;

⑥在“选择对象”提示下输入F,使用选择栏可以很容易地从复杂图形中选择非相邻对象。选择栏是一条直线,可以选择它穿过的所有对象。

⑦使用编组:使用GROUP命令(命令别名G)定义编组,在“选择对象”提示下输入G,输入编组名,构造选择集。或者使用未命名的编组来直接点选编组内的任一对象来选定整个编组,快捷键Ctrl+A用来切换编组选择开关。

5.绘制建筑图的一般步骤:建立模板文件,将常用设置如图层、标注样式、文字样式、多线样式等内容设置在一图形样板文件中(即另存为*.dwt文件),以后绘制新图时可在创建新图形向导中单击使用样板来打开它,并开始绘图。在有些时候,需要从另一个文档中复制图层、标注样式、图块等设置时,就可以使用“设计中心”来实现,或者可以通过打开另一个文档,AUTOCAD2000可以在多文档中拖动复制各种对象和格式。

6.其他几点建议。在绘图的过程中,图层的使用非常重要,它可以快速的选择、编辑对象,而且使图纸样式统一,各种线条清晰明了;在绘图的时候,尽量使用重复命令,以减少每次输入命令的时间;使用方向键来调出刚使用过的命令,减少重复输入命令;对于较复杂的图形,使用图形清理命令PU来清理不使用的块、标注样式、图层、文字样式、线形等对象类型,提高计算机的运算速度。

在使用计算机绘图的过程中,要多操作,多总结,有不清楚的地方要多查看有关书籍,AUTOCAD2000中文版的联机帮助也是一本非常出色的参考书,大家可以多看,多学习,共同提高。

巧借EXCEL在AUTOCAD中绘曲线

在工程计算时,经常要用AutoCAD画出一条曲线,而这条曲线如果是由多个坐标点连接成的,输入起来就麻烦,而且容易出错。如果利用EXCEL应用程序来保存数据,并与CAD 巧妙地结合起来,就能很容易地画出该曲线。具体方法为

首先,在Excel中输入坐标值。我们将x坐标值放入A列,y坐标值放入到B列,再将A列和B列合并成C列,由于AutoCAD中二维坐标点之间是用逗号隔开的,所以我们在C2单元格中输入:“=A2&”,“&B2”,C2中就出现了一对坐标值。我们用鼠标拖动的方法将C2的的公式进行复制,就可以得到一组坐标值。

其次,选出所需画线的点的坐标值,如上例中C列数据,将其复制到剪贴板上,即按Excel中的复制按钮来完成此工作。

最后,打开AutoCAD,在左下角处可以看见命令行(左下图),

在“command”后键入“spline”(画曲线命令),出现提示:“Object/:”,再在此位置处

点击鼠标右键,弹出菜单,在菜单中选“Paste”命令,这样在Excel中的坐标值就传送到了AutoCAD中,并自动连接成曲线,单击鼠标右键,取消继续画线状态,曲线就画好了。

通过上面的方法,可以很方便地绘制各种曲线或折线,并且在Excel中很容易地修改并保存坐标值。

此主题相关图片如下:

几何计算器应用示例。

引言

几何计算器是AutoCAD R12提供的一个十分有用的工具。和普通的计算器一样,几何计算器可以完成+、-、*和/的运算以及三角函数的运算。这使得用户在使用AutoCAD绘图过程中,可以在不中断命令的情况下用计算机进行算术运算,AutoCAD则将运算的结果直接作为命令的参数使用。但重要的是,和一般的计算器不同,AutoCAD几何计算器可以作几何运算。它可以作坐标点和坐标点之间的加减运算,可以使用AutoCAD的OSNAP模式捕捉屏幕上的坐标点参与运算,还可以自动计算几何坐标点。如计算两条相交直线的交点,计算直线上的等分点等。此外,AutoCAD几何计算器还具有计算矢量和法线的功能。当然,AutoCAD几何计算器还有其它的功能,这里就不一一罗列。

在使用AutoCAD绘图中,常常需要确定一些无法直接给出坐标的点。例如,任意两点间的中点;和任意方向直线相切的圆的圆心;以及直线上任意等分点等。这就是我们通常所说的CAD绘图的定位问题。实际上,在许多计算机绘图场合,定位是否方便和精确往往直接影响作图的效率和速度。因此,应该充分利用AutoCAD几何计算器的几何运算功能,来实现AutoCAD绘图中的快速定位。

在命令提示Command:下键入CAL或激活下拉式菜单的辅助菜单项拾取其中几何计算菜单项都可启动AutoCAD几何计算器。CAL命令也是一个透明命令,可以在其它的命令下随时启动几何计算器。此外,还可以在AutoLISP程序中使用CAL命令。

下面是利用AutoCAD几何计算器的几何运算功能实现在AutoCAD绘图中经常遇到的几个快速定位的实例。

1.在两实体间确定中点

这里不需先在两个实体之间画一条辅助线再用OSNAP的MID模式得到中点。例如,要从一个圆心和一直线的端点之间的中心为起点画一直线。操作过程如下:Command: line

From point: 'cal (启动几何计算器)

>> Expression: (cen+end)/2 (输入表达式,这里计算器把OSNAP的cen和end模式当作点坐标的临时存储单元)

>> Select entity for CEN snap用光标捕捉圆心)

>> Select entity for END snap用光标捕捉直线的端点)

To point:

其它的目标捕捉模式如int、ins 、tan等等均可在几何计算表达式中使用。如果用表达式(cur+cur)/2代替表达式(cen+end)/2,则可以在计算机要求输入点时,再设定OSNAP方式来捕捉所需的点。

2.确定一条直线上的任意等分点和与直线端点定长的点

使用几何计算器提供的plt和pld函数可以完成这个操作。假设屏幕上有一端点为A和B的直线,要在直线上获得分直线段AB为1比2的点。仍以画直线为例,操作过程如下:Command: line

From point: 'cal

>> Expression: plt(end,end,1/3)

>> Select entity for END snap用光标捕捉端点A)

>> Select entity for END snap用光标捕捉端点B后即得到距A点为1/3线段长的点) To point:

如果要得到直线上距端点A为5的点,使用函数pld(end,end,5)代替上面操作过程中的plt(end,end,1/3)即可。

3.用相对坐标来确定点

在绘图中,经常要相对一条线画出另一条线,下面就是操作过程:

Command: line

From point: 'cal

>> Expression: end+[2,3](作点和点的相加运算)

>> Select entity for END snap捕捉一基准直线的端点后即可获得距端点相对位移(2,3)的点)

To point:

这个功能和AutoCAD R13中提供的From目标捕捉模式相似。

4.作和一斜线相切的圆以及过圆上一点作圆的切线

利用AutoCAD正交模式可容易地画出和垂直线或水平线相切的圆。画一个和斜线相切的圆则需要准确地确定圆心。操作过程如下:

Command: circle

3P/2P/TTR/

: 'cal

>> Expression: cur+3*nee(cur表示用光标在屏幕上拾取一个点,nee函数用来计算两端点矢量的法线,3是圆的半径)

>> Enter a point:nea(用光标在直线上捕捉一个点作为圆和直线的切点)

to >> Select one endpoint for NEE用光标捕捉直线的一个端点)

>> Select another endpoint for NEE用光标捕捉直线上的另一个端点)

Diameter/ <1.6745>: 3(给出圆的半径后即可画出这个圆)

改变光标捕捉直线两个端点的顺序可在直线的另一侧画圆。

假设过圆和一直线的交点作圆的切线的操作过程如下:

Command: line

From point: int(捕捉交点)

of

To point: 'cal

>> Expression: int+3*nor(cen,int)

>> Select entity for INT snap用光标捕捉交点)

>> Select entity for CEN snap用光标捕捉圆心)

>> Select entity for INT snap再用光标捕捉交点即画出从交点出发长度为3的已知圆的切线)

To point:

5.过一条斜线上的已知点作斜线的垂线

因为是非水平非垂直的直线所以不能用AutoCAD的正交模式画直线的垂线。利用几何

计算器可直接画出和斜线垂直并且为确定长度的直线。实际上这是一个如何确定垂线的另一个端点的问题。其操作过程如下:

Command: line

From point: mid(设过直线的中点作垂线)

of

To point: 'cal

>> Expression: mid+5*nee(5是垂线的长度)

>> Select entity for MID snap用光标选择斜线捕捉中点)

>> Select one endpoint for NEE用光标捕捉直线的端点)

>> Select another endpoint for NEE用光标捕捉直线的另一个端点)

to point:

同样,改变光标捕捉直线端点的顺序,也可在直线的另一侧画垂线。

补充相关示例

本帖包含附件

2003112811541133727.rar ( 27.52 KB,已被下载401 次)

请使用WinRAR软件打开RAR压缩文件。

45. 在AutoCAD中有时尺寸箭头及Trace画的轨迹线变为空心,用TRIMMODE命令,在提示行下输新值1可将其重新变为实心。

46. 用AutoCAD打开一张旧图,有时会遇到异常错误而中断退出,这时首先使用40介绍的方法,如果问题仍然存在,则可以新建一个图形文件,而把旧图用图块形式插入,可以解决问题。

打开别人图时,找不到原文件的字体怎么办?很好的方法!希望固定!

打开别人一张图时,要不停的替换我没有的字体文件,怎样才能一劳永逸?

答:有两种办法,

一:复制要替换的字库为将被替换的字库名,如,打开一幅图,提示找不到jd字库,你想用hztxt.shx替换它,那么你可以把hztxt.shx 复制一份,命名为jd.shx,就可以解决了。不过这种办法的缺点显而易见,太占用磁盘空间。最好用下面这种办法。

二:在autocad r14/support 目录下创建acad.fmp文件,如果原来有此文件直接打开,这是一个ASCII文件,输入"jd;hztxt",如果还有别的字体要替换,可以另起一行,如“jh;hztxt",存盘退出,以后如果你打开的图包含jd和jh这样你机子里没有的字库,就再也不会不停的要你找字库替换了。

解决AutoCAD在XP操作系统下打印时致命错误的方法

近来,有些会员反映AutoCAD 2002 版或2004版本在点击打印时出现致命错误并退出AutoCAD的现象。

经过我的研究,这跟AutoCAD 2002及以上版本使用打印戳记有关。在2000版时,增补的打印戳记功能就有很多的BUG,这个功能在2002版本后就直接做为AutoCAD功能。该功能在98操作系统中是完全没有问题的,但在有些XP系统中就会出错。所以在XP系统中最好不要去开启该功能。

如果你已经不幸开启了该功能而使AutoCAD在打印时出现致命错误,解决的方法只能是这

样:

在AutoCAD的根目录下找到AcPltStamp.arx文件,把它改为其它名称或删除掉。

这样再进行打印就不会再出错了,但也少了打印戳记的功能。该方法对于2002版及2004版均有效。

如何快速的绘图

一、熟悉对CAD中基本操作命令/快捷图标的使用

这一点大多数人都知道,古人云:熟能生巧。基本命令与快捷图标便是CAD中大家最熟悉的,也应该能熟练掌握了,所以不详谈了。

二、ACAD.PGP文件修改

大家都知道LINE命令在COMMAND输入时可简化为L,为何会如此呢?因为在AutoCAD中有一个加密文件ACAD.PGP中定义了LINE命令的简写,先找出这个文件打开它。找到"These examples include most frequently used commands."的提示语,在其下的几行文字就可对简写的定义,记住它的左列是简写命令的文字实现你可以根据你的需要进行修改(当然是你比较熟悉的英文缩写喽),它的右列是默认的命令请不要随意修改。相信这能为你提高一定的速度。

三、对图形夹点操作

夹点,你用过吗?当你用鼠标左键点击图形,图形上便会出现许多方框这些就是夹点。通过控制夹点便能进行一些基本的编辑操作。如:COPY,MOVE,改变图形所在的图层等基本操作。而且不同的图形,还有其特殊的操作。如:直线有延伸操作。

四、大量使用修改命令

对于CAD绘图工作人员来说,一幅图60%--70%是修改只有30%--40%是作图,这一点并不难理解。从图形构成来看图形只有直线与曲线这两种,而曲线又由大量的圆进行剪切而成的,所以一张图最终由直线和圆组成。既然如此作图只需先画圆或直线并确定位置,然后进行一系列操作如:OFFSET, TRIM, FILLET, ARRAY, CHAMFER等,来实现图形。

如一个轴承的绘图,只需两条互相垂直的直线,而后进行OFFSET,FILLET,CHAMFER 等一系列操作便能精确的完成轴承的绘制。

五、构建图块来简化绘图工作

图块是CAD操作中比较核心的工作,许多程序员与绘图工作者都建立了各种各样的图块。由于他们的工作给我们的带来了简便,我们能像砖瓦一样使用这些图块。如工程制图中建立各个规格的齿轮与轴承;建筑制图中建立一些门、窗、楼梯、台阶等以便在绘制时方便调用。

在这些图块中其中的柔性块最容易被调用,它其实是用Auto LISP/Visual LISP编写的程序。如要学习我推荐《Visual LISP使用教程》这本书。我主要介绍图形外部块的建立和调用。

1.建立图样原型的DWG文件并保存(在WBLOCK命令下的操作,要建立图块的基点,以便以后调用)

2.从InsertION中向需要图块的图形中加入图块。

通过这两部就能建立并运用图块了。图块的运用将进一步的提高绘图的速度。

关于鼠标的一点小技巧:

***AUX2

'_zoom _w

***AUX3

'_zoom _p

'pan

***AUX4

'layer$p0=tool $p0=*

'layer

在acad.mnu中做上面的设置你只要按住shift键然后击鼠标

右键就可以框选放大(zoom w)

按住ctrl键然后击鼠标

右键就可以回到上一次图形窗口(zoom p)

你还为cad2000的中键功能与原r14的中键弹出的osnap功能

冲突而苦恼吗ctrl+p即可解决

优化AutoCAD系統的方法

一、优化Windows系统

1.清理维护磁盘,优化Windows系统性能

如果AutoCAD发生故障,可能会导致非正常地退出交换文件,并丢失一些磁盘簇。Windows系统在启动时会自动检查丢失的磁盘簇。如果不想重新启动系统,则可从命令行运行chkdsk。

2.整理磁盘碎片,优化Windows系统性能

什么是磁盘碎片?同一磁盘文件的各个部分分散在磁盘的不同区域,当在磁盘中删除旧文件添加新文件就会产生碎片。它减慢了磁盘的访问速度,降低了磁盘的综合性能。就如同一本小说不是印刷在连续的页面上,而是每隔几行需要出现“转到xxx页”。AutoCAD在运行时,需要在磁盘中创建一定的临时文件,倘若分布于磁盘碎片之中,自然降低速度。

运行“磁盘碎片整理程序”整理磁盘碎片?

二、优化AutoCAD系统

1.优化AutoCAD R13或早期版本创建的二维多段线和关联填充

自R14版起,AutoCAD以一种优化格式创建二维多段线和关联填充,这种优化格式可以节省内存和磁盘空间。请使用CONVERT命令更新AutoCAD R13及其早期版本创建的填充图案或多段线。

2.删除图形数据库中没有使用的命名对象,有效缩减图形文件尺寸

随着时间流逝,图形中可能会积累一些无用的命名对象(不在图中绘制出的对象)。例如,图形文字不再使用的文字样式,或者不包含任何图形对象的图层;更有甚者,包含巨大的未使用的图块等。清理操作只删除一个层次的引用。可能需要重复执行三次以上方可彻底完成清理操作。注意若在开始绘图时,执行清理废料,可能会清理掉已定义的绘图模板。

3.编组会严重影响选择类操作的速度,应删除

编组是已命名的对象选择集,与未命名的选择集不同,编组是随图形保存的。编组是属于命名对象,但可惜不能够用PURGE命令清除。如果删除一个对象或把它从编组中删除使编组为空,那么编组仍保持原定义。如若存在大量空的编组,严重影响选择速度。

4.网络版优化

AutoCAD无论是安装在网络服务器上,还是安装在客户端工作站上,用户都可以共享服务器硬盘上的数据并且把不希望共享的图形储存在本地硬盘上。两种方法各有其优点。在客户端工作站上安装AutoCAD可以优化网络性能。在服务器上安装AutoCAD可以让用户

共享一份可执行文件,从而节省磁盘空间并使软件的安装和升级大大简化。也可以根据自己的网络配置,把客户端安装和服务器上安装结合起来。

5.按需加载和优化外部参照的性能

通过结合使用按需加载和保存索引的图形,可以提高包含外部参照的图形的性能。打开按需加载时,如果索引已保存到参照图形中,AutoCAD将只从参照图形中把与重生成当前图形有关的数据加载到内存中。换句话说,被参照的材料是根据需要读取的。按需加载的优异性能表现在:(1)剪裁外部参照以显示它的一小部分,并且空间索引已保存在外部参照图形中;(2)冻结外部参照的几个图层,并且图层索引与外部参照图形共同保存。

6.将其他几何图形加载到局部打开的图形中

如果处理一个很大的图形,可以使用“局部打开”选项选择图形中要处理的视图和图层中的对象(仅限于图形对象)。在图形被局部打开后,可以使用PARTIALOAD命令将其他几何图形从视图、选定的区域或图层中加载到图形中。

7.其他操作技巧

(1)冻结或关闭图层冻结图层时AutoCAD不刷新被冻结图层上的物体数据库,从而提高速度。关闭图层时,方便操作,不需重新生成。

(2)关闭可见元素图形的复杂程度会影响AutoCAD刷新屏幕或处理命令的速度。如果需要提高程序的性能,可关闭文本、线宽、填充、亮显选择内容以及点标记。

(3)改变临时交换文件位置Windows的Temp目录是临时交换文件的缺省位置。可以在“选项”对话框的“文件”选项卡中找到“临时图形文件位置”,通过增加记录项可以指定不同的目录。

(4)管理光栅图像,如:临时卸载图像,拆离图形中不再需要的图像,控制图像显示质量。

(5)临时卸载外部参照。

(6)使用SHX字体替换TTF字体。

(7)控制合适的显示性能。

☆运用虚拟屏幕,减少重生成。

☆显示精度。可以使用VIEWRES命令和FACETRES系统变量控制圆、圆弧和椭圆的显示精度。

☆禁止带光栅图像平移和缩放。系统变量RTDISPLAY=1。

☆仅亮显光栅图像边框。IMAGEHLT=0。

☆关闭实体填充。FILLMODE=0。

(8)添加RAM是最有效的提高系统性能的方法。安装更多的RAM可以降低AutoCAD使用临时交换和页调度的需求,达到优化性能的目的。

(9)若内存较小时,使用永久交换文件,其速度比临时交换文件的速度更快。硬盘预留一定的空间,以备系统缓冲之用。

(10)对于很大的三维图,强迫AutoCAD将模型空间的对象看作二维的对象可以更有效地利用内存。相关系统变量是TREEMAX和TREEDEPTH。

三、扩充软件,丰富专业知识

(1)采用基于AutoCAD平台的专业软件。AutoCAD可以绘制任意复杂的图形,但AUTODESK从来不推荐用户用最基本的命令一笔一划地绘图。

(2)运用正版软件,支持CAD事业的发展,新的产品必将提升您公司的生产力。

(3)做好工作组或公司内部的系统规划,充分利用用户定制的优势。

(4)参加AUTODESK认证培训,整体提高CAD设计队伍的能力。

使用AutoCAD 2000 提高绘图效率的途径和技法

一、遵循一定的作图原则

为了提高作图速度,用户最好遵循如下的作图原则:

1.作图步骤:设置图幅→设置单位及精度→建立若干图层→设置对象样式→开始绘图。

2.绘图始终使用1:1比例。为改变图样的大小,可在打印时于图纸空间内设置不同的打印比例。

3.为不同类型的图元对象设置不同的图层、颜色及线宽,而图元对象的颜色、线型及线宽都应由图层控制(BYLAYER)。

4.需精确绘图时,可使用栅格捕捉功能,并将栅格捕捉间距设为适当的数值。

5.不要将图框和图形绘在同一幅图中,应在布局(LAYOUT)中将图框按块插入,然后打印出图。

6.对于有名对象,如视图、图层、图块、线型、文字样式、打印样式等,命名时不仅要简明,而且要遵循一定的规律,以便于查找和使用。

7.将一些常用设置,如图层、标注样式、文字样式、栅格捕捉等内容设置在一图形模板文件中(即另存为*.DWF文件),以后绘制新图时,可在创建新图形向导中单击"使用模板"来打开它,并开始绘图。

二、选用合适的命令

用户能够驾驭AutoCAD,是通过向它发出一系列的命令实现的。AutoCAD接到命令后,会立即执行该命令并完成其相应的功能。在具体操作过程中,尽管可有多种途径能够达到同样的目的,但如果命令选用得当,则会明显减少操作步骤,提高绘图效率。下面仅列举了几个较典型的案例。

1.生成直线或线段

(1)在AutoCAD中,使用LINE、XLINE、RAY、PLINE、MLINE命令均可生成直线或线段,但唯有LINE命令使用的频率最高,也最为灵活。

(2)为保证物体三视图之间"长对正、宽相等、高平齐"的对应关系,应选用XLINE和RAY命令绘出若干条辅助线,然后再用TRIM剪截掉多余的部分。

(3)欲快速生成一条封闭的填充边界,或想构造一个面域,则应选用PLINE命令。用PLINE生成的线段可用PEDIT命令进行编辑。

(4)当一次生成多条彼此平行的线段,且各条线段可能使用不同的颜色和线型时,可选择MLINE命令。

2.注释文本

(1)在使用文本注释时,如果注释中的文字具有同样的格式,注释又很短,则选用TEXT (DTEXT)命令。

(2)当需要书写大段文字,且段落中的文字可能具有不同格式,如字体、字高、颜色、专用符号、分子式等,则应使用MTEXT命令。

3.复制图形或特性

(1)在同一图形文件中,若将图形只复制一次,则应选用COPY命令。

(2)在同一图形文件中,将某图形随意复制多次,则应选用COPY命令的MULTIPLE (重复)选项;或者,使用COPYCLIP(普通复制)或COPYBASE(指定基点后复制)命令将需要的图形复制到剪贴板,然后再使用PASTECLIP(普通粘贴)或PASTEBLOCK(以块的形式粘帖)命令粘帖到多处指定的位置。

(3)在同一图形文件中,如果复制后的图形按一定规律排列,如形成若干行若干列,或者沿某圆周(圆弧)均匀分布,则应选用ARRAY命令。

(4)在同一图形文件中,欲生成多条彼此平行、间隔相等或不等的线条,或者生成一

系列同心椭圆(弧)、圆(弧)等,则应选用OFFSET命令。

(5)在同一图形文件中,如果需要复制的数量相当大,为了减少文件的大小,或便于日后统一修改,则应把指定的图形用BLOCK命令定义为块,再选用Insert或MInsert命令将块插入即可。

(6)在多个图形文档之间复制图形,可采用两种办法。其一,使用命令操作。先在打开的源文件中使用COPYCLIP或COPYBASE命令将图形复制到剪贴板中,然后在打开的目的文件中用PASTECLIP、PASTEBLOCK或PASTEORIG三者之一将图形复制到指定位置。这与在快捷菜单中选择相应的选项是等效的。其二,用鼠标直接拖拽被选图形。注意:在同一图形文件中拖拽只能是移动图形,而在两个图形文档之间拖拽才是复制图形。拖拽时,鼠标指针一定要指在选定图形的图线上而不是指在图线的夹点上。同时还要注意的是,用左键拖拽与用右键拖拽是有区别的。用左键是直接进行拖拽,而用右键拖拽时会弹出一快捷菜单,依据菜单提供的选项选择不同方式进行复制。

(7)在多个图形文档之间复制图形特性,应选用MA TCHPROP命令(需与PAINTPROP 命令匹配)。

三、使用快车工具(EXPRESS TOOLS)

所谓快车工具,实际上是为用户设计并随AutoCAD 2000一起免费提供的实用工具库。该库中的大部分工具来自AutoCAD R14的优惠(Bonus)工具,其余的则已被舍弃或改进,同时又增加了一些新工具。快车工具在图层管理、对象选择、尺寸标注样式的输入/输出、图形的编辑修改等众多方面对AutoCAD进行了功能扩展,而且能非常容易地结合在AutoCAD 2000的菜单和工具条中,使用起来方便快捷,故能明显提高你绘图的工作效率。

安装快车工具的方法,是在安装AutoCAD 2000时选择"完全"安装,或者选择带有"快车工具"选项的"用户"安装。假如当初不是这样,则应以"增加"方式重新安装AutoCAD 2000,并选择需添加的"快车工具"。

缺省时,AutoCAD 2000在启动时不把快车工具装入内存,以缩短其启动时间。当你第一次使用快车工具时,工具库会自动装入。不过你也可以在开始时用EXPRESS TOOLS命令强行装入。在已正确安装了快车工具的前提下,如果屏幕上未出现其"快车"菜单,你可以使用EXPRESS MENU命令将菜单显示出来。

下面则是在屏幕上显示"快车"工具条的方法步骤:

(1)在下拉式菜单中,选择视图>工具条...,则出现"工具条"对话框。

(2)在名为"菜单组"的下拉组合框中,选择"快车"。

(3)在名为"工具条"的组合框中点选所需要的选项。凡冠以"X"的选项,将在屏幕上显示其工具条。

(4)单击"关闭"按钮,退出对话框。

四、打开或关闭一些可视要素

图形的复杂程度影响到AutoCAD执行命令和刷新屏幕的速度。打开或关闭一些可视要素(如填充、宽线、文本、标示点、加亮选择等)能够增强AutoCAD的性能。

(1)如果把FILL设为OFF,则关闭实体填充模式,新画的迹线、具有宽度的多义线、填充多边形等,只会显示一个轮廓,它们在打印时不被输出。而填充模式对已有图形的影响效果,可使用REGEN命令显示出来。另外,系统变量FILLMODE除控制填充模式之外,还控制着所有阴影线的显示与否。

(2)关闭宽线显示。宽线增加了线条的宽度。宽线在打印时按实际值输出,但在模型空间中是按象素比例显示的。在使用AutoCAD绘图时,可通过状态条上的LWT按钮,或者从"格式"菜单中选择"宽线"选项,用"宽线设置"对话框将宽线显示关闭,以优化其显示性能。系统变量LWDISPLAY也控制着当前图形中的宽线显示。

(3)如果把QTEXT设为ON,则打开快显文本模式。这样,在图样中新添加的文本会被隐匿起来只显示一个边框,打印输出时也是如此。该设置对已有文本的影响效果,可使用REGEN命令进行显示。另外,系统变量QTEXTMODE也控制着文本是否显示。这在图样中的文本较多时,对系统性能的影响是很明显的。

(4)禁止显示标示点。所谓标示点,是在选择图形对象或定位一点时出现在AutoCAD 绘图区内的一些临时标记。它们能作为参考点,能用REDRAW或REGEN命令清除,但打印输出时并不出现在图纸上。欲禁止标示点显示,可将BLIPMODE设为OFF,以增强AutoCAD的性能。

(5)取消加亮选择。在缺省情况下,AutoCAD使用"加亮"来表示当前正被选择的图形。然而,将系统变量HIGHLIGHT的值从1改为0,取消加亮选择时,也可增强AutoCAD的性能。

(6)顺便一提的是,将系统变量REGENMODE的值设为0,或者将REGENAUTO设为OFF,可以节省图形自动重新生成的时间。

五、及时清理图形

在一个图形文件中可能存在着一些没有使用的图层、图块、文本样式、尺寸标注样式、线型等无用对象。这些无用对象不仅增大文件的尺寸,而且能降低AutoCAD的性能。用户应及时使用PURGE命令进行清理。由于图形对象经常出现嵌套,因此往往需要用户接连使用几次PURGE命令才能将无用对象清理干净。

六、使用命令别名和加速键

AutoCAD为一些比较常用的命令或菜单项定义了别名和加速键。使用命令别名和加速键可以明显节省访问命令的时间。命令别名是在acad.pgp文件中定义的。用任何文本编辑器打开并编辑该文件,就可以添加、删除或更改命令别名。用这种方法定义的别名,当重新进入AutoCAD时即可使用。在最新的软件版本中,用户不必退出AutoCAD就可以利用快车工具重新定义命令别名,但如果使用这种方法,则需要在第一次使用新定义的别名之前,执行REINIT命令以对软件重新初始化。

命令加速键是在acad.mnu文件中定义的。欲添加、删除或更改命令加速键,用户只能用文本编辑器对acad.mnu文件进行编辑修改。修改过的*.mnu文件必须用MENU命令加载并编译后,新定义的命令加速键方可使用。

一、AutoCAD表格制作

AutoCAD尽管有强大的图形功能,但表格处理功能相对较弱,而在实际工作中,往往需要在AutoCAD中制作各种表格,如工程数量表等,如何高效制作表格,是一个很实用的问题。在AutoCAD环境下用手工画线方法绘制表格,然后,再在表格中填写文字,不但效率低下,而且,很难精确控制文字的书写位置,文字排版也很成问题。尽管AutoCAD支持对象链接与嵌入,可以插入Word或Excel表格,但是一方面修改起来不是很方便,一点小小的修改就得进入Word或Excel,修改完成后,又得退回到AutoCAD,另一方面,一些特殊符号如一级钢筋符号以及二级钢筋符号等,在Word或Excel中很难输入,那么有没有两全其美的方法呢,经过探索,可以这样较好解决:先在Excel中制完表格,复制到剪贴板,然后再在AutoCAD环境下选择edit菜单中的Paste special,选择作为AutoCAD Entities,确定以后,表格即转化成AutoCAD实体,用explode炸开,即可以编辑其中的线条及方字,非常方便。

二、在Word文档中插入AutoCAD图形

Word文档制作中,往往需要各种插图,Word绘图功能有限,特别是复杂的图形,该缺点更加明显,AutoCAD是专业绘图软件,功能强大,很适合绘制比较复杂的图形,用AutoCAD

绘制好图形,然后插入Word制作复合文档是解决问题的好办法,可以用AutoCAD提供的EXPORT功能先将AutocAD图形以BMP或WMF等格式输出,然后插入Word文档,也可以先将AutoCAD图形拷贝到剪贴板,再在Word文档中粘贴。须注意的是,由于AutoCAD 默认背景颜色为黑色,而Word背景颜色为白色,首先应将AutoCAD图形背景颜色改成白色。另外,AutoCAD图形插入Word文档后,往往空边过大,效果不理想。利用Word图片工具栏上的裁剪功能进行修整,空边过大问题即可解决。

三、线宽修改

AutoCAD提供了一个多义线线宽修改命令PEDIT,来进行多义线线宽的修改(若不是多义线,则该命令将先转化成多义线,再改变其线宽),但是PEDIT操作繁,每次只能选取1个实体操作,效率低下。AutoCAD R14附赠程序Bonus提供了mpedit命令,用于成批修改多义线线宽,非常方便高效。在AutoCAD2000中,还可给实体指定线宽(LineWeight)属性修改线宽,只需选择要改变线宽的实体(实体集),改变线宽属性即可,线宽修改更加方便,须注意的是,LineWeight属性线宽在屏幕的显示与否决定于系统变量LWDISPLAY,该变量为ON,则在屏幕上显示LineWeight属性线宽,该变量为OFF,则不显示。多义线线宽同LineWeight都可控制实体线宽,两者之间的区别是,LineWeight线宽是绝对线宽,而多义线线宽是相对线宽,也就是说,无论图形以多大尺寸打印,LineWeight线宽都不变,而多义线线宽则随打印尺寸比例大小变化而变化,命令scale对LineWeight线宽没什么影响,无论实体被缩放多少倍,LineWeight线宽都不变,而多义线线宽则随缩放比例改变而改变。

四、图形的打印技巧

由于没有安装打印机或想用别人高档打印机输入AutoCAD图形,需要到别的计算机去打印AutoCAD图形,但是别的计算机也可能没安装AutoCAD,或者因为各种原因(如AutoCAD 图形在别的计算机上字体显示不正常,通过网络打印,网络打印不正常等),不能利用别的计算机进行正常打印,这时,可以先在自己计算机上将AutoCAD图形打印到文件,形成打印机文件,然后,再在别的计算机上用DOS的拷贝命令将打印机文件输出到打印机,方法为:copy <打印机文件>prn /b,须注意的是,为了能使用该功能,需先在系统中添加别的计算机上特定型号打印机,并将它设为默认打印机,另外,COPY后不要忘了在最后加/b,表明以二进制形式将打印机文件输出到打印机。

五、选择技巧

用户可以用鼠标一个一个地选择目标,选择的目标逐个地添加到选择集中,另外,AutoCAD 还提供了Window(以键入“w”响应Select object:或直接在屏幕上自右至左拉一个矩形框响应Select object:提示),Crossing(以键入“C”响应Select object:或直接在屏幕上自左至右拉一个矩形框响应Select object:提示),Cpolygon(以键入“CP”响应Select object:),Wpolygon(以键入“WP”响应Select object:)等多种窗口方式选择目标,其中Window及Crossing用于矩形窗口,而Wpolygon及Cpolygon用于多边形窗口,在Window及Wpolygon 方式下,只有当实体的所有部分都被包含在窗口时,实体才被选中,而在Crossing及Cpolygon 方式下,只要实体的一部分包括在窗口内,实体就被选择像。AutoCAD还提供了Fence方式(以键入“F”响应Select object:)选择实体,画出一条不闭合的折线,所有和该折线相交的实体即被选择。在选择目标时,有时会不小心选中不该选择的目标,这时用户可以键入R来响应“select objects:”提示,然后把一些误选的目标从选择集中剔除,然后键入A,再向选择集中添加目标。当所选择实体和别的实体紧挨在一起时可在按住CTRL键的同时,然后连续单击鼠标左键,这时紧挨在一起的实体依次高亮度显示,直到所选实体高亮度显示,再按下enter键(或单击鼠标右键),即选择了该实体。还可以有条件选择实体,即用'filter 响应select objects:,在AutoCAD2000中,还提供了QuickSelect方式选择实体,功能和filter 类似,但操作更简单,方便。AutoCAD提供的选择集的构造方法功能很强,灵活恰当地使

用可使制图的效率大大提高。

六、质量属性查询

AutoCAD提供点坐标(ID),距离(Distance),面积(area)的查询,给图形的分析带来了很大的方便,但是在实际工作中,有时还须查询实体质量属性特性,AutoCAD提供实体质量属性查询(Mass Properties),可以方便查询实体的惯性矩、面积矩、实体的质心等,须注意的是,对于曲线、多义线构造的闭合区域,应先用region命令将闭合区域面域化,再执行质量属性查询,才可查询实体的惯性矩、面积矩、实体的质心等属性。

[原创] 轻松删除顽固图层之秒招(r0r提供)

几大专业CAD网站中经常能看到这样的贴子:处理图样时要把不用的图层删除掉,虽然把这个图层内的所有图形都删除了,你就是删除不了该图层,动用了所有删除及相关的工具也是枉然。这种情况在处理别处转来的图样时最会碰到,有时真的只能望层兴叹,除非采用第三方工具软件,否则除了无奈还是无奈。

在一次不经意的操作过程中,我意外发现了一个非常有效的方法,屡试屡爽,百发百中,高兴之余决定拿出来与大家共享:打开一个CAD文件,在图面上只留下你需要的可见图形;点文件-另存为,确定文件名,在文件类型栏选*.DXF格式,在弹出的对话窗口中点工具-选项-DXF选项,再在选择对象处打钩,点确定,接着点保存,就可选择保存对象了;把可见或要用的图形选上就可以确定保存了,完成后退出这个刚保存的文件,再打开来看看,你会发现你不想要的图层不见了,哈哈,爽吧!

这其实是个DXF格式的选择性保存命令,不过隐藏得有点深,很少用到这个命令,巧的是由于工作需要我经常要用该命令,还被我当作删除顽固图层之另类用法,可能连该软件的制作公司都不曾想到呢,请大家活学活用,在此法下再也没有删不掉的图层了,当然0层除外。

2000、2002、2004使用通过,R14没用过,估计这功能也有吧。

如果要删除的层里面有实体,就要先把实体删除才行,把要删的层先关闭.

2 还有一个方法,在VBA版块中提过。(由MCCAD提供)

可以全选图形,然后选择文件菜单->输出->块文件,这样的块文件就是选中部分的图形了,如果这些图形中没有指定的层,这些层也不会被保存在新的图块图形中。

3 将无用的图层关闭,全选,COPY 粘贴至一新文件中,那些无用的图层就不会贴过来。如果曾经在这个不要的图层中定义过块,又在另一图层中插入了这个块,那么这个不要的图层是不能用这种方法删除的(由hellmen 提供)

4 用图层过虑可以非常简单而又很方便的解决这个问题,把与你的习惯不一样的图层全部转换成你的图层就可以了,这样来消除没有用的图层有个好处就是你只是在你这个文件中编辑,根本不要转换文件格式啊,复制粘贴到一个新文件中那么麻烦,。最后用purge命令,消除没有用的块啊,图层啊,线形啊等等什么的,一个清爽的图就出现在您的面前了,(文件大小可以缩小到原来的30~50%哟~)

鼠标的功能!

二键式鼠标

左键:选择功能键(选象素选点选功能)

右键:绘图区-----快捷菜单或[ENTER]功能

1.变量SHORTCUTMENU 等于0---------[ENTER]

2.变量SHORTCUTMENU 大于0---------快捷菜单

3.或用于环境选项--------使用者设定---------快捷菜单开关设定

[shift]+右键:对象捕捉快捷菜单

三键式鼠标

左键:选择功能键(选象素选点选功能)

右键:绘图区-----快捷菜单或[ENTER]功能

1.变量SHORTCUTMENU 等于0---------[ENTER]

2.变量SHORTCUTMENU 大于0---------快捷菜单

3.或用于环境选项--------使用者设定---------快捷菜单开关设定

中间键:Mbuttonpan=1(系统默认值)

压着不放并拖曳实现平移

双击ZOOM ------E缩放成实际范围

[Shift]+压着不放并拖曳作垂直或水平的实时平移

[Ctrl]+压着不放并拖曳随意式实时平移

Mbuttonpan=0 对象捕捉快捷菜单

[Shift]+右键对象捕捉快捷菜单

二键+中间滚轮鼠标

左键:选择功能键(选象素选点选功能)

右键:绘图区-----快捷菜单或[ENTER]功能

1.变量SHORTCUTMENU 等于0---------[ENTER]

2.变量SHORTCUTMENU 大于0---------快捷菜单

3.或用于环境选项--------使用者设定---------快捷菜单开关设定

中间滚轮1.旋转轮子向前或向后,实时缩放、拉近、拉远

2.压轮子不放并拖曳实时平移

3.双击ZOOM ------E缩放成实际范围

[Shift]+压轮子不放并拖曳作垂直或水平的实时平移

[Ctrl]+压轮子不放并拖曳随意式实时平移

Mbuttonpan=0 (系统默认值=1)按一下轮子对象捕捉快捷菜单[Shift]+右键对象捕捉快捷菜单

这是我看书过程中觉得好的,我想跟大家分享分享!

制造特效字体[转贴]

打开AutoCAD2000中文版(注意:某些字体特效用AutoCADR14无法完成),并做好各项设置。这里图形界限为42000×29700mm,字体高度2000mm,你可以依自己的习惯自行设置,其它我就不罗嗦了。

---第一例:空心字---

我们先来做一种最基本的效果。

步骤:

1、键入“Mtext”(多行文字)命令,打开“多行文字编辑器”,“字符”标签里选择一种中文字体,例如综艺体,并输入“空心字”三个字。

注:字体要选择笔划有宽度的,中英文均可,单线体(如txt.shx,gbenor.shx,gbcbig.shx 等)没有什么效果处理可言(谁说的?)。

2、键入“Txtexp”(分解文字)命令,选择全部,回车分解所选文字。

注:在AutoCAD中,文字属于一类特殊的对象,必须分解成线后,才能对其进行更多的处理。“Txtexp”(分解文字)是Express工具集中的命令(即AutoCAD2000中文版菜单栏上的“快捷工具”,安装时你必须全部或定制安装才行),该命令的功能是把文字分解为

组成它的直线和圆弧。注意,不要用“Explode”(分解)命令。

3、键入“Trim”(修剪)命令,框选“空心字”,剪掉每个文字笔划内部多余的线条。

4、键入“Boundary”(建立边界)命令,确认“高级”标签下“对象类型”里为“多义线”选项,按“拾取点”按钮,在每个笔划内部逐一点击,回车。

注:因修剪后笔划成为许多个独立的零碎直线和圆弧,所以用这个命令再把每一个笔划连成封闭的多义线。注意,该命令的结果,实际上是在原地复制了一份对象,并且颜色变为随层色。可将原对象删除,以免影响操作。另外,对空心字而言,这一步也可不做(做了也无妨,下同),这里为后面某些字效的处理做准备。

5、在屏幕上框选“背景字”,按“Ctrl+1”,打开“对象特性”对话框,在“颜色”栏里,选择一种颜色,或者单击右侧的下拉箭头,选“其它”,这里有更多的颜色可供选择。 注:下面的制作除必要外不再进行颜色选择这一步,你可以自行更改颜色。

好了,空心字制作完毕,是不是挺简单?

(以下除有说明外均进行空心字的制作过程)。

---第二例:描边字---

步骤:

1、输入“描边字”,字体为琥珀体,并选择一种颜色,将“描边字”向旁边拷贝一份,注意在执行“Txtexp”(分解文字)命令之前进行复制,并输入一个整数值,方便后边操作。

2、键入“Mpedit(多重多义线编辑)命令,框选所有文字,回车,键入“W”,回车后输入新的线宽,本例中输入40。

注:线宽数值不要太大,否则笔划间距就小,打印出来会模糊不清。

另外,如键入“S”(样条曲线)选项,可以制作“曲线字”。看看效果,是不是很意外?注意确认在执行“Boundary”(建立边界)命令后删除了原对象,否则有的笔划存在反转扭曲现象。

3、键入“Move”(移动)命令,选择拷贝的那份文字,输入第一步中记下的数值,将其移动到原位。

---第三例:外框字---

外框字也就是轮廓字,我们用“偏移”命令来制作。

步骤:

1、输入“外框字”字,字体为黑体,并将“外框字”向旁边拷贝一份,并输入一个整数值,方便后边操作,同样,在执行“Txtexp”(分解文字)命令之前进行。

2、键入“Office”(偏移)命令,输入合适的偏移距离,本例中输入150,点选“外”字的各个部分,将其同心拷贝,用同样的方法制作另两字的外框。

注:对某些字而言,内部笔划不用偏移,例如“国”字,只偏移“口”就行了,这是与“描边字”不同的地方。

3、键入“Trim”(修剪)命令,逐一剪掉多余的部分,只保留每个字的外轮廓。

注:有的汉字笔划较多,偏移后重复的地方也太多,稍不注意就会修剪出错,故你可以采取边偏移边修剪的方法。修剪完毕后,使用“Boundary”命令建立边界,你就可以进行多次偏移,从而制作出多层的轮廓效果。

4、最后键入“Move”(移动)命令,输入第一步中记下的数值,把刚才拷贝在一边的“外框字”移到原位置对齐即可。

---第四例:拉伸字---

步骤:

1、输入“拉伸字”,字体为黑体。

2、键入“Stretch”(拉伸)命令,分别框选各个文字的上或下半部分向上或下拉伸。 注:如果你有把握,可用“Mstretch”(多重图元拉伸)命令一次性完成。有时,也需要逐个笔划进行拉伸,以创造更为夸张的效果。

3、键入“Solid”(填充)命令,逐一填充文字的所有笔划,完成。

注:对于带圆弧的笔划最好分多次填充,才能保持原来的外观。另外,如果用下面将提到的“图案填充”命令并选择“Solid”图案,会更加省事。

在AutoCAD中,文字的胖瘦可通过两种方式修改,第一,用“Dtext”(动态文本)命令输入文字,然后在“对象特性”对话框里修改“宽度”,或者用“Textfit”(文字调整)命令在屏幕上调整,该命令仅对动态文本有效。第二,在“文字样式”对话框中调整“宽度比例”。应该说这不属于拉伸字的范畴,这里仅为大家作一个说明。

---第五例:立体字---

步骤:

1、输入“立体字”,字体为琥珀体,并在分解文字之前拷贝一份后用。

2、键入“Extrued”(挤压)命令,框选“立体字”,提示“拉伸高度”输入“-300”。 注:之所以输入负值,是在执行第六步后可使拷贝的“立体字”移到原位置能居于立体字的上端面。若输入正值,应将其沿Z轴正向移动相同的高度,其结果是一样的。

3、键入“Rotate3d”(三维旋转)命令,框选“立体字”,回车,按“两点”从左到右定义轴,随后输入旋转角度,例如30。

注:文字似乎变矮了,实际上文字本身高度并没有变矮,只是在三维旋转的作用下,文字与XY平面成一角度,由于投影的关系才变得矮了。

4、再次执行该命令,按“两点”从上到下定义轴,角度依然输入30。

5、用同样的方法将刚才拷贝在一边的“立体字”按相同的角度旋转两次。

6、键入“Move”(移动)命令,把旋转后的“立体字”移到原位置对齐即可。

立体字就这么做好了,是不是有点旁门左道?所以显得别扭些,我试了多种办法也没有把字正过来,不知哪位朋友有高招。

---第六例:网格字---

既然字体被分解后转化为直线和圆弧,就可以使用“图案填充”命令,下面我们就利用这个命令来制作几例字体效果,先来做网格字。

步骤:

1、输入“网格字”,字体为琥珀体。

注:建议选择笔划较粗的字体,这样容易出效果。

2、键入“Bhatch”(图案填充)命令,打开“图案填充”对话框,点“快速”标签下“图案”右边的按钮,打开“图案填充”调色板,单击“ANSI”标签,选择名为“ANSI37”的图案,“确定”后返回,在“比例中”输入合适的值,点“拾取点”按钮,在笔划内部逐一单击,回车单击“确定”。

注:如果填充图案太密,或拒绝填充,用“Hatchedit”(图案填充编辑)命令进行调整,直到比例合适为止。