文档库

最新最全的文档下载
当前位置:文档库 > WORD公式编辑器使用方法

WORD公式编辑器使用方法

公式编辑器简明教程(1)--公式编辑器的基本知识

★公式编辑器的来历

你一定知道在Word中有个“公式编辑器”应用程序,但你可能不清楚它其实不是微软公司开发的,它是Design Science公司的Mathtype“公式编辑器”特别版,是为Microsoft应用程序而定制的。

★公式编辑器的安装

“公式编辑器”不是Office默认安装的组件,如果要使用它,重新安装Office至如图1所示步骤时,在“O ffice工具”中选择“公式编辑器”,从选项中选择“从本机运行”,继续进行安装就可以将“公式编辑器”安装成功了。

WORD公式编辑器使用方法

图1

★启动公式编辑器

需要编辑公式时,单击“插入→对象”命令,打开“对象”对话框(如图2所示),在“对象类型”中找到“Mi crosoft公式3.0”,选定后,单击[确定]按钮,在文档中就插入了公式编辑窗口,此时文字与公式处于混排状态,如果你勾选了“显示为图标”前的复选框,在文档中插入的是“Microsoft公式3.0”的图标。

WORD公式编辑器使用方法

图2

双击图标,可打开一个独立的“公式编辑器”程序窗口,此程序窗口与Word程序窗口是相互独立的,在编辑公式过程中若想编辑文字,直接切换到Word程序窗口进行编辑即可,不需关闭“公式编辑器”程序窗口,给编辑文档带来了很多方便。

在“公式编辑器”程序窗口中编辑完公式后,单击“文件→更新”命令,或者按F3键,文档中的公式即被更新,若直接关闭了“公式编辑器”程序窗口,也可完成更新操作。

小提示:每次插入完一个公式,都要重新启动“公式编辑器”,是不是觉得有点麻烦?《数学工具》已经为您把“插入公式编辑器”这一功能放到了主工具栏中(如图3所示),你只需轻点鼠标就可以实现向当前Word文档敀数学公式了。

WORD公式编辑器使用方法

3

★工具栏的组成

创建公式主要是由“公式编辑器”工具栏来完成的,先来认识一下它吧:“公式编辑器”工具栏的组成如图4所示,在工具栏上排列着两行共19个按钮,将鼠标箭头停留在按钮上,会自动显示各按钮的提示信息。

WORD公式编辑器使用方法

图4

用顶行的按钮可插入150多个数学符号,其中许多符号在标准Symbol字体中没有,如果需要输入特殊符号,尽管在这里查找好了。

底行的按钮用于插入模板或结构,它们包括分式、根式、求和、积分、乘积和矩阵等符号,以及各种围栏。许多模板包含插槽(键入文字和插入符号的空间)。工具板上的模板大约有120个(分组显示),我们可以通过嵌套模板(把模板插入另一个模板的插槽中)来创建复杂的多级化公式,但嵌套的模板不能超过10级。

若要在公式中插入符号或模板,可单击工具栏上的相应按钮,然后在显示的工具板中单击特定符号模板。

★公式的创建

在公式编辑器中大家就可以建立需要的公式了,比如要建立如图5所示的公式:

WORD公式编辑器使用方法

图5

先键入“S”,然后在“上标和下标”模板中,选取带下标的选项(如图6),这时S的右侧就出现下标框,输入“ij”,然后按右光标键,使输入点再次变为普通字符,再输入“=”

WORD公式编辑器使用方法

图6

在工具栏中单击“求和模板”(如图7),在打开的选项中选择上下带虚框的求和符号,然后将光标置于相应的位置框上,分别输入“n”、“k=1”:

WORD公式编辑器使用方法

图7

单击工具栏上的“希腊字母”按钮(如图8),在α上单击一下,然后再按前面的方法输入下标“ik”,接下来要输入乘号,单击“数字符号”按钮,从中选取乘号。同样,再插入β及其下标,公式就输完了。

WORD公式编辑器使用方法

图8

单击公式编辑器菜单“文件”,选“退出并返回”,退出公式编辑环境,返回到Word中。这时候公式对象就可以像图形一样进行各种编辑操作。如果想改公式,只要双击公式结果,就又进入公式编辑器,可以对公式进行编辑修改操作。

★选定公式中的元素

能否准确、熟练地对公式中的元素进行选定,是对公式进行编辑的基础:可以用鼠标拖动的办法进行选定,也可以按住“Ctrl”键并单击修饰字符进行选定,还可以利用“Shift”键和光标键进行选定,而用鼠标左键双击也可以选定。

★定位、移动插入点

在“公式编辑器”中,插入点的水平线沿插槽底边闪动,竖线则沿插槽顶端到底端闪动,其大小和形状表明要键入的下一个文字或要插入的下一个符号显示的位置。

利用鼠标和键盘都可以定位插入点,用鼠标定位插入点很简单,但有时面对很小的插槽的确很难“下手”,这时应该考虑用键盘。

利用键盘在公式中移动插入点有多种方法:

1、首选考虑的是应用光标键,它可以对插入点准确地定位,利用向右键或向左键,可在当前的插槽或模板中向右或向左移动一个单位,而利用向上键或向下键可上移一行或下移一行。

2、“Tab”键对快速移动插入点有很大的帮助,按下“Tab”键,插入点移动到插槽的结尾,如果插入点已在结尾处,则移动到下一个逻辑插槽,若同时按下了“Shift”和“Tab”键,则插入点会移动到上一个插槽的结尾处。

3、要想将插入点快速移动到当前插槽的开始或结尾,“Home”和“End”键是最佳的选择。

★复制和移动公式

对于公式的复制或移动,在其创建过程或编辑的过程中都可以进行,也可以在文档中对创建好的公式进行操作,操作方法与对文本的操作类似。也可将公式编辑过程中选中的部分元素直接粘贴到正文中,粘贴后内容是作为“公式”保存的。

★删除公式中的项目

对于模板和插槽,在进行删除时首先要选定它们,再利用“BackSpace”键或“Delete”键,就可以快速删除,若单击“编辑→清除”命令也可删除。

若要恢复删除的内容,删除项目后,立即选择“编辑”菜单中的“撤消键入”命令即可,需要注意的是,撤消操作只能执行一次。若要删除插槽,最好先将插槽清空再删除,因为对于有些插槽,如果不先删除包含它们的模板,是不能将其删除的。

★给公式加编号

你可以在公式与文字混排时给公式加上编号,但有时在编辑公式过程中加上编号会更好一些,例如在书写方程组时,在编辑公式过程中可以非常容易地给每个方程加上编号(如图9所示),但如果在公式与文字混排时再给方程加编号,那就比较麻烦了。

WORD公式编辑器使用方法

图9

★应用内置样式

“公式编辑器”窗口的“样式”菜单中提供了“数学、文字、函数、变量、希腊字母”等几种内置样式,对这几种样式灵活、合理地运用,会使你的公式更加规范和美观。

应用样式时可以用鼠标来切换,也可以用键盘快速指定:

数学Ctrl Shift =:文字Ctrl Shift E:

函数Ctrl Shift F:变量Ctrl Shift I:

希腊字母Ctrl Shift G:

矩阵向量Ctrl Shift B:

★更改内置样式

若提供的样式不能满足需要,可以单击“样式”菜单中的“其他”命令,在打开的“其他样式”对话框中选择“公式编辑器”样式中没有的字体和字符格式。

★自定义内置样式

用“样式”菜单中的“定义”命令可以改变为每种内置样式(数学样式无指定字体和格式)定义的字体和字符格式。

选择“样式”菜单中的“定义”命令,打开“样式”对话框(如图9所示),单击要定义的样式右侧的箭头,列表框中会显示出默认打印机的有效字体,选择要使用的字体名称即可,若要使用加粗或倾斜字符格式,可选中“字符格式”下的“加粗”或“倾斜”复选框。

WORD公式编辑器使用方法

图10

★设置字符的字号

对内置样式的定义或改变,其实是对字符的字体进行设置,若要改变字符的字号,应使用“尺寸”菜单中的相关命令。若想改变“尺寸”的大小,可单击菜单中的“尺寸→定义”命令,打开“尺寸”对话框(如图11所示),对于各项在公式中对应的位置,在右侧预览中都有详细的提示,修改好各项尺寸的大小后单击[确定]或[应用]按钮即可。

图11

★调整元素间距

在“公式编辑器”窗口中,单击“格式→间距”命令,可打开“间距”对话框(如图12所示),在这里可以对公式中各元素的间距进行详细地设置,如对行距、元素间距、字符的高度、上标高度、根式间距等进行设置,对于每一项内容,对话框右侧都有预览说明和图示,若想恢复系统的默认设置,只要单击[默认]按钮就可以了。

图12

★增加空格

在编辑公式时,若要增加几个空格,你一定首先想到的是键盘上的空格键(Space),输入空格试一试?啊!怎么不行?先打开“样式”菜单瞧瞧吧,你一定选择的是“数学”样式吧,切换到“文字”样式中再试一试?可以输入空格了。

其实在“数学”样式中也可以用空格键输入空格,只要将输入法切换到“中文输入法”状态就可以了,为了输入一个空格,来回不断地切换真够麻烦的,其实可以用工具栏中的[插槽和省略号]按钮(如图3所示),其中提供了几种增加元素间距(或空格)的选项。

★精确调整公式

如果要对公式进行非常精确的控制、移动等,必须利用“微移”命令,“微移”可精确控制公式中各项目

的位置,在调整模板插槽的项目时尤其有用,实现的方法是:利用“Ctrl

光标键”可以“微移”所选项目。

★公式的对齐

在“公式编辑器”的“格式”菜单中,专门准备了几个对齐命令,其实还有一件对齐的秘密武器,它使公式在任意位置都能准确对齐,它隐藏在工具栏的[间距与省略号]按钮中,如图13(黑色矩形框内的符号),在每行的对齐位置插入这个符号,各行就会自动对齐。

WORD公式编辑器使用方法

图13

★公式与正文的排版

如果你在编辑完公式后马上就用鼠标在公式编辑框外单击,那么得到的公式将是“嵌入型”的公式,如果需要进行图文混排,不又是一件很头痛的事吗?

其实根本不用担心,公式对象的插入方式取决于我们在“工具”/“选项”/“编辑”选项卡中的“图片插入/粘贴方式(I):”框中的设置。对于已经插入的公式也可以随时作出改变,右击该公式,选择“设置对象格式”项,并在“版式”选项卡中将其转换为想要的类型就可以了。

经过前面的介绍,对“公式编辑器”的应用也略知一二了,下面我们就以拉格朗日插值公式为例(如图14所示),介绍一下如何应用“公式编辑器”。

WORD公式编辑器使用方法

图14 注:拉格朗日插值公式是根据数列的前n项的数据构造的数列通项公式,f(m)是第m项。

★制作过程

1、将“公式编辑器”的“样式”切换到“文字”样式,尺寸为“标准”状态。

2、用键盘输入f(m)=

3、从工具栏中的“求和模板”中选择一个“带中上标和中下标极限的求和符”,然后在中下标和中上标处用键盘分别输入i =1和n(这个在前面已经有介绍,在此就不再赘述了)。

4、接下来,将光标移到求和部分,从工具栏的“分式和根式模板”中选择“标准尺寸的竖分式”(如图1 5所示)

WORD公式编辑器使用方法

图15

5、将光标移到分子处,从工具栏的“乘积和集合论模板”中选择“带中上标和中下标极限的乘积”,然后按上一步同样的方法输入求积表达式。分母与分子的处理方法一样。

6、最就是输入数列的项a i ,将光标移到分数线外部,用键盘输入ai,然后用鼠标选中字母i ,然后再用鼠标点选“下标和上标模板”中的“下标”选项(如图16所示)。

WORD公式编辑器使用方法

图16

7、到这里,整个方程式就这样制作完成了。

★操作中应该注意的问题

1、制作下标时你可能首先想到的是插入“下标模板”,如果下标出现的次数比较多,这样要不断地进行鼠标和键盘的切换,可以试试先将下标的数字正常输入,再集中设置下标的方法:选中数字后,单击工具栏上的“尺寸→下标”命令,再重复几次所有下标就可以搞定了。或用本文中步骤6的方法比较快。

2、插入到Word文档中的公式是以inlineshape(即嵌入式图片)的形式保存的,你可能像操作图片一样给它加上底色,拖动控制点来改变它的大小等。

经过这一番的“亲密接触”,你是不是对“公式编辑器”更了解了呢?“公式编辑器”是Office的组件,所以它不仅能在Word中应用,在其他的Office程序如Excel、PowerPoint中都可以自如地使用,俗话说的好:“熟能生巧”,只要你不断地探索,相信你一定会很好地驾驭我们的好帮手——“公式编辑器”。

★修改公式编辑器提示窗口显示次数

对于经常录入大量数学公式的朋友来说,最讨厌的就是公式编辑器的提示:

每当用户使用了若干次公式编辑器后,就会有一个公式编辑器提示对话框弹出来,问你是否想了解有关“数学类型”的详细内容,如图1所示。若不选择“不再显示此信息”,则弹出间隔为100次:若选择“不再显示此信息”,则弹出间隔为500次,非常烦人。经过多次的研究,笔者发现该对话框虽然无法禁止,但可以延长其发作间隔:将500次延长为32767次。修改方法如下:

打开注册表,找到表项:

HKEY_CURRENT_USER\Software\Microsoft\Equation

Editor\3.0\Options\General,将MTUpgradeDialog的数值改为32767。

★常用快捷键指南

毋庸置疑,快捷键的使用能极大地提高录入公式的效率,公式编辑器的帮助文件中提供了全面的快捷键指南,这里只列出了一些比较重要的和帮助文件中不易找到的快捷键。

1、通用快捷键:

Ctrl+A:全选;Ctrl+X:剪切;Ctrl+C:复制;Ctrl+V:粘贴;Ctrl+B:加黑;C trl+S:保存;Shift+方向键:局部选择

2、常用快捷键:

Ctrl+H:上标;Crtl+L:下标;Ctrl+J:上下标; Crtl+R:根号;Ctrl+F:分号

★矩阵的对齐

矩阵的对齐没有快捷键,普通的对齐命令对其无效,所以有些朋友往往无法对齐矩阵中的公式,其实操作很简单:执行“格式-矩阵”命令,即可弹出矩阵对齐对话框,按照我们的需要操作就行了。

★公式编辑器的启动与退出

工具/自定义/键盘/插入/InsertEquation,把指针放在“请按新快捷键”下的空行内,按“Ctrl+Enter”(当然也可以用别的快捷键,不过这个最易操作),再顺次点击“指定”、“关闭”、“关闭”。以后在WORD中直接用按“Ctrl+Enter”即可启动公式编辑器,退出公式编辑器时,按Esc即可。

★上下标汉字的大小

有时上下标为汉字,则显得很小,看不清楚,可以对设置进行如下改变,操作为“尺寸/定义”,在出现的对话框中将上下标设为8磅。

★正文与公式字号的统一

如果word正文选用五号字,则将公式编辑器中“尺寸/定义”对话框中的“标准”定为11磅最为适宜。

★空格的输入

在输入法的全角状态下,可以输入空格,半角状态下则不可以。

★文字的加黑

在“样式/定义”中可以对文字进行加黑或倾斜等设置。

★特殊符号输入

在公式编辑中,一些特殊符号无法直接输入(如①、★、≌、∽、⊙等),可先在word正文中插入某个特殊符号,再通过“复制、粘贴”的方法将它移植到公式中。