文档库

最新最全的文档下载
当前位置:文档库 > PRE2001实用问题解答读书笔记

PRE2001实用问题解答读书笔记

PRO/E2001实用问题解答

读书笔记

1、如何调整右侧菜单宽度?

当用户自行新增命令规划菜单时,可能因命令名称过长而需要调整右侧菜单的宽度,可使用set_menu_width参数设置它的宽度,响应值从8到20,输入负值代表以系统宽度设置。此参数需要重新启动Pro/E才能起作用。

2、使用Pro/E时,右侧菜单所占屏幕位置过多,要如何设置才能有效使用屏幕空间?

在2001版本中,右侧菜单中的许多命令已通过Icon图标显示出来或利用Insert下拉式菜单实现操作,因此不需要占用太大空间,你可使用reserved_menu_space参数设置菜单空间大小,若输入较小数值(例如1)可缩小所占空间,Pro/E界面会往右拉宽以增加工绘图空间。此参数需要重新启动PRE才能起作用。另外,若同时设置Window_Scale参数且其数值过大,reserved_menu_spac e参数将盖过Window_Scale对空间的影响。

3、进入Pro/E后,其窗口界面底部仍有间隙,要使用哪个参数设置才能使界面充满屏幕?

可使用Window_Scale参数使界面充满屏幕,若界面陷阱电荷上下边界框已紧贴屏幕,输入再大的参数值都不会再有任何影响。若希望界面再往右扩增,可利用reservec_menu_space参数。此参数需要重新启动Pro/E才能起作用。

4、为何在菜单中看不到Slot命令?

在配置文件中设置allow_anatomic_features参数为Yes,便可使它出现在菜单中。

5、用线结构查看模型时,如何调整圆弧的平滑度?

执行View(视图)>Display Settings(显示设置)>Model Display(模型显示),在Model Display(模型显示)对话框中切换到Edge/Line(边/线)的Edge Quality(边质量)字段,将其设置为Very High(很高)可改变以线结构显示的圆弧平滑度,关闭对话框后便能查看设置的结果。

6、对模型着色进行查看时,如何调整圆弧的平滑度?

执行View(视图)>Display Settings(显示设置)>Model Display(模型显示),在Model Display(模型显示)对话框中切换到Shade(阴影)的Quality(质量)字段,输入的数值越高可改善圆弧的平滑度,设置完毕只要按Apply(应用)便可实时查看设置结果。

7、如何使用propagate_change_to_parents参数设置文件保存形式?

设置保存图文件时,其所属的最上层装配图文件是否同时保存,其响应值为:yes:当图文件有所变更并保存时,其所属的装配图文件同样要保存。例如:已打开某图文件A及参考A的装配图文件,当图文件A有所变更并保存时,参考它的装配图文件也会同时保存。No:只保存有所变更的图文件,其所属的装配图文件不加保存。

8、为何已设置save_object_in_current参数的响应值为Yes,但在其他目录中打开的文件还是无

法保存到当前工作目录中?

当override_store_back参数设置为no,并且用户没有该目录的保存权限时,save_object_in_current参数才会起作用。若要把在其他目录中打开的文件保存到当前工作目录中,请把override_store_back参数设置为Yes,通过防止文件回存原目录,使它保存在当前工作目录中。

9、override_store_back参数如何与save_object_in_current参数配合使用?

override_store_back参数主要控制文件是否回存原目录,以防止文件回存原目录,使它保存在当前工作目录中。若响应值为Yes,表示不要回存到所打开的源目录(就是保存在当前工作目录中);若响应值为No(默认值),表示要回存到所打开的源目录,此时若用户没有该目录的保存权限,save_object_in_current参数便会起作用,响应值为Yes,代表可以保存在当前工作目录中,响应值为No(默认值),则不可。一般我们会设置override_store_back参数为No,save_object_in_current参数

为Yes,避免既没有权限在原目录下存盘,又没有把文件存到工作目录中。当override_store_back设置为Yes,save_object_in_current参数为No,执行保存时,系统还是会把图文件保存到当前工作目录中(当override_store_back参数设置必须为No,并且用户没有该目录的保存权限时,save_object_in_current参数才会起作用)。当override_store_back参数与save_object_in_current参数同时设置为No(并且没有权限保存至源目录),执行保存时,系统会显示信息“保存的文件名could not be saved;Check disk space or write access.”。

10、执行Erase not Display(拭除不显示的)命令后,在Erase not Display对话框中发现有

些图文件需要保存,在此方面有何解决办法?

用户可配合prompt_on_erase_not_disp参数设置响应值为yes(默认值为no),使用Erase not Display 命令清除不显示在窗口的图文件。

其参数响应值为:

Yes:每次执行Erase not Display命令,按OK按钮关闭Erase not Display对话框后,系统在Message Area 中会询问是否保存清除的图文件,若以Yes响应,该图文件便被保存并从内存中清除。

No:默认值,Pro/E只显示Erase not Display对话框,按OK关闭对话框后,系统会直接把图文件从内存中清除。

11、退出Pro/E时,系统会问是否保存草图文件(例如:s2d0001、s2d0002的草图),要如

何设置配置文件才能在退出系统时不出现这些信息?

只要绘制草图(不管是否创建绘制特征),系统都会把它保存至内存,并用流水编号命名,当要退出系统时,便会在Message Area中显示这些草图文件名并询问是否保存。在绘制草图时,若以后有机会再次使用,请在当时立刻把它保存,否则在上述情况下,只看流水编号将难以判断哪些文件会再次使用,因此建议:

1)在配置文件中设置Prompt_on_exit参数以No为响应值(默认值),只要执行File(文件)>Eixt(退

出),便可直接退出系统,Message Area命令不会显示任何信息,但要小心如果刚才绘制的part、Drawing或Assembly并没有保存,系统还是不会加以询问就直接退出。

2)在配置文件中设置Prompt_on_exit参数以Yes. 为响应值, 执行File(文件)>Eixt(退出)后,系统

会先显示还没保存part、Drawing或Assembly,你可按需求保存,发询问Sketch文件时,直接输入q,代表以下的文件都不需要保存。

3)Allow_confirm_window:控制是否显示confirmation对话框,默认值为Yes,代表执行File(文

件)>Eixt(退出)后,系统会先显示confirmation对话框。若以No为响应值,而且Prompt_on_exit 参数以No,便直接退出。

12、不小心打开错误的大型装配图文件,该如何中途终止?

若不小心打开错误的文件,可连击屏幕右下方的红色图标,以终止读取文件,在旧版以前该图标会标示“Stop”字样。

13、每次使用Pro/E后,在工作目录中总会出现一些Trail文件(trail.txt),要如何设置其保

存路径?

只要激活Pro/E后,系统会在工作目录中产生Trail文件,若要有效地管理它们,可在配置文件中设置Trail_dir参数,通过Browser浏览指定的文件保存路径,一旦产生Trail文件,系统便会把它们存到该目录中。

Trail文件主要记录使用Pro/E的操作使用过程,用户无法令系统不产生它,若有需要,可利用Trail_delay设置Trail文件的每一步骤间的时间间隔。

14、每次新建新图文件时都需要New File Options对话框以浏览方式选取底图,可否设置默

认底图,只要在New对话框中单击OK按钮便可自动加载?

可在Config,pro文件设置Template_solidpart参数指定每次新建新图时都以该图文件为Part的底图。

另外,系统同时提供Template_designasm设置asm底图、Template_drawing设置drw底图、

Template_mfgcast设置t_casting.mfg底图、Template_mfgmold设置t_mold.mfg底图、Template_sheetmetalpart设置t_sheetmetal.prt。

15、如何设置Template的目录路径?

New File Options对话框所示的Template默认路径是“安装目录\Template”,若有需要,可在Config,pro 加设start_model_dir参数以自定义用户常用的样品文件目录路径。

16、如何设置配置文件使每次进入Pro/E后,系统能够加载指定的树状配置文件?

用户可把Moldel Tree设置成常用的形式再加以保存(其扩展名为*.cfg),然后在配置文件中设置mdl_tree_cfg_file参数,通过Browser浏览指定要加载的Moldel Tree文件。

相关参数:Moldel_tree_start:设置进入Pro/E后是否打开Moldel_tree,默认值为Yes。

17、配置文件(Config.pro)与权限配置文件(Config.sup)在使用上有何差异?

Config.sup可被视为配置文件的一种,它同样可用一般的字处理软件加以编辑,但其“权限”最大,所有记录在此文件中的环境参数不会被之后加载的配置文件覆盖,建议可将一些重要的环境参数记录在此文件中,再设置它在NT平台的修改权限。

启动Pro/E后,系统会先加载Config.sup,然后再根据配置文件放置不同目录的位置决定它们加载的先后次序。

18、建立快捷键(Mapkey)时,如何以功能键(Function Key)设置快捷键?

以功能键(Function Key)定义快捷键时,须配合输入“$”符号。例如要以F1定义某功能的快捷键,可在Key Sepuence文本框先输入“$”符号,再输入“F”与“1”。

F10为NT平台默认的快捷键,用户不要使用定义Mapkey。

19、哪一参数可设置进入草图模式后,是否以Intent Manager模式绘制草图?

若配置文件设置sketcher_intent_manager参数以Yes为响应值,便可控制每次进入草图后都以Intent Manager模式绘制草图;若以No为响应值,则以传统绘制模式(19版)绘制草图。

20、每次进入草图模式,系统都会显示Intent Manager的图标窗口,可否通过配置文件把它

关闭?

可在配置文件设置sketcher_overview_alert参数以NO为响应值。

21、在草绘器中,如何将实线变为辅助线?

按Ctrl+G,就可以。

22、如何在绘制圆的时候,在不选中椭圆命令的情况下切换至绘制椭圆?

不管用户是运行圆还是圆弧绘制命令,只要配合按shift键并拖曳鼠标,便自动切换成椭圆或椭圆圆弧命令,反之也同样可相互切换。

23、如何将灰色显示的默认尺寸(Weak Dimension)变为黄色显示的使用尺寸(Strong

Dimension)?

选中要改变的尺寸,按Ctrl+T键,则可改变。

24、绘制草图时,如何控制是否设置系统自行建立的限制条件?

在Intent Manager模式下绘制图素,系统自行产生限制条件(以红色显示),若不希望该条件设置到图素,可按鼠标右键(反复切换以红色显示的条件是否起作用),若有两个或两个以上的限制条件同时出现(例如:同时水平与等长),按鼠标右键只设置以红色显示的条件作用与否,但用户可按切换使其他条件轮流作用(以受鼠标右键控制),若有需要可同时按与鼠标右键,锁住以红色显示的限制条件,此是会以圆圈符号示之,不管如何拖曳鼠标,该条件还是锁住并设置到图素,当再同时按与鼠标右键或直接按右键时便能解除锁定模式。

25、Ctrl+Alt+A可运行截图命令。

26、如何使用Edit>Convert To>Tapered功能?

当草图图素以Offset Edge(偏置边)偏移产生时,可利用Tapered(锥形)修正首尾两端为不同偏移量。如:进入特征草图并以Offset Edge偏移建立图素,选取图素后运行Edit(编辑)>Convert To(转换

到)>Tapered(锥形)命令便会在另一端产生偏移尺寸,修改成其他数值后便可成形为拉伸特征。

27、在2001版中,草图的Text命令有何新增功能?

运行Sketch>Text命令绘制文字,可利用Text对话框的Place Along Curve(沿曲线放置)功能,选中曲线,使文字依其曲率放置。

28、Pre2001可直接打开的dxf文档,利用cad图形进行绘图。

29、如何在草图模式中参考使用AutoCAD的图文件?

运行Sketch>Data from File(数据来自文件)命令,可以加载其他*.sec的草图、工程图图文件(*.drw)、IGES或AUTOCAD的Drawing格式图文件。若仍在使用旧版的Pro/E而且没有购买IGES Translator 模块,可用Dxf或Dwg存盘,再从Pro/E的Drawing模块读取并以工程图图文件(*.drw)格式存盘,便可从草图模式中读取。

30、Surface(曲面)>Transform(转换)功能除了可应用于曲面外,是否也可用于基准曲线?

通过Transform(转换)功能,用户可以对基准曲线以复制或不复制方式进行位移、旋转、映射的操作。

31、如何把以Thru Points方式构建的基准曲线在其端点以切线方向作延伸?

以构建基准曲线的合成曲线(Composite Curve)命令点选曲线,选取Exact>Trim/Extend,点选Next调整要开始延伸的端点,系统会显示青色的十字点,按Accept确定,用户可利用Drag只作延长拖曳,或利用Enter Length以输入正值方式依端点以切线方向延伸。

32、以Formed(印贴)方式投影的曲线运动与通过Projected>Along Dir(投影>垂直于草绘

平面)、Projected>Normal to Surf(投影>垂直于曲面)方式投影的曲线有何差异?

以Projected>Along Dir(投影>垂直于草绘平面)进行投影时,系统会依照用户指定的投影方向产生曲线;以Projected>Normal to Surf(投影>垂直于曲面)方式投影时,系统会依照曲面法线进行投影,也就是说曲线上的点以最短的距离投影至曲面,这些点便构成Normal to Surf投影的曲线。以Formed(印贴)方式投影的曲线,其长度与草图图素长度相同。

33、为何以成形Formed(印贴)方式构建投影的曲线会失败?

若成形投影的曲面无法展开成为平面,系统将难以定义成形的基准曲线,用户可在Config.pro配置文件中设置mesh_spline_surf参数以Yes为响应值。无法展开成为平面的曲面会以蓝色网线显示,也就是说,没有显示蓝色网线的曲面可能无法被曲线成形投影,但只要以蓝色网线显示的曲面,都无法被曲线成形投影。

34、在草绘中,设置参考时,References(参照)对话框中的Xsec(X截面)有何作用?

用户可通过此选项点选特征表面,系统会以该表面与绘图平面的相交处作为参考标注尺寸。

35、在装配中以Use Edge选取其他模型边界产生的图素,如何保留这些图素并删除参考条

件?

以Use Edge(使用边)所产生的图素不会有任何尺寸标注,其几何限制参考条件符号为“~”,用户以左健点选图素使其以红色显示,按右键选取Next,再执行Delete命令,系统便会显示尺寸,或者从参考对话框中,直接选取删除。

36、在草图上以负值显示的尺寸,当草图成形为特征后,在模型上会以正值显示,此时用

Modify命令修改该特征尺寸成为负值,如何决定其方向?

以配置文件参数show_dim_sign默认的响应值,草图尺寸可以显示真正的符号(正与负),但特征尺寸只以正值显示。当以Modify点选特征尺寸时,用户不必理会其草图的真正符号,输入正值,图素便以正方向改变,若输入负值,则作反方向修改。

show_dim_sign:默认值为NO,若以Yes为响应值,特征尺寸的符号将与草图尺寸符号相同;若数值为负会显示为负号。

37、在草图中如何设置关系式?

在草绘器中点草绘下的关系键,便可对关系式作相应设置。

38、草图的尺寸已建立关系式(Relation),当要重新标注时,关系式需被重新定义,要如何

保留关系式并重新标注尺寸?

可在Edit(编辑)>Replace(替换)命令点选要被修改的尺寸(此尺寸便会消失),再以鼠标点选要被标注的尺寸线并按鼠标中键,重新放置尺寸,其关系式仍有效。

39、何为已知尺寸(Known Dimension),如何标注?

在特征草图中标注时,直接标注已知实体的尺寸为已知尺寸(Known Dimension),这些尺寸符号会以Kd#表示(一般尺寸符号为sd#,,参考尺寸符号为rsd#),用户只可在特征草图中建立已知尺寸,其功能主要是通过关系式在草图恙特征之间建立互动的参数关系。

40、构建扫描特征时,构建对话框中的Attributes(属性)选项在哪种情况下显示Add inn Faces

(增加内部因素)/No inn Faces(无内部因素)、Free Ends(自由端点)/Merge Ends(合并终点)?哪种情况下并不会出现Attributes(属性)选项供我们设置构建属性?

若扫描轨迹为开放性的,Attributes(属性)选项显示Free Ends(自由端点)/Merge Ends(合并终点);若扫描轨迹为封闭性的,Attributes(属性)选项显示Add inn Faces/No inn Faces;若扫描轨迹为3D路径(轨迹不在一平面上)、实体边界(不管其边界是否在一平面上)或是以投影(Projected)(不管投影后的曲线是否在一平面上)建立的基准曲线,都无法定义Attributes(属性)选项。当Attributes(属性)选项为Free Ends(自由端点)/Merge Ends(合并终点),剖面草图必须为封闭的。No inn Faces:剖面草图必须为封闭的;Add inn Faces:剖面草图必须为开放。

41、构建扫描特征时,为何设置Attributes(属性)选项为Merge Ends(合并终点)时无法建构建

特征?

1、顺接后的特征端面已超越相接的实体特征表面。

2、轨迹以多条图素定义时,连接至实体特征的端点的轨迹不是直线,不容易使用Merge Ends功能。

42、以Sweep(扫描)构建扫掠特征时,为何无法利用通过点(Thru Points)作为轨迹构建

特征?

系统不允许将以从文件写入((From File),从方程式定义(From Equation)或通过点(Thru Points)等方式建立的基准线作为Sweep命令的轨迹路径。若需要可使用Variable Section Sweep(可变截面扫描)以通过点(Thru Points)的基准线作为轨迹构建扫掠特征。

43、为何构建Variable Section Sweep特征时,系统告知:“Could not setup sketching plane”。

即使已定义所有轨迹,也无法进入草图绘制剖面?

以Norm to Origin Traj(垂直于原始轨迹)方式构建特征时,一般建议原法线轨迹(Original Trajectory)起点与X轴法线轨迹(X-Vector)在同一平面或其长度比X轴法线轨迹短。

44、构建弹簧时,为何不能利用已存在的螺旋轨迹为扫掠路径并直接用Sweep(扫描)命令

构建弹簧,而需要另外通过Helical Sweep命令配合绘制轨迹轮廓定义弹簧?

利用从文件写入(From File)、从方程定义(From Equation)或通过点(Thru Points)等方式建立的螺旋轨迹,虽可在其端点的法线定义绘图平面,但该平面可作360度的旋转,无法定义查看方向,故不可。

45、如何构建椭圆轨迹的螺旋弹簧?

以Advanced(高级)>Helical Sweep(螺旋扫描)构建的弹簧,其轮廓为圆形,若要装配的配件的剖面为特殊形状,则可能需要利用以Intr.Surfs(曲面求交)方式构建的基准曲线定义轨迹。

1、先利用surface(曲面)>New>Extrude(拉伸)构建一个开放性的特殊曲面(如椭圆)

2、执行surface(曲面)>New>Advanced(高级)>Helical Swp(螺旋扫描)建立一个螺旋曲面,

3、点选基准曲线中的Intr.Surfs(曲面求交)命令,以Whole(整个)方式点选第一步中建立的曲面,再以

Whole(整个)方式点选第二步中建立的曲面,得到相交的螺旋曲线,

4、执行Feature(特征)>Create(创建)>Protrusion(加材料)>Sweep(扫描),即可建立一个特殊形状的弹簧。

由上得知:只要通过Intr.Surfs(曲面求交)方式构建的基准曲线都可作为扫描特征的轨迹。

46、用Advanced(高级)>Helical Sweep(螺旋扫描)构建弹簧时,如何设置参数使保持圈

数不变的情况下,只要改变其长度便可改变节距,以模拟其实际装配至零组件的情况?

若要模拟弹簧压缩情况,用户需通过关系式,其操作步骤如下:

1、先建立弹簧。

2、执行Relations(关系)>Add Param(增加参数)>Real Number(实数),输入N(设置用户参数并命名为

N,代表弹簧圈数),再输入5(弹簧圈数)。

定义用户参数(圈数)时,建议以Real Number(实数)为圈数的参数属性,若属性为整数(Integer),系统将无法接受非整数,如4.5圈的弹簧。

3、在Relations(关系)菜单中点选弹簧,显示其参数尺寸,执行Relations(关系)>Add(增加),在Message

Area中输入节距=长度/N(圈数),修改原长度,执行再生后,发现弹簧会压缩,圈数仍然不变。

而系统自动调整弹簧节距。

4、若要改变圈数,可执行Set Up(设置)>Parameters(参数)>Modify(修改),点选N的参数,输入新

值后再生即可。

47、混合合扫描中,两剖面线段数目不同时,应如何定义草图?

参考书一般多会注明进行混合的两剖面的线段数目必须相同,严格而言,系统是要求剖面与剖面之间的顶点(Vertex)数目相同(并不是线段数目相同)。若从三角形混合扫描成四边形,只要在三角形的剖面草图上用鼠标点选所要的顶点,执行Sketch(草绘)>Feature Tools(特征工具)>Blend Vertex(混合顶点)设置顶点(两顶点重叠),使两剖面顶点数相同,便能成功构建混合特征。

若其中一个剖面为圆形,可能无法设置混合顶点(Blend Vertex),此时剖面定义步骤如下:

1、执行Divide命令在圆形草图四个适当位置打断。

2、设置对齐条件至4个断点,使它们作水平与垂直对齐。

3、绘制矩形图素使其通过四个断点,再把它转成中心线(辅助图素),便能成功定义草图并使其顺接

至四边形的剖面。

4、若从三边形混合扫描至五边形,可在三边形草图同一顶点加设两个混合顶点(Blend V ertex),第二

个混合顶点的直径会比第一个的大。

48、当构建混合扫描特征时,哪种情况下会在构建特征对话框中显示Join(合并)/No Join选

项?它们有何功能?

当构建混合扫描、可变截面扫描、或者扫描特征时,只要以选取方式选取曲面边界为扫描轨迹,系统便会询问构建的曲面是否与边界相接的曲面连接,成功连接的边界将以紫色显示(已成为单边边界),此功能可省去执行Merge(合并)命令。要进行Surface(曲面)>Transform(转换)的时候,它们被视为同一曲面,但要执行抑制或删除时,它们便被视为两个特征。

49、如何在轨迹上设置混合扫描(Swept Blend)特征的剖面?

当定义扫描轨迹的多条图素相切相接时,在接点位置可增加剖面。若希望在指定的位置追加剖面,可先在轨迹上加设基准点以定义新增剖面的位置(一般会以On Curve方式构建),再调整基准点构建次序至混合扫描特征之前,以Redefine命令点选。在Sections(截面)菜單中点(Add)增加,若有多个基准点产生时,可用Next/Previous选项设置要加设剖面的点。

50、如何利用面积曲线图(Area Graphs)控制混合扫描(Swept Blend)特征在轨迹上的剖

面面积的变化?

构建混合扫描的特征,系统以默认计算方式控制两剖面的面积扫描变化。通过面积曲线图,可以在不需要绘制草图的情况下,控制剖面变化直接在轨迹上指定的点设置其面积。其操作步骤如下:

1、执行Redefine(重定义)命令點选特征,在构建特征对话框中选取Blend Control(用面积或周长控制

曲线)选项,在Blend Control面板中选取Area Graph(面积控制曲线)>Done,出现面积曲线图(Area Grahps)。

2、在Define Graph面板中Add Point(增加点)中选取已建立的基准点(或利用Create Point再加设基准

点),在Message Area中输入所要的面积数值(如:800),若要改变数值,可用Change V alue(改变值)点选基准点(配合菜单选取功能)并输入所要数值。

3、以Modify命令点选特征可看到Area800的面积参数。

4、利用已建立的基准点定义面积曲线图后,若要让系统作默认的变化计算,可在Blend Control面板

中选取None(无)>Done。虽然特征面积不再受面积曲线图的控制,但特征仍为基准点的子系,在此情况下,用户必须在Define Graph菜单中用Remove Point(删除点)功能把基准点删除,才可以取消与基准点的父子参考关系。

51、为何构建Tweak Offset(扭曲>偏距)特征时,建议尽量不要使用Side Norm To Surface(侧

边垂直于曲面)功能?

因为若所选的表面有弧度,以Side Norm To Surface(侧边垂直于曲面)所定义的特征边缘表面可能造成无法拖模。

52、为何构建Tweak(扭曲)>Replace(替换)特征时,有时候会失败?

请确认所选取的曲面的边界超越被取代的表面,避免系统因无法把曲面边界合理延伸而失败。另外,执行Replace命令时,尽量不要改变模型的拓扑几何,否则特征会构建失败。

53、可配合基准面代替一般的曲面执行Tweak(扭曲)>Replace(替换)构建特征吗?

系统允许用户选取基准面代替一般的曲面进行Replace(替换)。配合偏移的基准面进行特征表面取代,可把拉伸的柱子特征改变成为切除的挖孔特征。

54、不小心用Delete删除了重要的特征,如何挽救?

1、先打开含有这些特征的旧版本文件。

2、在所要的文件中执行Feature>Copy>Same

Refs>FromDifVers>Done,在Window窗口下点选旧版本文件。3、再点选所要复制的特征,单击Done 按钮,在Scale菜单中执行Same Dims>Done,便可把被删除的特征利用复制方式挽救回来。

55、如何使用Copy from different model(从不同模型中复制特征)命令?

1、先打开含有要复制特征的文件。

2、在所要的文件中执行Feature>Copy>New Refs(新参考)>

FromDifModle(从不同模型) >Done,在Window窗口下点选含有要复制特征的文件。3、再点选所要复制的特征,单击Done按钮,在Sel Ref(选取参考)>Alternate(替换)命令中反回原模型文件,点选相同的参考。然后按Done,即可。

56、什么情况下会使用Same Refs(相同参考)>Indepent(独立)方式进行特征复制?

在一个特征中含有两个不同对象(如:在加材料拉抻中含有矩形与圆两个对象),使二个不同对象具有独立的高度修改参数,可执行Feature>Copy>Same Refs>Independent选取它,在Gpvar Dims菜单中按Done按钮表示不要修改任何尺寸,按OK退出对话框,然后用Redefine(重定义)可分别删除不要的对象,即可将一个特征分成两个相对独立的不同特征。

57、如何以Dependent(从属)方式进行特征复制,同时设置某些参数为Independent(独立)?

不管以Dependent(从属)方式还是以Independent(独立)方式进行复制,只要在GP V AR DIMS菜单中勾选参数尺寸,该尺寸便成为独立属性。

58、如何把以参考方式Dependent(从属)复制的特征的属性改为独立性质(Independent)?

在特征菜单中执行Modify(修改)>Make Indep(独立),在Make Indep菜单中利用Dimension(尺寸)命令点选复制的特征尺寸,该尺寸便成为独立性质,利用Section(截面)命令点选复制的特征,其草图尺寸便成为独立性质,其他尺寸还是保持参考属性。

59、已利用Make Datum方式定义了绘图平面,为何无法角度尺寸进行Pattem(阵列)?

无法进行Pattern(阵列)的原因多为草图定义不当。当遇到无法Pattem(阵列)的特征时,建议先单独以Modify对特征进行修改,把它的位置改变成第二个复制特征的位置,看它在该位置可否成形或几何有否变化,找到变化的原因,删除不必要的参考,即可。

60、如何以Pattem(阵列)命令构建不同位移增量的阵列特征?

可执行Pattem(阵列)命令点选要阵列的特征,在PAT DIM INCR(阵列尺寸增量)菜单中选取Tab(表)选

项,点选将要修改的特征尺寸参数,按Done,便可构建不同增量的阵列特征。

PRE2001实用问题解答读书笔记

执行Modify>Pattern Table命令,系统会显示TABLES对话框,就可以对阵列表进行编辑等操作。62、在2001版下打开i2版的零件图文件,该图文件是否支持面向对象功能?

可以利用面向对象功能对特征进行编辑。直接用鼠标双击特征,系统会以青色显示其草图,在草图顶点(V ertex)也会显示黄色的点,用户可随意拖曳图素或顶点,从而修改特征形状。

点选特征后单击右键,在出现的对话框中选动态修改,可直接对特征作深度方向拖曳。

63、为何点选特征并显示白手图标符号后,无法抓取图素进行拖曳?

不管草图标注的尺寸属性为默认的还是使用尺寸,用户都可对草图进行拖曳,但如果图素以几何限制条件固定在特征上,该图素便无法被拖曳。

64、如何设置鼠标点选对象的有效范围?

可通过配置文件参数Pick_aperture_radius设置。

65、如何设置使鼠标点选对象后在Message Area中显示特征编号?

以配置文件参数provide_pick_message_always以Yes为响应值,便能随时点选对象并在Message Area 中显示特征编号。

66、以Modify修改特征尺寸后,Message Area中并没有显示原来的尺寸,要如何快速查询

修改前的尺寸值?

执行Info(信息)>Session Info(进程信息)>Message Log(消息日志)命令,在所示的Message Log对话框中会显示特征被修改前的尺寸值。

67、如何避免不小心以Delete命令删除特征?

在Part图文件中,执行Feature>Read Only(只读)命令点选特征,可避免不小心删除特征。若要恢复可再次执行Feature>Read Only(只读)>Clean(清除),就可恢复。

68、如何对模型进行比例缩放?

在PART菜单下执行Modify>Scale Model,然后输入比例值。

69、如何更改特征名称?

在Feature>Set Up(设置)>Name(名称),后点选特征,就可更改。

70、如何对特征进行注释?

在Feature>Set Up(设置)>Notes(注释),后就可进行建立、修改、删除、移动等注释。

71、如何在特征尺寸后加入文字描述?

执行Modify>DimCosmetics(尺寸装钸)>Text(文本)命令,点选尺寸后在Message Area输入要描述的文字,按Enter可切换至第二行继续输入,再按Enter结束。

72、如何设置特征尺寸显示的小数位?

执行Modify>DimCosmetics(尺寸装钸)>Num Digits(小数位数),个别点选要修改小数位的尺寸,或在Config.pro文件中设置default_dec_place参数控制整环境的小数位,所设置的参数不会影响草图环境与执行Modify>DimCosmetics(尺寸装钸)>Num Digits(小数位数)命令设置的小数位值。

相关参数:Sketcher_dec_places参数控制草图环境的小数位。

73、在Pro/E的Surface(曲面)与Quilt(面组)在定义上有何差异?

在Pro/E系统中,若独立存在的对象只有面积但不具有体积,称为Quilt(面组);实体表面、基准面与Quilt(面组),都属于Surface(曲面)。

74、描述曲面的连续性的“C0、C1、C2”的定义为何?

两曲面共同相接于同一边界称为C0连续;若两曲面共同相切于同一边界,斜率为连续(曲率不一定连续),称为C1连续(一阶导数连续);当两曲面在共同相接的边界曲率相同,则称为C2连续(二阶导数连续)。

75、G2连续与C2连续有何差异?

C2连续乃指曲线曲率连续,面G2连续则指几何上的连续,所以两曲线可能不是C2连续,但仍可具有G2连续的特性。

76、单边边界(Single-Sided Edge)的定义是什么,在屏幕上如何显示?

该边界只属于一个曲面,描述曲面的外围边界视为单边边界,在屏幕上以黄色显示。

77、双边边界(Double-Sided Edge)的定义是什么,在屏幕上如何显示?

该边界同时属于两个曲面,当两曲面以Merge(合并)指令相接后,产生的相接边界便视为双边边界,在屏幕上以紫色显示。

78、如何改变曲面的法线方向?

执行Feature(特征)>Create(创建)>Surface(曲面)>Transform(转换)>Flip Normal(翻转方向)命令,可调整曲面的法线方向。

79、如何设置参数数使执行Shade(着色)命令时,可以看到基准曲线与模型边界?

在下拉式菜单View(视图)>Display Settings(显示设置)>Model Display(模型显示)对话框中勾选Shade字段的With DatumCurve(带基准曲线),勾选With Edges(带边)选项以显示模型边界。另外,对应Config.pro的参数分别是Shade_with以Curves为响应值显示基准曲线,Show_shaded_edges以Yes 为响应值显示模型边界。

80、show_geom_checks_on_creation,设置值为Yes时,当正在创建的特征具有几何检测功能时,在特征

创建结束时,就会出现“显示错误菜单”。

81、如何设置参数使执行Shade命令时,只对实体着色(曲面并不会着色)?

在下拉式菜单View(视图)>Display Settings(显示设置)>Model Display(模型显示)对话框中不要勾选Shade字段的Surface features(曲面特征)选项,表示不显示曲面。另外,也可在Config.pro中设置Shade_surface_feat参数以NO响应时,曲面特征并不会随实体特征同时进行着色。

82、在Surface Merge(曲面合并)对话框的Primary Quilt(主面组)与Additional Quilt(附加面

组)中设置的曲面有何差异(把两者指定的曲面对换,对计算结果有何影响)?

执行Merge命令,以曲面A为Primary Quilt(主面组)、曲面B为Additional Quilt(附加面组),接合后产生接合曲面C。以鼠标直接点选曲面A区域,将可选取到曲面A;点选曲面B区域,则会选取到所产生的接合曲面C,所以执行Redefine、Delete或Suppress命令点选Primary Quilt(主面组),用户将

可直接编辑该曲面;点选Additional Quilt(附加面组)区域,便会对产生的Merge曲面是进行编辑。83、在构建Boundary Surface(边界曲面)时,如何控制产生破碎的小面(Twin Edge定义的小

面)?

1、利用自边界中的Control Points(控制点)功能,指定相接的对应点可控制产生的小面。(两边界对应

点数目不同时,可加设基准点来控制)

2、修改定义边界的图素以增加Twin Edge(小曲面)间距,减少小碎面。

3、尽量使用云形线代替多条圆弧相接的图素定义边界。

4、利用合成曲线取代投影曲线定义边界曲面的边界。

84、破碎小面对特征构建的何影响?

定义不当的边界,对以后构建的特征将带来许多不良的影响,除了定义不佳外,甚至使这些特征无法构建。不容易构建圆角、薄板伸出项、Shell(壳)、倒角等特征。

85、在构建Boundary Surface(边界曲面时),为何无法在Surface:blended对话框中通过Bndry

Conds(定义/改变边界条件)选项设置边界与曲面相接?

两相接的曲面边界必须已存在相切的定义。

86、在构建Boundary Surface(边界曲面时),如何使用Surface:blended对话框中的Bndry

Inflnc(定义/改变边界影响条件)选项?

通过Bndry Inflnc选项可以利用SideCrvInflnc(侧边曲线影响)选项设置边界相接情况。边界会自动顺接。

87、曲面陷入实体内,不容易着色观察,对此有何见议?

1、执行Feature>Create>Surface>Transform点选曲面,再依不同选项设置它的位移方向与偏移距离,使

超出实体范围达到容易着色观察的目的。

2、执行Simplfd Rep(简化表示)>Create(创建)建立新的简化模式,Attributes(属性)选项设置为Exclude

Features(排除特征),Feature选项以Include(包含)方式选取要查看的曲面,系统只会显示有关的基准曲线与该曲面。其他特征均不显示。

88、如何查询选取的曲面组是以哪种形式(C0、C1、C2)作连续性相接?

选取下拉式菜单Analysis(分析)>Curve Analysis(曲线分析),在Curve Analysis(曲线分析)对话框中以Dihedral Angle(两面角),显示角度为0,则代表相邻的曲面以C1或C2作连续相接。以Curvature(曲率)选项选取查询的曲面边界(可同时选取多条连接的边界),系统会显示青色的曲率向量曲线。当该曲线相连接时,代表这些曲面作C2连续;若向量曲线不连续(但相连接),则代表作C1连续,两曲面相切;若向量曲线不连续(也不相连接),则代表作C0连续,两曲面只相接但不相切。

89、装配的组件可能会以两种方式进行组装,但设置的装配条件可能会有所冲突(Invalid

Constraints),如何使代表不同组装方式的装配条件同时存在?

在实际的产品装配中常会设计活动的组件,例如相机的镜头伸缩,电池盖等;以电池盖为例,可先设置关闭状态的装配条件,然后在Component Placement(元件放置)对话框不要勾选它们,再次针对打开状态设置另一组的装配条件,即可。

90、如何检测组件与组件之间是否有干涉存在?

执行Analysis(分析)>Model Analysis(模型分析)切换至Pair Clearance(对间隙)对话框,用户可通过From 与To字段设置Part,点选指定的零件进行干涉检测。此方式只可对两个零件进行干涉检查。若两零件并没有干涉,系统会显示它们的最小间距。若有干涉,在结果栏中会有显示。

91、如何让系统检测整个装配的所有零件之间是否有干涉存在?

执行Analysis(分析)>Model Analysis(模型分析)切换至Global Interference(全局干涉检查)对话框,在Setup(设定)字段勾选Part Only(仅零件)选项,按Compute(或中键),便能针对整个装配的所有零件检查干涉。若有干涉存在,干涉的零件名称会显示在Result(结果)字段。在绘图区将以红色显示干涉的部位。如果要检测次装配与次装配之间是否有干涉存在,可在Setup(设置)字段勾选Sub-assemblies only(仅子组件)选项并按Compute(或中键),即可。如果要检测整个装配的所有零件与曲面之间是否有干涉存

在,可在Setup(设置)字段勾选Part Only(仅零件)选项、Quilts(面组)字段勾选Include(包含)并按Compute(或中键),即可。

92、为何在一工程图中打开工程图配置文件(*.dtl),设置Projection_type参数为Third_angle

以第三角法投影,但打开的新图以Template的A4-drawing为底图后,系统自动投影的视图为第一角法?

设置的参数只对所属的工程图有所作用,因此在该工程图设置Projection_type参数,只确保它所建立的视图会以第三角法投影。若希望以Template的A4-drawing为底图,你必须打开它,设置Projection_type参数为Third_angle,然后再保存(A4-drawing),下次参考它为底图时,所建立的视图将以第三角法投影。

93、如何使用Drawing_setup_file参数?

在Config.pro文件中,可设置Drawing_setup_file参数并通过Browse图标选取指定的加载的工程图配置文件。此参数只适合不参考任何底图(Template的样品文件)打开新工程图时使用。只要打开新工程图,在New对话框不要勾选“Use default template”,进入New Drawing对话框以Empty(空)选项打开新图,便可加载指定的工程图配置文件。

94、在Template的A4_drawing中,如何编辑代表3个视图的Symbol图标符号?

打开Template的A4_drawing工程图,执行下拉菜单Format(格式)>Symbol Gallery(符号库)>Redefine (重定义)命令点选要改变的视图,系统显示SYM_EDIT_RIGHT_VIEW窗口,用户可利用Sketch 下拉菜单绘制图素或以SYMBOL EDIT(符号编辑)菜单的Tools(工具)编辑图素。

95、如何给3个视图加设视图名称?

在Config.pro中设置Make_project_view_notes参数以Yes响应,便可显示视图名称,系统会以默认的名称定义。若需要,可执行Modify、Move命令修改、移动视图名称,或以Delete删除。此参数只对设置后才建立的视图有效。

96、当视图相当密集时,如何显示它的选取范围,使移动它的时候不会选到其他视图?

用Query Select(查询选取)方式抓取父视图,或者执行Views(菜单管理器中的视图)>Dwg Models(绘图模型)>Model Disp(模型显示)>Hilite Cur(加亮显示),使目前所有视图显示有效的选取范围,系统会以紫色方框显示。

97、移动子视图时,只可依父视图方向拖拽,是否可以把这种对齐的设置解除?

执行Views(菜单管理器中的视图)>Modify View(修改视图)>Alignment(对齐)>Unalign View(撤消对齐)点选要自由拖拽的视图后,便能解除与父视图的对齐关系。若要重新对齐,可选取Align View(对齐视图)命令,点选要恢复对齐关系的子视图。

98、移动视图是要到Drawing菜单选取Views>Move View命令才可,为何不能直接以Move

命令操作?

在2001版中,此方面已做改进,若用i2版,只要在Config.pro文件中设置allow_move_view_with_move 参数响应值为Yes,便可直接移动。

99、可否调整局部视图显示的边框线形?

工程图配置文件(*.dtl)的Detail_circle_line_style参数可以设置局部视图边框的线形,默认值为Solidfont,建议值为phantomfont(假想线线形)。若需要,可以No为detail_view_circle参数的响应值,直接控制不要显示局部视图的边框。

100、在打开大型装配的工程图时,哪些功能可帮助节省等待力文件加载的时间?

一般打开工程图文件时,系统都会把所参考的图文件同时加载到内存中,所以会耗费相当多的时间。

在此情况下,用户可以在保存工程图时,勾选Environment(功能>环境)对话框中的Save Display(保存显示)选项,系统便会把图素与尺寸同时保存。打开工程图时,在File Open(文件打开)对话框中勾选“Retrieve Drawing as View Only(检索绘图仅作为视图)”,表示只单独打开工程图。以此打开的工程图时间最短,但无法编辑。利用Save Display(保存显示)方式保存的工程图文件容量会较多,也就是说

以硬盘空间换取打开工程图的时间。

101、在工程图中怎样将尺寸直接标示在等角视图中?

可使用工程图配置文件(*.dtl)中的Allow_3d_dimension参数,以Yes为响应值。

102、标示角度尺寸时,所呈现的标示方式并不是想要的,要如何修改?

可使用工程图配置文件(*.dtl)中的Angdim_text_orientation参数。呈现方式如下:Horizontal、Horizontal Outside、Parallel Outside、Parallel Above。另外,也可使用Draw_angle_units参数控制角度单位表示方式,响应值为:ang_deg(度)、ang_min(分)、ang_sec(秒)。

103、工程图中如何调整尺寸对齐方式?

可使用工程图配置文件(*.dtl)中的Text_orientation参数,响应值为:Parallel、Horizontal;此参数的不同响应值将影响Parallel_dim_placement与Dim_text_gap等参数作用与否,故要小心使用。104、如何控制引线是否显示?

可使用工程图配置文件(*.dtl)中的Default_dim_elbows参数,可控制是否显示引线。若该尺寸没有引线,便不受此参数影响。建议值为Yes。

105、工程图中哪一个参数可以修正引线长度?

Leader_elbow_length:设置引线距离,此参数只对设置后的引线尺寸标注有效。建议值为3。106、工程图中哪一个参数可以修正引线尾端长度?

可使用工程图配置文件(*.dtl)中的Dim_text_gap参数调整水平形式的引线尾端长度,但只有Text_orientation参数响应值为horizontal、parallel_diam_horiz与iso_parallel_diam_horiz的才可作用。107、希望标注尺寸时,尺寸值能显示在尺寸线下,Pro/E有此功能吗?

可使用工程图配置文件(*.dtl)中的Parallel_dim_placement参数,控制尺寸在尺寸线之上或之下,响应值分别为Above与Below。值得注意的是,Text_orientation参数响应值必须为Parallel时才可作用,而且不支持以两种单位方式标注的尺寸形式。

108、如何调整延伸线相关长度值?

可使用工程图配置文件(*.dtl)中的Witness_line_offset参数,可控制延伸线的原点偏移量;

Witness_line_delta参数则可调整延伸线的端点偏移量。

109、如何产生以Slot定义的圆孔的十字中心,并调整其长度大小?

在Show/Erase对话框中以Axis图标点选圆孔特征,便可在所有相关的投影视图中同时产生中心轴,正视图的轴心将以十字中心线显示,侧视图则以中心线显示。若要调整十字中心端点超越边界偏移量,可以数字输入方式控制工程图配置文件(*.dtl)中听Circle_axis_offset参数。当要个别调整其偏移量时,只要以左键点选十字中心线再抓取格点拖拽便可。若要调整中心端点超越边界偏移量,可使用axis_line_offset参数,以数字输入方式控制。当要个别调整其偏移量时,只要以左键点选中心线再抓取格点拖拽便可。

110、视图所示的基准点符号太大,要如何修改其大小?

可使用工程图配置文件(*.dtl)中的datum_point_size参数,输入所要的数字控制基准点大小。还可利用datum_point_shape参数以不同的响应值设置基准点的显示形状,它们分别为Cross(十字)、Triangle(三角形)、Circle(圆形)、Dot(实心的点)、Square(矩形)与Default(依Config.pro的参数datum_point_symbol设置形状)。注意的是:Config.pro中的参数datum_point_symbol同样可控制基准点的形状,但与datum_point_size参数相互独立。

111、建立极数组(Polar Array)的Pattern特征后,如何在视图中显示表示数组时所参考的中心圆?

可使用工程图配置文件(*.dtl)中的radial_pattern_axis_circle参数为Yes,便可显示表示数组时所参考的中心圆。

112、如何改变直径尺寸的标注形式?

执行Modify>Any Item,点选直径尺寸,选取Toggle Type切换标注形式。

113、收到国外的工程图时,所示的尺寸小数点符号以逗号显示,要如何修改此符号?

在工程图配置文件设置decimal_marker参数,可以comma显示逗号、period显示“。”号。

114、如何在工程图中设置尺寸为只读模式?

在Config.pro文件中设置Draw_models_read_only参数,以Yes为响应值,系统便只允许用户只可在Part中修改尺寸。若要在工程图中修改尺寸,只要以NO为响应值便可。

115、如何把以mm为单位构建的模型,在工程图中同时显示两种单位的尺寸标注形式?

在工程图配置文件设置Dual_dimensioning参数,可以控制。

116、构建模型的单位为mm,如何以inch为单位标注尺寸以提供厂商图面(可否直接设置Drawing_units参数为inch)?

不可以直接设置,可通过以下步骤:

⑴确认Drawing_units参数仍然是mm,将视为主单位(Primary)。

⑵设置Dual_secondary_units参数为Inch。

⑶再设置Dual_dimensioning参数为Secondary(只显示“次单位”)方式显示尺寸。

117、为何产生的工程图转至AutoCad后,图面会放大?

转换文件前,请先设置Drawing_units参数为mm,使真实长度与模型相同,否则图素将变大。

118、从AUTOCAD转至Pro/E的工程图后,为何其图面会放大?

在AUTOCAD中以mm为单位绘制草图,但Pro/E的工程图单位却是inch,加载的图素将会放大。119、如何设置工程图的公差是否显示?

在工程图配置文件(*.dtl)中设置Tol_display参数,便可控制是否显示公差。

120、如何设置工程图的公差以哪种格式显示?

在Config.pro配置文件设置Tol_mode参数,便可控制公差以哪种格式显示。

121、如何控制公差文字大小?

在工程图配置文件(*.dtl)中设置Tol_text_height_factor,可以尺寸文字高度为比例参考值作高度调整;Tol_text_width_factor可以尺寸文字宽度为比例参考值作宽度调整。另外可通过blank_zero_tolerance参数设置当公差值为零时是否显示。

122、以Limits(显示上下公差)为公差形式构建建特征后,有何方法可快速选取所有尺寸修正以Nominal(显示的没有公差)形式显示公差?

Config.pro的Tol_mode默认值便是Limits,若没有注意此参数设置便构建特征,所有特征尺寸公差皆会以Limits显示。

123、以Plus/minus方式显示的公差,如何设置零的公差值不显示?

在工程图配置文件中设置blank_zero_tolerance参数以Yes为响应值,便能使零的公差值不要显示。

当要再次显示公差值时,点选尺寸,按右键选取Properties,打开Dimension Properties对话框(i2版本方式执行Modify>Dimension或以AnyItem选取尺寸,打开Modify Dimension对话框),在Tolerance字段输入上限或下限的公差值,按OK按钮退出便可完成设置。

124、如何改变模型密度?

1、执行Set Up(设置)>Density(密度),在Message Area中输入所要的密度。

2、执行Set Up(设置)>Material(材料),以Define在定义材质特性文件中定义模型密度或以Edit(编

辑)编辑已成功建立的材质特性文件的密度。

3、第一次执行Analysis>Model Analysis命令,系统要求输入所要的密度。

4、从Relations(关系)利用系统参数mp_density定义密度,其关系式格式为“mp_density=输入的密

度值”。

125、如何证明模型以某一基准面作对称?

执行Analysis>Model Analysis,以One Side Volume(单侧体积)命令点选该基准面,先对某一边的体积进计算,再以“Saved Analysis(保存分析)”功能保存。重复上述操作,再计算另一边的体

积,对比两体积测量结果是否相同。

126、如何检测模型的边界为云形线(Spline)、圆弧、或直线的线型?

执行Analysis>Model Analysis,以Edge Type(边的类型)命令点选查询的边界,Model Analysis对话框会告知对象的线型。

127、如何检测模型表面是否为平面?

1、Analysis(分析)>Surface Analysis(曲面分析)切换至Slop(斜率)对话框,当选取的表面有色

层渐变,代表是规则曲面。只有一种黄色则为平面。

2、Analysis(分析)>Measure Distance(测量),在First Entity切换成Plane(平面)点选检测表面,

若无法选取,代表不是平面。

128、如何使用默认图层(Default Layer)?

1、打开配置文件,在Option中输入def_layer,在Value中浏览选取所要的默认图层,根据所示的

图层名称可以判断它的属性。

2、在Value字段的Layer_round_feat中接着输入Round,此名称(Round)将是默认图层名称,并显

示在图层对话框中。

3、按Add/Change、Apply与Close键,关闭对话框。

4、建立默认图层特征后,打开图层对话框就会有相应的图层显示。

129、