文档库

最新最全的文档下载
当前位置:文档库 > 计算机网络复习题

计算机网络复习题

计算机网络复习题

一、判断正误题

1、非归零编码为英文缩写是NZ。(错对)

2、在10M或100M局域星型网中联网的双绞线一般是8蕊线,实际在工作中它使用了1,

2,3,4号线。(错)

3、关于以太网中逻辑链路控制层(LLC)的规定协议是TCP/IP标准。(错)

4、局域网(LAN)的特点是:便于安装、建网成本低、维护和扩充,它为单位所拥有。

(对)

5、某单位原来已经组建了多个100M速度的Ethernet工作组网络(总数有300台左右

PC),如果计划将这些工作网络通过主干网互连,那么应优选现有技术的100M光纤以太网,作为主干网互连技术。(错)

6、虚拟局域网用软件方式来实现逻辑工作组的划分与管理,其成员可以用交换机端口号

和MAC地址进行定义。(对)

7、两台计算机利用电话线路进行较远距离传输数据信号时必备的设备是ADSL。(错)

8、快速ETHERNET网(100M/S)使用的是802.11协议。(错)

9、若某用户在域名为http://www.wendangku.net/doc/ca6fadd61a37f111f1855b76.html的邮件服务器上申请了一个帐号,帐号名为123,

则该用户的电子邮件地址是123@http://www.wendangku.net/doc/ca6fadd61a37f111f1855b76.html。(错)

10、DNS作用是对把已注册的网络名解析成对应MAC地址。(错)

11、如果IP地址为202.130.191.33,屏蔽码为255.255.192.0,那么网络地址是

202.130.191.0。(错)

12、关于以太网中逻辑链路控制层(LLC)的规定协议是IEEE802.1标准。(错)

13、无分类编址CIDRA的主要作用是:消除了传统的A类、B类和C类地址划分。(对)

14、在网络的各类传输介质中,抗干扰能力最弱的是介质是同轴电缆。(错)

15、奈奎斯特(Nyquist)准则与香农(Shannon)定理从定量的角度描述了频率与速率的

关系。(错)

16、NAT是用来进行物理地址(MAC)转换的,主要是解决MAC与IP不同地址长度问题。(错)

17、路由器按照转发表指出的路由数据报转发给下一个路由器,这种叫作直接交付。(对)

18、在WINDOWS 98/2K/XP操作系统中,上网前要配置上网参数,其中DNS参数是指

动态路由表。(错)

二、填空题

1、工作在MAC层的交换机是【】。(二层交换机)

2、传统的路由器低速、复杂,它常造成【】问题?(堵塞)

3、基带系统的特点在于:带宽有限、衰减大、只能传【】信号。(数字)

4、把计算机的数字0、1信号转变成模拟信号,已便在通讯线上远距离传输,这种变换

过程是【】。(调制)

5、检查本机的IP地址、网卡物理地址、DNS地址、子网掩码地址的命令是【】。

(IPCONFIG/ALL )

6、每个主机的域名与【】地址的关系是一对一关系:( IP )

7、用户在利用客户端邮件应用程序从邮件服务器接收邮件时,通常使用的是SMTP和【】

协议。( POP3 )

8、例如某主机只有一个IP地址,但它必须同时在该机上完成如:WWW、FTP、POP3、SMTP

等服务器配置,则用【】技术(方法)来区分本台机上的不同类型的服务。(端口)9、有一种设备工作在OSI的第二层,并可连接二种不同类型的局域网的设备是【】(网

桥)

10、利用INTERNET上的虛电路(非独占物理线路)作为传输通道来通讯的电话是【】。

( IP电话)

11、电子商务应用系统通常包含【】系统、支付网关系统、业务应用系统和用户

及终端系统。(系统平台)

12、C/S结构模式是对大型主机结构的一次挑战,基中S表示的是【】。(服务(器))

13、典型的以太网交换机允许一部分端口支持10BASE-T,另一部分端口支持

100BASE-T。在采用了【】技术时,交换机端口可以同时支持10Mbps/100Mbps。(自适应)

14、如果IP地址为202.133.151.33,屏蔽码为255.255.224.0,那么网络地址是【】。

( 200.133.128.0 )

15、在Internet中有数以百万计的WWW服务器,如果用户不知道要查找的信息在哪一

台WWW服务器中,最好的办法是使用【】。(搜索)

16、虚拟局域网用软件方式来实现逻辑工作组的划分与管理,其成员可以用交换机端口

号、【】或网络层地址进行定义。( MAC地址)

17、一个功能完备的计算机网络需要制定一套复杂的协议集。对于复杂的计算机网络协

议来说,最好的组织方式是【】结构模型。(层次)

三、问答题

1、IP地址中的各种类别(A、B、C)的地址所拥有的地址数目的比例是怎样的(写出算法)?答

A类地址:2^7*2^24 占50%

B类地址:2^14*2^16 占25%

C类地址:2^21*2^8 占12.5%

2、电话通信和电子邮件通信是使用客户服务器工作方式吗?为什么?

电话通信不是用C/S方式,电子邮件是;

电话是电路交换方式,邮件是分组交换方式;

电话是即时通信方式,它们的内容不存取的,电子邮件则不是这种,邮件必须由发信人先存在服务器上,然后收信人去取;

3、作为中间系统,转发器、网桥、路由器有何区别?

答:

转发器工作在物理层

.网桥或桥接器工作在数据链路层。

.路由器工作在网络层

.网关工作在应用层

4、同步通信和异步通信的区别是什么?

“异步通信”是一种很常用的通信方式。异步通信在发送字符时,所发送的字符之间的时间间隔可以是任意的。当然,接收端必须时刻做好接收的准备(如果接收端主机的电源都没有加上,那么发送端发送字符就没有意义,因为接收端根本无法接收)。发送端可以在任意时刻开始发送字符,因此必须在每一个字符的开始和结束的地方加上标志,即加上开始位和停止位,以便使接收端能够正确地将每一个字符接收下来。异步通信的好处是通信设备简单、便宜,但传输效率较低(因为开始位和停止位的开销所占比例较大)。

“同步通信”的通信双方必须先建立同步,即双方的时钟要调整到同一个频率。收发双方不停地发送和接收连续的同步比特流。但这时还有两种不同的同步方式。一种是使用全网同步,用一个非常精确的主时钟对全网所有结点上的时钟进行同步。另一种是使用准同步,各结点的时钟之间允许有微小的误差,然后采用其他措施实现同步传输。

5、例举三种以上的802.3目前最常见协议?

答:例举3种以上802.3标准目前最常见的协议。

计算机网络复习题

6、为什么计算机进行通信时发送缓存和接收缓存总是需要的?

答:

当计算机的两个进程(在同一台机器中或在两个不同的机器中)进行通信时,如果发送进程将数据直接发送给接收进程,那么这两个动作(一个是发送,另一个是接收)是非常难协调好的。这是因为计算机的动作很快,如果在某一时刻接收进程开始执行接收的动作,但发送进程的发送动作稍微早了一点或稍微晚了一点(在收发双方事先未进行同步的情况下,发送时刻不可能恰好和接收时刻精确地重合),这都会使接收失败。因此,在计算机进程之间的通信过程中,广泛使用缓存。

7、路由表中只给出到目的网络的下一跳路由器的IP地址,然后在下一个路由器的路由表

中再给出再下一跳的路由器的IP地址,最后才能到达目的网络进行直接交付。采用这样的方法有什么好处?

这样做的最大好处就是使得路由选择成为动态的,十分灵活。当IP数据报传送到半途时,若网络的情况发生了变化(如网络拓扑变化或出现了拥塞),那么中途的路由器就可以改变其下一跳路由,从而实现了动态路由选择。

8、网络的子网掩码为255.255.255.252,问该网络能够连接多少台主机?请把算法写出来。答

子网掩码: 255.255.255.248

对应二进制 11111111 11111111 11111111 11111000

主机全为0的有3位,即最多主机组合台数:2^3=8台,但除去全为“0”和全为“1”两种组合,即:8-2=6台,001-110

9、通过普通的电话用户线拨号上网时(使用调制解调器),试问一对用户线可容许多少个

用户同时上网?

这并没有限制。但用户数目越多,则每一个用户的上网速率就越低。

多个用户共同使用一对电话线拨号上网有时是很有用的。例如,一个办公室内只有一对电话用户线可供拨号上因特网,但办公室内有多人在办公,他们都有自己的PC机,而且都想同时使用拨号上网。这时可将所有用户的PC机都用以太网连接起来(当然每一台PC机都必须安装一个以太网卡)。只有一台PC机要特殊些,即需要同时安装以太网卡和拨号上网卡(或使用外置的调制解调器)。这台特殊的PC机通常叫做代理服务器,它通过调制解调器用拨号方式与本地的ISP相连。代理服务器必须安装专门的软件(如Wingate 2.0),同时还要完成一些必要的配置,这样就能使连接在以太网上的各PC机用共享一个调制解调器的方式同时上网。ISP并不知道有多少人共享一个调制解调器。ISP只知道现在是这台代理服务器在使用拨号上网。ISP只分配一个临时的IP地址给此代理服务器暂时使用。

10、从路由选择角度比较虚电路和数据报的特点?

计算机网络复习题

计算机网络复习题

11、SMTP和POP3是互联网中什么协议?它们主要区别是什么?

POP即为PostOfficeProtocol的简称,是一种电子邮局传输协议,而POP3是它的第三个版本,是规定了怎样将个人计算机连接到Internet的邮件服务器和下载电子邮件的电子协议。它是Internet电子邮件的第一个离线协议标准。简单点说,POP3就是一个简单而实用的邮件信息传输协议。

什么是SMTP?

SMTP的全称是“SimpleMailTransferProtocol”,即简单邮件传输协议。它是一组用于从源地址到目的地址传输邮件的规范,通过它来控制邮件的中转方式。SMTP协议属于TCP/IP 协议簇,它帮助每台计算机在发送或中转信件时找到下一个目的地。SMTP服务器就是遵循SMTP协议的发送邮件服务器。

在outlook或foxmail等中需要设置的;

简单来说:

pop3是邮件接收协议

smtp是邮件发送协议

12、IP地址中的前缀和后缀最大的不同是什么?通过何种算法得来?试举一例子;

(1) 前缀是由因特网管理机构进行分配的,而后缀是由分配到前缀的单位自行分配的。

(2) IP数据报的寻址是根据前缀来找目的网络,找到目的网络后再根据后缀找到目的主机。

通过IP地址号秘子网掩码号“AND”

如: 202.115.176.33 255.255.255.240

11001010 01110011 10110000 00100001

AND 11111111 11111111 11111111 11110000

11001010 01110011 10110000 00100000

202 115 176 32

13、为什么计算机进行通信时发送缓存和接收缓存总是需要的?

当计算机的两个进程(在同一台机器中或在两个不同的机器中)进行通信时,如果发送进程将数据直接发送给接收进程,那么这两个动作(一个是发送,另一个是接收)是非常难协调好的。这是因为计算机的动作很快,如果在某一时刻接收进程开始执行接收的动作,但发送进程的发送动作稍微早了一点或稍微晚了一点(在收发双方事先未进行同步的情况下,发送时刻不可能恰好和接收时刻精确地重合),这都会使接收失败。因此,在计算机进程之间的通信过程中,广泛使用缓存。

14 、网络的子网掩码为255.255.255.128,问该网络能够连接多少台主机?请把算法写出

来。

子网掩码: 255.255.255.128

对应二进制 11111111 11111111 11111111 10000000 主机号全为0的有7位,即最多组合:2^7=128台,但除去主机号全为“0”和全为“1”两种组合,即:128-2=126台,主机号从:00000001-11111110

四、解释下列网络名词或对应命令功作用

(交换器和路由器常用命令表)

交换机命令

~~~~~~~~~~

[Quidway]dis cur ;显示当前配置[Quidway]display current-configuration ;显示当前配置[Quidway]display interfaces ;显示接口信息[Quidway]display vlan all ;显示路由信息[Quidway]display version ;显示版本信息

[Quidway]super password ;修改特权用户密码[Quidway]sysname ;交换机命名

[Quidway]interface ethernet 0/1 ;进入接口视图[Quidway]interface vlan x ;进入接口视图

[Quidway-Vlan-interfacex]ip address 10.65.1.1 255.255.0.0 ;配置VLAN的IP地址

[Quidway]ip route-static 0.0.0.0 0.0.0.0 10.65.1.2 ;静态路由=网关[Quidway]rip ;三层交换支持[Quidway]local-user ftp

[Quidway]interface ethernet 0/1 ;进入端口模式[Quidway]int e0/1 ;进入端口模式[Quidway-Ethernet0/1]duplex {half|full|auto} ;配置端口工作状态[Quidway-Ethernet0/1]speed {10|100|auto} ;配置端口工作速率[Quidway-Ethernet0/1]port link-type {trunk|access|hybrid} ;设置端口工作模式[Quidway-Ethernet0/1]port access vlan 3 ;当前端口加入到VLAN [Quidway-Ethernet0/2]port trunk permit vlan {ID|All} ;设trunk允许的VLAN [Quidway-Ethernet0/3]port trunk pvid vlan 3 ;设置trunk端口的PVID [Quidway-Ethernet0/1]undo shutdown ;激活端口

[Quidway-Ethernet0/1]shutdown ;关闭端口

[Quidway-Ethernet0/1]quit ;返回

[Quidway]vlan 3 ;创建VLAN [Quidway-vlan3]port ethernet 0/1 ;在VLAN中增加端口

[Quidway-vlan3]port e0/1 ;简写方式[Quidway-vlan3]port ethernet 0/1 to ethernet 0/4 ;在VLAN中增加端口[Quidway-vlan3]port e0/1 to e0/4 ;简写方式[Quidway]description string ;指定VLAN描述字符[Quidway]description ;删除VLAN描述字符

[Quidway]display vlan [vlan_id] ;查看VLAN设置

[Quidway]link-aggregation e0/1 to e0/4 ingress|both ;端口的聚合[Quidway]undo link-aggregation e0/1|all ; 始端口为通道号

----------------------------------------

路由器命令

~~~~~~~~~~

[Quidway]display version ;显示版本信息[Quidway]display current-configuration ;显示当前配置[Quidway]display interfaces ;显示接口信息[Quidway]display ip route ;显示路由信息

[Quidway]sysname aabbcc ;更改主机名[Quidway]super passwrod 123456 ;设置口令[Quidway]interface serial0 ;进入接口

[Quidway-serial0]ip address ;配置端口IP地址[Quidway-serial0]undo shutdown ;激活端口[Quidway]link-protocol hdlc ;绑定hdlc协议

静态路由:

[Quidway]ip route-static {interface number|nexthop}[value][reject|blackhole]

例如:

[Quidway]ip route-static 129.1.0.0 16 10.0.0.2

[Quidway]ip route-static 129.1.0.0 255.255.0.0 10.0.0.2

[Quidway]ip route-static 129.1.0.0 16 Serial 2

[Quidway]ip route-static 0.0.0.0 0.0.0.0 10.0.0.2

[Quidway]router id A.B.C.D ;配置路由器的ID [Quidway]ospf enable ;启动OSPF协议[Quidway-ospf]import-route direct ;引入直联路由[Quidway-Serial0]ospf enable area ;配置OSPF区域

五、计算题(1题,共10分)

某单位分配到一个B类IP地址,其net-id为129.250.0.0。该单位有4000台机器,平均分布在16个不同的地点。如选用子网掩码为255.255.255.0,试给每一地点分配一个子网号码,

并计算出每个地点主机号码的最小值和最大值。

4000/16=250台

第1个地点子网号:129.250.00010000.00000000 第2个地点子网号:129.250.00100000.00000000 第3个地点子网号:129.250.00110000.00000000 第4个地点子网号:129.250.01000000.00000000 。。。。。。

第14个地点子网号:129.250.11100000.00000000 第15个地点子网号:129.250.11110000.00000000 第16个地点子网号:129.250.10001000.00000000

最小值:129.250.16.0

最大值:129.250.144.0

计算机网络复习题
计算机网络是指将地理位置不同的具有独立功能的多台计算机及其外部设备,通过通信线路连接起来,在网络操作系统,网络管理软件及网络通信协议的管理和协调...
计算机网络复习题
21世纪的一些重要特征是数字化,网络化和信息化。这是一个以网络为核心的信息时代。在该网络中,用户可以快速传输数据文件,并从网络中查找和获取各种有...
计算机网络复习题
计算机网络解析与同步练习:《计算机网络解析与同步练习》作为《计算机网络(第3版)》的教学参考书,结合例解析和同步练习复习相关知识点...
计算机网络复习题
1网络协议的主要内容是。[答:]语法、语义和同步。2大楼里的计算机网络系统。[答...
计算机网络复习题
计算机网络复习题 计算机网络复习题一、填空题 1.从计算机网络系统组成的角度看,...
计算机网络(谢希仁)期末复习题及答案
计算机网络期末复习题及答案 一、选择题 1、传输延迟时间最小的交换方法是( ) ...
计算机网络复习题及答案
计算机网络复习题及参考答案一、单项选择题 1.下列网络中作为我国 Inter...
计算机网络》期末考试复习题
选择题 Most important!!《计算机网络》期末考试复习题 1.国际标...
(完整版)计算机网络复习题及答案
计算机网络复习题及参考答案 一、单项选择题 1.下列网络中作为我国 Inte...
计算机网络基础复习题(含答案)
计算机网络基础复习题(含答案)_计算机硬件及网络_IT/计算机_专业资料。计算机网络复习题 二 填空题 1. IP地址为192. 192. 45. 60,子网掩码为255. 255. 255......
计算机网络复习题(1)带答案
计算机网络复习题(1)带答案_计算机硬件及网络_IT/计算机_专业资料。1. 世...
计算机网络复习题及答案(精华版)
计算机网络复习题及答案(精华版)_计算机硬件及网络_IT/计算机_专业资料。. ...
计算机网络复习题带答案
计算机网络复习题带答 案 Document serial number【KKGB...
计算机网络复习题(含答案)
网络地址(14 位) 主机地址(16 位) C. 10 网络地址(14 位) 主机地址(16 位) D. 110 网络地址(21 位) 主机地址(8 位)第5页 计算机网络复习题 37.......
计算机网络复习题与答案(精华版)
计算机网络复习题与答案(精华版)_计算机硬件及网络_IT/计算机_专业资料。下载...
计算机网络复习题 (全)
计算机网络复习题 (全)_理学_高等教育_教育专区。计算机网络复习题 5、以下说...
最新计算机网络复习题-(全)
最新计算机网络复习题-(全)_计算机硬件及网络_IT/计算机_专业资料。精品文档...
计算机网络复习题(答案详解)
计算机网络复习题第一章 1.计算机网络定义: 凡是利用通信设备和线路按不同的拓扑...
计算机网络复习题(选)
计算机网络复习题(选)_IT认证_资格考试/认证_教育专区。一、选择题 1、 一...
计算机网络期末复习题(含答案)
计算机网络期末复习题(含答案)_工学_高等教育_教育专区。1.HTML 也称(超...
计算机网络复习题.汇总
计算机网络复习题.汇总_IT认证_资格考试/认证_教育专区。一、填空题 1.TC...
计算机网络复习题及答案(精华版)
===精选公文范文,管理类,工作总结类,工作计划类文档,欢迎阅读下载=== 计算机网络复习题及答案(精华版) 《计算机网络》复习题 第一章 概述 一、选择题 1. 以下......
计算机网络复习题及答案
精品文档 《计算机网络复习题及参考答案 一、单项选择题 1.下列网络中作为我国...
计算机网络复习题及答案
不要只是简单的看答案) 做题,达到复习的目的,不要只是简单的看答案) 第一章 概述一,选择题 DACDC DCCCC CCB 二,综合应用题 1,答: 计算机网络的发展过程大致......