文档库

最新最全的文档下载
当前位置:文档库 > 通达信指标公式源码 分时主图 打板 做t 追涨

通达信指标公式源码 分时主图 打板 做t 追涨

通达信指标公式源码 分时主图 打板 做t 追涨

使用说明:

1,加入量比指标,粉色条:量比>5, 兰色条:量比>2.5,

2,macd大家不用教,

3,彩带是分时均线,做t.结合macd,粉进兰出。

4,分时线变桔黄色,涨停可能较大,如左上角三色带全紫,涨幅不大可追!(新手慎为)

5,狮子,红球,金指,均为强势信号,如多指标共振,果断杀入!

指标只做参考,同一只枪,高手弹无虚发,低手可能自伤,祝大家投顺利!

无法导入的用这个去掉了左上角色条

先建一引用公式否则左上角色条不显示

引用公式源码如下

{FSKY 分时K线引用}

今量:VOL;

昨量:REF(VOL,1);

前量:REF(VOL,2);

昨开:REF(O,1);

昨收:REF(C,1);

前开:REF(O,2);

前收:REF(C,2);

源码:

{反转MACD 参数: p, 0, 20, 4;}

{前量:="FSKY.前量#DAY";

昨量:="FSKY.昨量#DAY";

今量:="FSKY.今量#DAY";

前总:=前量;

昨总:=昨量;

总:=今量,NODRAW;

BMM:=MAX(前总,昨总);

AMM:=IF(总/BMM>2,BMM*3,BMM);

MM:=200/AMM;

KP:=DYNAINFO(4);

ZX:=DYNAINFO(7);

A1:=IF(ZX>=KP,355,0);

A2:=IF(ZX>=KP,0,355);

A3:=IF(ZX>=KP,0,0);

DRAWRECTREL(0,80,MM*今量,110,RGB(A1,A2,A3));

昨开:="FSKY.昨开#DAY";

昨收:="FSKY.昨收#DAY";

A4:=IF(昨收>=昨开,355,0);

A5:=IF(昨收>=昨开,0,355);

A6:=IF(昨收>=昨开,0,0);

DRAWRECTREL(0,40,MM*昨量,70,RGB(A4,A5,A6));

前开:="FSKY.前开#DAY";

前收:="FSKY.前收#DAY";

A7:=IF(前收>=前开,355,0);

A8:=IF(前收>=前开,0,355);

A9:=IF(前收>=前开,0,0);

DRAWRECTREL(0,0,MM*前量,30,RGB(A7,A8,A9));}

RC:=DYNAINFO( 3);

量比超2.5:=IF(DYNAINFO(17)>2.5,RC-0.15,DRAWNULL),COLORFF9933;

量比超5:=IF(DYNAINFO(17)>5,RC-0.15,DRAWNULL),COLORBA75FF; DRAWBAND(量比超2.5,RGB(51,153,255),量比超2.5+0.015,RGB(51,153,255)); DRAWBAND(量比超5,RGB(255,118,188),量比超5+0.015,RGB(255,118,188));

{首次起爆}

TT:=BARSCOUNT(C);{取得有效收盘价}

均价黄:SUM(C*V,TT)/SUM(V,TT),LINETHICK1,COLOR00FFE1;{分时均线的取值}

量两步:=MA(V,5)>REF(MA(V,5),1) AND REF(MA(V,5),1)>REF(MA(V,5),2);

价两步:= C>=REF(C,1) AND REF(C,1)>REF(C,2);

价上岗量破5:=C>均价黄AND V>MA(V,5);

量起爆:=V>=REF(V,1)*2 ;

价创新高:=C>=HHV(C,0);

量创新高:=V>=HHV(V,0);

对昨日涨幅:=C/DYNAINFO(3)<=1.02;{涨幅控制2个点以内}

每日一点:=量两步AND 价两步AND 价上岗量破5 AND 量起爆AND 价创新高AND 量创新高AND 对昨日涨幅;

{计算收益、已爆分钟}

VC:=BARSSINCE(每日一点)+1;

首次起爆价:REF(C,VC-1),NODRAW;

今天收益:(DYNAINFO(7)-首次起爆价)/首次起爆价*100,NODRAW;

起爆时间:REF(TIME/10000,VC),NODRAW;

已爆分钟:VC-1,NODRAW;

首次起爆量:=REF(VOL,VC-1);

DRAWICON(已爆分钟>=2,RC-0.1,11);{出现金手指,至少已经确认2分钟了}; {MACD P:1,20,4;}

{RC:=DYNAINFO( 3);}

S2:=SMA(C,2,1);

S6:=SMA(C,6,1);

DK:=2*(S2-S6);

STICKLINE(DK>0,RC,RC+DK,0,1),COLOR0000AA;

STICKLINE(DK<0,RC,RC+DK,0,1),COLOR00AA00;

AP1:=REF(C,P)=HHV(C,2*P+1);

BB1:=FILTER(AP1,P);

CC1:=BACKSET(BB1,P+1);

DD1:=FILTER(CC1,P);{高点}

AP2:=REF(C,P)=LLV(C,2*P+1);

BB2:=FILTER(AP2,P);

CC2:=BACKSET(BB2,P+1);

DD2:=FILTER(CC2,P);{低点}

上:=REF(C,BARSLAST(DD1)),COLORFF00FF,NODRAW;

下:=REF(C,BARSLAST(DD2)),COLOR00FF00,NODRAW;

相对能量:(C-下)/(上-下)*100,COLORYELLOW,NODRAW;

R11:=BACKSET(ISLASTBAR,BARSLAST(DD1)+1);

S11:=R11>REF(R11,1);

压力线:DRAWLINE(DD1,C,S11,C,1),COLOR00FF00;

T11:=BACKSET(ISLASTBAR,BARSLAST(DD2)+1);

U11:=T11>REF(T11,1);

支撑线:DRAWLINE(DD2,C,U11,C,1),COLOR00FFFF;

STICKLINE(C>0,下,下,1,0),COLOR00FF00;

STICKLINE(C>0,上,上,1,0),COLORFF00FF;

DRAWNUMBER(ISLASTBAR,压力线,压力线),COLOR00FF00; DRAWNUMBER(ISLASTBAR,支撑线,支撑线),COLOR00FFFF;

R1:=MA(C,13);

R2:=SMA(R1,5,2);

DRAWBAND(R1,RGB(255,0,125),R2,RGB(0,111,255));

C,LINETHICK2,COLORDDDDDD;

{涨停}

地:=DYNAINFO(11)+(DYNAINFO(11)*0.021);

涨停:IF(DYNAINFO(7)>地,1,0),NODRAW,COLOR0088FF;

涨:=IF(涨停=1,C+0.0075,DRAWNULL),COLOR8000FF,LINETHICK2; DRAWBAND(涨,RGB(255,211,0),C-0.0075,RGB(255,125,0));

时间:=TIME=100000;

N:=BARSLAST(时间);

常数:=CONST(IF(N=0,C,REF(C,N))),COLORGREEN,DOTLINE;

CS1:=CONST(IF(N,HHV(H,0),REF(HHV(H,0),N)));

CS2:=CONST(IF(N,LLV(L,0),REF(LLV(L,0),N)));

STICKLINE(时间=1,CS1,CS2,1.2,0),COLOR008888;

均价A:=SUM(V*C,0)/SUM(V,0),COLORYELLOW;

{CONST(IF(时间,HHV(H,0),REF(HHV(H,0),N))),COLOR000066,DOTLINE; CONST(IF(时间,LLV(L,0),REF(LLV(L,0),N))),COLOR006600,DOTLINE; CONST(IF(N,LLV(L,1),REF(LLV(L,0),N))),COLOR888888;

CONST(IF(N,HHV(L,1),REF(HHV(L,0),N))),COLOR888888;}

{涨停2}

AA:=BARSLAST(TIME=103000);

CC:=REF(HHV(C,0),AA+1);

VV:=REF(HHV(V,0),AA+1);

ZF:=CC/DYNAINFO(3)<1.05;

涨停2:=CROSS(C,CC) AND V>VV AND ZF,COLOR0000FF;

DRAWICON(涨停2,RC-0.06,13);

{开量冲板}

资金:=C*IF(PERIOD=0 AND MINUTE=31,VOL,0),COLORSTICK,NODRAW;{√}冲板线:=(CAPITAL/100)*1/20,COLORCYAN,LINETHICK1,NODRAW;

单量必板线:=资金>1000;{分时图单量超1000万资金};

单量冲板线:=资金>冲板线AND 资金<1000;{分时图单量超500万资金}; DRAWICON(单量必板线AND

DYNAINFO(4)/DYNAINFO(3)>1.01,RC+0.03,31);{1000万处画仙人指} DRAWICON(单量冲板线AND

DYNAINFO(4)/DYNAINFO(3)>1.01,RC-0.03,23);{500万处画十字星,以示警戒};